WENN / UND / ODER

Bild

Betrifft: WENN / UND / ODER
von: Friedrich
Geschrieben am: 13.11.2003 17:32:18

Hallo ich versuche eine lange Formel zu verkürzen.
Habe jedoch etwas Probleme damit.

Folgendes:

Wenn in C9 "A", "D", "U" oder "K" steht und gleichzeitig entweder D9 oder E9
leer sind dann ist 8:12 einzutragen, sind D9 und E9 beide mit Zeiten belegt,
ist die Differenz zwischen E9 und D9 zu berechnen.

mfG Friedrich

Bild


Betrifft: AW: WENN / UND / ODER
von: th.heinrich
Geschrieben am: 13.11.2003 17:39:05

hi Friedrich,

wie sieht die FORMEL momentan aus ?

gruss thomas


Bild


Betrifft: AW: WENN / UND / ODER
von: AndreasG
Geschrieben am: 13.11.2003 17:43:52

Hallo Friedrich

=Wenn(und(oder(c9="A";C9="D";C9="U";c9="K"));oder(D9="";E9="");"8:12";wenn(und(d9<>"";E9<>"");E9-D9;""))

ungetestet, sollte aber funzen

Grüße

Andreas


Bild


Betrifft: AW: WENN / UND / ODER
von: Friedrich
Geschrieben am: 13.11.2003 17:47:46

Danke Andreas,
werd's probieren.


Bild


Betrifft: AW: WENN / UND / ODER
von: Friedrich
Geschrieben am: 13.11.2003 17:45:02

Geht doch sicher kürzer,

das "U" habe ich noch nicht drin!

=WENN(UND(C10="D";D10="");Regel;WENN(UND(C10="D";E10="");Regel;WENN(UND(C10="K";D10="");Regel;WENN(UND(C10="K";E10="");Regel;WENN(UND(C10="A";D10="");Regel;WENN(UND(C10="A";E10="");Regel;WENN(E10="";0;WENN(D10="";0;E10-D10))))))))


Bild


Betrifft: Geht nicht !
von: Friedrich
Geschrieben am: 13.11.2003 17:54:30

Andreas,

geht so nicht, es fehlen anscheinend Argumente ?


Bild


Betrifft: AW: WENN ADUK -> 8:12 ...
von: FP
Geschrieben am: 13.11.2003 19:38:23

Hallo Friedrich,

meinst Du das etwas so?

Excel Jeanie HTML
Formeln der Tabelle
F2 : =WENN(SUCHEN(C2;"ADUK")*ZÄHLENWENN(D2:E2;"");"8:12";E2-D2)+0
F3 : =WENN(SUCHEN(C3;"ADUK")*ZÄHLENWENN(D3:E3;"");"8:12";E3-D3)+0
F4 : =WENN(SUCHEN(C4;"ADUK")*ZÄHLENWENN(D4:E4;"");"8:12";E4-D4)+0
F5 : =WENN(SUCHEN(C5;"ADUK")*ZÄHLENWENN(D5:E5;"");"8:12";E5-D5)+0
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download   Servus aus dem Salzkammergut Franz

Bild


Betrifft: Franz, kleiner Fehler
von: Friedrich
Geschrieben am: 13.11.2003 20:04:43

Hallo Franz,

wenn C D E leer keine Null in F

Friedrich


Bild


Betrifft: AW: davon war aber auch keine Rede ;-)
von: FP
Geschrieben am: 13.11.2003 20:38:27

Hallo Friedrich,

... aber bitte sehr:

Excel Jeanie HTML
Formeln der Tabelle
F2 : =WENN((C2<>"")*SUCHEN(C2;"ADUK")*ZÄHLENWENN(D2:E2;"");"8:12";(E2<D2)+E2-D2)+0
F3 : =WENN((C3<>"")*SUCHEN(C3;"ADUK")*ZÄHLENWENN(D3:E3;"");"8:12";(E3<D3)+E3-D3)+0
F4 : =WENN((C4<>"")*SUCHEN(C4;"ADUK")*ZÄHLENWENN(D4:E4;"");"8:12";(E4<D4)+E4-D4)+0
F5 : =WENN((C5<>"")*SUCHEN(C5;"ADUK")*ZÄHLENWENN(D5:E5;"");"8:12";(E5<D5)+E5-D5)+0
F6 : =WENN((C6<>"")*SUCHEN(C6;"ADUK")*ZÄHLENWENN(D6:E6;"");"8:12";(E6<D6)+E6-D6)+0
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  
Servus aus dem Salzkammergut Franz

Bild


Betrifft: Vielen Dank
von: Friedrich
Geschrieben am: 16.11.2003 08:19:16

Ich danke Dir für deine prompte Hilfe.

Gibt es eine Seite auf der man die Formelverkürzungen durch Produkte sehen kann.
Wie ich festgestellt habe, ist dadurch eine enorme Verkürzung der Funktionen möglich.
Wann wird eine Matrixformel eingesetzt?

mfG Friedrich


Bild


Betrifft: Ich nerve ungerne
von: Friedrich
Geschrieben am: 16.11.2003 11:56:57

Hallo,

geht gut. Habe aber noch ein kleines Problem entdeckt. Wenn in C kein Buchstabe eingegeben werden soll, müßte das Ergebnis solange Null sein, bis D und E gefüllt sind.

C leer D 6:00 E leer 0:00
C leer D leer E 13:00 0:00
C leer D 6:00 E 13:00 7:00

ist das möglich

im Voraus besten Dank

Friedrich


Bild


Betrifft: Das scheint's zu sein
von: Friedrich
Geschrieben am: 13.11.2003 19:55:37

Danke FP


Bild

Beiträge aus den Excel-Beispielen zum Thema " Einen Summenwert, durch Excel berechnen (schwer)"