Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema MsgBox
BildScreenshot zu MsgBox MsgBox-Seite mit Beispielarbeitsmappe aufrufen

zählen...wieder.:)

Betrifft: zählen...wieder.:)
von: emin
Geschrieben am: 15.04.2003 - 15:35:01

hallo alle,
hier unten füge ich ein Beispiel ein.Damit ich besser erklären kann.ich möchte alle 8.(in Spalte A) zählen, wenn jede 8 (Spalte C )zwischen 660 und 670 und wenn (Splate D) E0 trifft. Also es gibt zwei Kriterium. Mit einem Kriterium kann ich aber zweite habe ich nicht geschaft.

grüß

emin


Tabelle1
 ABCD
151,0138650,1R
251,0131649,5R
361,0183662,9R
461,0209663,4R
571,0379647,2R
671,0371647,5R
781,0563675,6R
881,0583673,9R
991,0631678,6R
1091,0626679,1R
1151,0172644,0E0
1261,0211644,0E0
1361,0260641,3E0
1471,0420676,4E0
1571,0454659,0E0
1681,0593673,8E0
1781,0683670,5E0
1881,0683660,3E0
1981,0729658,1E0
Excel Tabellen einfach im Web darstellen   Excel Jeanie HTML  2.0    Download  

  

Re: zählen...wieder.:)
von: moe
Geschrieben am: 15.04.2003 - 15:44:43

Hier ein Lösungsvorschlag

Gruss
Moe
Sag bescheid ob es funktioniert

Sub Vergleich()


Dim i As Integer
i = 0
Range("A1").Select
Range(Selection, Selection.End(xlDown)).Select
For Each cell In Selection

If cell.Value = 8 And cell.Offset(0, 2).Value > 660 And cell.Offset(0, 2).Value < 670 And cell.Offset(0, 3).Value = "E0" Then
i = i + 1
cell.Interior.ColorIndex = 3
End If
Next cell
MsgBox i
End Sub

  

Klassisches SUMMENPRODUKT
von: Boris
Geschrieben am: 15.04.2003 - 15:47:23

Hi Emin,

=SUMMENPRODUKT((A1:A19=8)*(C1:C19>=660)*(C1:C19<=670)*(D1:D19="E0"))

Die Suchwerte kannst du natürlich auch in Zellen schreiben und darauf referenzieren.

Gruß Boris