Microsoft Excel

Herbers Excel/VBA-Archiv

Formelhilfe

    Betrifft: Formelhilfe von: mike
    Geschrieben am: 27.08.2003 08:38:47

    Hallo zusammen,
    habe eine Formel gebastelt, die aber nicht funktioniert:
    =WENN(B6="10:30";"frei";"")
    Ich möchte im Prinzip erreichen, dass in der Zelle nur dann "frei" steht, wenn in B1 "10:30" steht. Ansonsten soll sie leer sein. Mit der Uhrzeit "10:30" in B1 wird nicht gerechnet. Was habe ich falsch gemacht?

    Gruß
    Mike

      


    Betrifft: =WENN(B6=("10:30")*1;"frei";"") oT von: Boris
    Geschrieben am: 27.08.2003 08:41:40




      


    Betrifft: AW: Formelhilfe von: Harald Kapp
    Geschrieben am: 27.08.2003 08:46:57

    Hallo Mike,
    mit "10:30" vergleichst Du nur einen Textstring. In der Zelle B6 steht aber eine Zahl, die lediglich als 10:30 angezeigt wird.

    Du hast zwei Möglichkeiten:
    =WENN(B6=0,4375;"frei";"") Da 10:30 = 0,4375*24h (Zeiten werden als Bruchteile eines 25h Tages gespeichert.
    =WENN(B6=ZEITWERT("10:30");"frei";"") Das ist übersichtlicher.

    Gruß Harald


      


    Betrifft: Danke euch beiden. Funktioniert. von: mike
    Geschrieben am: 27.08.2003 08:58:28

    .