Tabelle vergleichen

Bild

Betrifft: Tabelle vergleichen
von: Frank
Geschrieben am: 28.11.2003 10:01:06

Hallo,

mein Problem ist folgendes, jeden Monat bekommt meine Firma eine Excel Tabelle mit Daten von Vertrieblern (TabelleA), diese TabelleA wird mit einer, schon vorhandenen, Tabelle mit Stammdaten (TabelleB) verglichen. Bsp.:

Eingangstabelle-TabelleA.....................Stammdatentabelle-TabelleB
.Spalte.A.|.Spalte.B........................Spalte.A.|.Spalte.B.|.Spalte.C
....01........10€..............................01.........5..........7
....01........24€..............................02.........4..........6
....01.........8€..............................03.........4 .........6
....02........11€
....02........78€
....03.......120€

Aus diesem Vergleich entsteht die Endstandtabelle (TabelleC). In dieser Tabelle werden nach Spalte A zwei neue Spalten eingefügt (schon gelöst per Makro) und diese mit den Daten aus Tabelle B gefüllt (Spalte B/C). außerdem werden die gesamten Kosten für die jeweiligen Nummern zusammengerechnet. Das sollte dann so aussehen:
Endstandstabelle-TabelleC
.Spalte.A.|.Spalte.B.|.Spalte.C.|.Spalte.D
.01.Total......5...........7........42€
.02.Total......4...........6........89€
.03.Total......4...........6.......120€
Dieses Problem muss dringend gelöst werden, ich wäre euch sehr zu Dank verpflichtet wenn sich der Sache jemand annehmen würde.
MfG
Frank

Bild


Betrifft: AW: Tabelle vergleichen
von: Thorsten
Geschrieben am: 28.11.2003 10:39:31

Hi Frank,

anhand deiner Beispiel- Tabellen verstehe ich nicht so ganz, wofür du da ein Makro brauchst. Das Problem lässt sich, so wie ich es verstehe, mit der Formel SummeWenn lösen. Heißt folglich, du kopierst die Tabelle2 als eine neue Tabelle und fügst in die Spalte D die Formeln ein. In deinem Beispiel würde dann in D1 zum Bsp stehen:
=SUMMEWENN(A1:B6;A1;B1:B6)
wobei A1:B6 der ganze Bereich ist (Firmenname und Betrag)
und A1 dem Kriterium entspricht
und B1:B6 der Bereich ist, aus dem summiert werden soll.

MFG T.


Bild


Betrifft: AW: Tabelle vergleichen
von: Frank
Geschrieben am: 28.11.2003 10:51:52

mmh das versteh ich nich ?
diese 3 tabellen sind eigene .xls dateien
also nicht in einer gesamten datei.


Bild


Betrifft: AW: Tabelle vergleichen
von: Thorsten
Geschrieben am: 28.11.2003 11:05:01

Auch da sehe ich nicht das Problem.

Die Formel kann ja den Pfad der Datei enthalten, zum Beispiel
=SUMMEWENN([Mappe1.xls]Tabelle1!$A$1:$B$6;[Mappe1.xls]Tabelle1!$A$1;[Mappe1.xls]Tabelle1!$B$1:$B$6)
Wobei in[] der Name bzw. Pfad der Datei steht.


Bild


Betrifft: AW: Tabelle vergleichen
von: Frank
Geschrieben am: 28.11.2003 11:11:01

ahh vielen dank und könntest du mir das noch genauer mit dem !$A$... erklären


Bild


Betrifft: AW: Tabelle vergleichen
von: Thorsten
Geschrieben am: 28.11.2003 11:22:55

Hi,

nun, das !$A$1 steht für die Zelle:

a) ! stellt den Bezug her (soweit ich weiß)

b) mit dem ersten $ wird die Spalte fixiert, das heißt,wenn du die Formel nach unten kopierst oder nach recht, bleibt dieser Wert (also der Spaltnename) konstant

c) Das geiche bewirkt das $ vor der 1, das fixiert deine Zeilenzahl.

Beispiel: du hast die Formel in der Zelle stehen und kopierst die nach unten, dann steht dann auch in der nöchsten Zeile der Wert aus A1.

hoffe, dass ist verständlich....

oder als Beispiel...

du schreibst in die Zelle b1 die Formel =a1
würdest du die dann kopieren und in b2 einfügen, würde dort dann nicht =a1 stehen sondern =a2...
schreibst du allerdings =a$1 dann beibt auch beim einfügen in b2 der Wert aus a1 stehen


Bild


Betrifft: AW: Tabelle vergleichen
von: Frank
Geschrieben am: 28.11.2003 11:35:12

ahja vielen dank :)


Bild

Beiträge aus den Excel-Beispielen zum Thema " Tabelle vergleichen"