Viele Werte summieren, aber jeden einzelnen runden

Bild

Betrifft: Viele Werte summieren, aber jeden einzelnen runden
von: Christian
Geschrieben am: 03.12.2003 15:11:12

Hallo,
ich habe ein grosses Problem.
Ich habe viele Werte in Spalte A und möchte diese Werte in einer Zelle (z.B B1) mit 0,8 auf 0 Stellen gerundet multiplizieren und dann summieren. Ich will jetzt allerdings nicht jede einzelne Zelle mit 0,8 multiplizieren und dann zusammenzählen. Das gibt sonst eine Riesenformel. Wenn ich aber zuerst zusammenzähle und dann multipliziere und runde, bekomme ich Rundungsdifferenzen.

Beispiel:
A1 = 254 Formel in B1 =runden(A1*0,8;0) ergibt 203
A2 = 113 Formel in B2 =runden(A2*0,8;0) ergibt 90 macht zusammen 293

Aber: mit Formel =runden((A1+B1)*0,8;0) ergibt 294 was aber falsch ist

Je mehr Werte ich habe desto größer wird die Differenz
Kann ich dass per Formel machen oder muss es per VBA sein. Wie kann ich das lösen.

Vielen Vielen Dank für die Hilfe
Chris

Bild


Betrifft: AW: Viele Werte summieren, aber jeden einzelnen runden
von: Mac4
Geschrieben am: 03.12.2003 15:22:48

Hallo Christian,

schau mal, ob Du hiermit weiterkommst:

=SUMMENPRODUKT((RUNDEN(A1:A200*0,8;0)*1))

Marc


Bild

Beiträge aus den Excel-Beispielen zum Thema " Viele Werte summieren, aber jeden einzelnen runden"