Microsoft Excel

Herbers Excel/VBA-Archiv

Zwischensummen getrennt in positiv und negativ

Betrifft: Zwischensummen getrennt in positiv und negativ von: Martin
Geschrieben am: 19.08.2004 12:31:18

Hallo Leute,

habe ein Problem, dass mich schon viel Hirnschmalz gekostet hat. Möchte gerne abhängig von einer Kriterienspalte fortlaufend Zwischensummen bilden, wobei getrennt werden soll in positive und negative Zwischensummen. Für eine effiziente Möglichkeit bin ich euch sehr sehr dankbar.

Gruß
Martin
https://www.herber.de/bbs/user/9804.xls

  


Betrifft: AW: Zwischensummen getrennt in positiv und negativ von: th0mas
Geschrieben am: 19.08.2004 12:37:55

Hi!
Probiers so: Schreib in die positive Spalte diese formel:
=IF($C4>0;$C4;"")
und in die negative diese:
=IF($C4<0;$C4;"")

lg, thomas


  


Betrifft: AW: Zwischensummen getrennt in positiv und negativ von: Martin
Geschrieben am: 19.08.2004 12:42:53

Hallo thomas,

dein vorschlag, liefert leider nicht das gewünschte Resultat. Ich glaube es ist schwieriger.

Gruß
Martin


  


Betrifft: AW: Zwischensummen getrennt in positiv und negativ von: th0mas
Geschrieben am: 19.08.2004 12:48:18

hmm, dann weiss ich nicht genau was du machen willst. Vl kannst du es noch ausführlicher erklären. Grundsätzlich kannst du aber deine 2 spalten lassen und mit 2 verschiedenen Formeln (eine prüft auf positiv ab, eine auf negativ) deine ergebnisse aufsplitten. Falls du dann die Gesamtsumme oder so brauchst, musst du natürlich beide Spalten markieren.


  


Betrifft: AW: Zwischensummen getrennt in positiv und negativ von: HermannZ
Geschrieben am: 19.08.2004 15:01:26

Hallo Martin,

Wenn ich das richtig verstanden habe meintest du das so??

https://www.herber.de/bbs/user/9814.xls

Gruß hermann


  


Betrifft: AW: Zwischensummen getrennt in positiv und negativ von: Martin
Geschrieben am: 19.08.2004 17:08:17

Hallo hermann,

erstmal danke für Deine Antwort, aber damit ist das Problem leider noch nicht gelöst. Habe meine Frage wohl nicht deutlich formuliert. Zudem habe ich in dem geposteten Sheet selbst einen Fehler gemacht.

Was ich gerne möchte ist in den grau hinterlegten Spalten zu sehen. Immer wenn sich das Kriterium ändert will ich wissen, ob die Summe der Werte, die unter dieses Kriterium fallen positiv ist oder negativ. Wenn ich das weiß, soll die für ein Kriterium sich aufbauende Summe in die pos Spalte oder in die neg Spalte geschrieben werden.

https://www.herber.de/bbs/user/9822.xls

Dank für Eure Hilfe.

Gruß
Martin


  


Betrifft: AW: Zwischensummen getrennt in positiv und negativ von: HermannZ
Geschrieben am: 19.08.2004 17:40:54

Hallo Martin,

Wenn dem so ist dann in F4 =WENN(E10>0;B4;"")
in F5 =WENN($E$10>0;F4+B5;"") herunterkopieren bis F10
in G4 =WENN(E10<0;B4;"")
in G5 =WENN($E$10<0;G4+B5;"") herunterkopieren bis G10

Gruß Hermann


  


Betrifft: AW: Zwischensummen getrennt in positiv und negativ von: Martin
Geschrieben am: 19.08.2004 18:05:50

Hallo Hermann,

das Problem ist immer noch nicht gelöst. Da ich tatsächlich sehr viele Kriterien habe (von 1 bis 1000) würde Dein Vorschlag sehr viel manuelle Arbeit bedeuten. Gibt es keine effizientere Möglichkeit? Vielleicht drei Formeln für E4, F4, G4 die einfach bis zum Ende runter kopiert werden können?

Gruß
Martin


  


Betrifft: AW: Frage ? von: HermannZ
Geschrieben am: 19.08.2004 18:30:03

Hallo Martin,

Frage ist die berechnung denn nach den von mir angegeben Formeln richtig??

Gruß hermann


  


Betrifft: AW: Zwischensummen getrennt in positiv und negativ von: Roland Hochhäuser
Geschrieben am: 19.08.2004 19:07:13

Hallo Martin,

wenn es auch ein VBA-Ansatz sein darf: folgenden Code in ein Modul und von Tabelle1 aus starten:
Sub sortieren()
Dim i As Long, j As Long, dblSumme As Double
Application.ScreenUpdating = False
Range("B4:C" & Range("C65536").End(xlUp).Row).Select
Selection.Sort Key1:=Range("C4"), Order1:=xlAscending
    For i = 4 To Range("C65536").End(xlUp).Row
        dblSumme = 0
        j = 0
            Do
                dblSumme = dblSumme + Range("B" & i + j).Value
                Range("E" & i + j).Value = dblSumme
                j = j + 1
            Loop While Range("C" & i + j).Value = Range("C" & i + j + 1).Value
        dblSumme = dblSumme + Range("B" & i + j).Value
        Range("E" & i + j).Value = dblSumme
            If dblSumme >= 0 Then
                Range("F" & i, Range("F" & i + j)).Value = Range("E" & i, Range("E" & i + j)).Value
            Else
                Range("G" & i, Range("G" & i + j)).Value = Range("E" & i, Range("E" & i + j)).Value
            End If
        Range("E" & i, Range("E" & i + j)).ClearContents
        i = i + j
    Next
Range("B4").Select
Application.ScreenUpdating = True
End Sub

Wenn du zwischendurch mal ein Kriterium änderst, müsste er das richtig einsortieren.
Gruß
Roland


  


Betrifft: AW: Zwischensummen getrennt in positiv und negativ von: Martin
Geschrieben am: 19.08.2004 21:31:37

Hallo Roland,

spitze, super, vielen vielen Dank für Deine Hilfe.

Gruß
Martin


  


Betrifft: Vielen Dank fürs Feedback o.T. von: Roland Hochhäuser
Geschrieben am: 19.08.2004 22:19:41




 

Beiträge aus den Excel-Beispielen zum Thema "Zwischensummen getrennt in positiv und negativ"