Microsoft Excel

Herbers Excel/VBA-Archiv

Filtern

Betrifft: Filtern von: Gregor
Geschrieben am: 03.09.2004 14:23:29

Hallo

Meine Anfrage von 11.30 Uhr war vielleicht etwas verwirrend, deshalb versuche ich es nochmals.

In Zelle C8 steht folgende Formel:
=WENN(C9=1;1;WENN(C9=2;2;WENN(C9=3;3;WENN(C9="alle";"";""))))
C9 füllt der User mit einer Liste " 1; 2; 3; alle " aus (Gültigkeit). Mit "alle" soll C8 kein Kriterium gesetzt werden.

Wenn ich in Zelle C8 direkt schreibe, dh. C8 mit Delete lösche, funktioniert die Spez-Filterung, dh. in C8 steht kein Kriterium. Wenn ich in C8 obenstehende Formel habe, dass heiss die leere Zelle C8 mit "" generiere, funktioniert die Spez-Filterung nicht. Vermutlich erkennt Spez-Filter ein Kriterium.

Woran kann das liegen?
Vielen Dank
Gregor

  


Betrifft: AW: Filtern von: Björn B.
Geschrieben am: 05.09.2004 04:15:19

Hallo Gregor,

es liegt daran, dass die Zelle C8 nicht wirklich leer ist, auch wenn Du keinen Wert hineingeschrieben hast. Du kannst das leicht überprüfen mit =istleer(C8).

Der folgende Ansatz hilft Dir hoffentlich zum Ziel:

1. Lösche die Spaltenüberschrift in Zelle C7

2. Trage folgende Formel in Zelle C8 ein:
=WENN($C$9<>"alle";C2=$C$9;C2<>$C$9)

3. Passe die Formel an deine Datei an, indem du C2 durch die erste Zelle in der Spalte,
für die das Kriterium gelten soll, ersetzt (z. B. F2).

Gruß
Björn


  


Betrifft: AW: Filtern von: Gregor
Geschrieben am: 05.09.2004 17:35:34

Hallo Björn

Ich konnte deine Antwort erst heute lesen, deshalb meine späte Reaktion. Auf jeden Fall vielen Dank, denn die Zelle sollte für die Filterung wirklich leer sein.
Ich werde deine Formel morgen im Büro anwenden.

Gruss Gregor


  


Betrifft: AW: Filtern von: Björn B.
Geschrieben am: 05.09.2004 18:03:53

Hallo Gregor,

ich bin gespannt, ob's klappt.

Gruß
Björn


  


Betrifft: AW: Filtern von: Gregor
Geschrieben am: 05.09.2004 19:52:42

Hallo Björn

Ich habe mich nochmals einige Zeit mit meinem Problem auseinandergesetzt und im "trockenen" geübt, dh. ohne die eigentliche Datei (Büro). Ich checke die Lösung jedoch nicht, obwohl ich an der Richtigkeit nicht zweifle. Wie gesagt, habe ich im Blatt "Filtern" die Spezialkriterien gesetzt, dh von A7 bis F8. Die Filterung erfolgt in Blatt "Reporting" mit Spaltenüberschriften von A2 bis AD2.
Wie soll der Spezfilter nun funktionieren, wenn ich die Spaltenüberschrift C7 löschen.

Zur Erinnerung nochmals meinen Befehl innerhalb meiner Prozedur:

'--- filtert mit Spezialfilter
Range("A2:AD" & intLastRowFilter).AdvancedFilter Action:=xlFilterInPlace, _
CriteriaRange:=Sheets("Filtern").Range("A7:F8"), Unique:=False

Kannst du deine Lösung noch etwas präzisieren. Was muss ich mit C2 ersetzen?

Gruss und vielen Dank
Gregor


  


Betrifft: AW: Filtern von: Björn B.
Geschrieben am: 05.09.2004 20:13:53

Hallo Gregor,

anbei ein paar Auszüge aus der Excel-Hilfe:

Spezialfilterkriterien können mehrfache Suchbedingungen für eine einzelne Spalte, mehrfache Suchkriterien für mehrere Spalten sowie Suchbedingungen beinhalten, die von einer Formel als Ergebnis geliefert werden.

Wenn Sie für die Festlegung eines Suchkriteriums eine Formel einsetzen, dürfen Sie als Kriterienbeschriftung keine Spaltenbeschriftung verwenden; (...).

Die Formel, die Sie zur Festlegung einer Suchbedingung verwenden, muss einen relativen Bezug verwenden, um sich auf die Spaltenbeschriftung (z. B. "Umsatz") oder auf das entsprechende Feld im ersten Datensatz zu beziehen. Alle anderen Bezüge in der Formel müssen absolute Bezüge sein, und die Formel muss zu WAHR oder FALSCH ausgewertet werden.


Um auf deine Frage "Was muss ich mit C2 ersetzen?" zurück zu kommen: NICHTS!!!

Du musst in der von mir angegebenen Formel "C2" durch einen relativen Bezug auf das Feld im ersten Datensatz ersetzen, dessen Spaltenüberschrift zuvor in C7 stand (in meinem Beispiel stand die Spaltenüberschrift in C1 und der erste Datensatz war in Zeile 2).

Im Übrigen ist es kein Problem im Spezialfilter nebeneinander Kriterien mit Spaltenüberschrift und berechnete Formeln ohne Spaltenüberschrift zu verwenden.

Gruß
Björn


  


Betrifft: AW: Filtern von: Gregor
Geschrieben am: 05.09.2004 21:40:43

Hallo Björn

Ich glaubs's nicht, aber es klappt. Ich habe es mit einer fingierten Datei getestet und es funktioniert einwandrei. Das mit der Formel beim Spezfilter kannte ich nicht, danke also für deine Geduld. Ich werd's morgen anwenden.

Gruss und einen guten Start in die neue Woche
Gregor


  


Betrifft: Danke für die Rückmeldung - o. T. von: Björn B.
Geschrieben am: 06.09.2004 12:49:33




 

Beiträge aus den Excel-Beispielen zum Thema "Filtern"