Matrix formeln

Bild

Betrifft: Matrix formeln von: Chris b
Geschrieben am: 10.02.2005 11:14:32

Hallo Excelprofis,
habe dieses mal einen frage nicht zu VBA sondern zu Matrixformeln.
Und zwar habe ich folgendes beispiel gefunden.

in Spalte B stehen untereinander und in Spalte be Dazu
---A-----------B----
3 hamburg -----12----
4 bremen -----2-----
5 hamburg -----4-----
6 bremen -----5-----
7 hamburg -----12----

dann habe ich noch in zelle G2 das wort "Hamburg" stehen und in Zelle H2 die Zahl "12"

Jetzt habe ich eine Matrixformel in einer zelle,
das ergebnis ist 2.Ich weiß auch was diese macht,sie sucht nach dem Wort Hamburg und der zahl 12 daneben.
{=SUMME((B3:B7=G2)*(C3:C7=H2))}

und als ergebniss erscheint "2" das ist auch korrekt es steht in der liste 2 mal hamburg und die zahl 2 daneben.
nur was ich nicht verstehe ist es wenn ich diese Matrix formel aufteile und zwar so:

{=SUMME(N(B3:B7=G2))} --- Ergebniss = 3

{=SUMME(N(C3:C7=H2))} --- Erebniss = 2

und wenn ich jetzt diese zwei werte miteinander Multipliziere dann bekomme ich als ergebniss 6 und nicht wie in der oberen Formel {=SUMME((B3:B7=G2)*(C3:C7=H2))} das ergebniss 2
Meine frage deshalb weil in der formel {=SUMME((B3:B7=G2)*(C3:C7=H2))} ja auch zwischen den beiden Formeln ein * steht.

Vielen Dank für eure Hilfe grüße Christian

Bild


Betrifft: AW: Matrix formeln von: Mac4
Geschrieben am: 10.02.2005 11:25:49

Hi Chris,

das Geheimnis liegt hier in der Klammersetzung! Es werden in der Matrixformel die Matrizen {Wahr.Falsch.Wahr.Falsch.Wahr}und {Wahr.Falsch.Falsch.Falsch Wahr} multipliziert.
Das Ergebnis ist Summe({1.0.0.0.0.1}) bzw. 2

Marc


Bild


Betrifft: AW: Matrix formeln von: Josef Ehrensberger
Geschrieben am: 10.02.2005 11:30:44

Hallo Christian!

Die Matrixformel multipliziert die Wahrheitswerte inerhalb der Matrix

Markiere mal in der Formel den String "B3:B7=G2" und drücke auf F9, dann
steht in der bearbeitungsleiste "(WAHR;,FALSCH;WAHR;FALSCH;WAHR) und wenn
du den zweiten Teil der Formel markierst steht "(WAHR;FALSCH;FALSCH;FALSCH;WAHR)"
und diese Paare werden nun miteinander Multipliziert und daraus die Summe errechnet

Also 1*1 + 0*0 + 1*0 + 0*0 + 1*1 = 2

Gruß Sepp

P.S.: Rückmeldung nicht vergessen!


Bild


Betrifft: AW: Matrix formeln von: Chris b
Geschrieben am: 10.02.2005 11:46:29

Vielen dank euch beiden.
Das ganze bringt doch licht ins Dunkel :)


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Matrix formeln"