Diagrammbalken

Bild

Betrifft: Diagrammbalken
von: nilex28
Geschrieben am: 25.02.2005 08:33:49
Hi Leutz!
Ich brauche unbedingt die Vorgehensweise, wie man die Diagrammbalken, wenn sich die Werte in der Tabelle ändern, gleichzeitig auch verändert.
Bsp: Wenn Wert<=1 dann Balken rot, wenn Wert>=1 dann Balken grün.
Ich vermute mal dass das eigentlich ganz simpel ist, aber ich komm einfach nicht drauf, ausserdem hab ich auch noch ´ne englische Version.
Wäre super wenn da jemand möglichst schnell eine Lösung parat hätte.
Vielen Dank schon mal im Voraus!
greetinx, nilex

Bild

Betrifft: AW: Diagrammbalken
von: Galenzo
Geschrieben am: 25.02.2005 09:02:43
nö - ist nicht simpel, brauchst du VBA.
(immer wieder bemängelt und hoffentlich in einer nächsten Excelversion so einfach möglich.)
Außer du willst positive und negative Werte unterschiedlich färben - das geht mit Diagrammeinstellung.
bei Interessse an einer VBA-Lösung sucht du mal im Forum nach "Diagramm Farben" oder so
Bild

Betrifft: auch ohne VBA
von: M@x
Geschrieben am: 25.02.2005 11:26:00
Hi,
das geht schon ohne VBA auch
man braucht dazu je Farbe eine Hilfsspalte
in einer Hilfsspalte steht dann die Formel =WENN(A1>=1;A1;)
so kannst du die Originalwerte in die Hilfspalten kopieren und mit diesen dann das Säülen oder Balkendiagramm zeichnen. wähl dann aber "gestapelt" aus, damit die Säulen zentriert dargestellt werden
Gruss
M@x
Bild

Betrifft: AW: auch ohne VBA
von: Galenzo
Geschrieben am: 25.02.2005 12:52:14
hmm.. interessanter Workaround - werd' ich mir mal merken
 Bild

Beiträge aus den Excel-Beispielen zum Thema "x-Achse - unterschiedliche Zeitraster"