Index

Bild

Betrifft: Index von: herta
Geschrieben am: 27.02.2005 18:45:40

Hallo

ich habe verschieden Excelformeln, die ich über VBA lösen möchte. Kann mir bitte jemand den Code sagen für folgende Formeln:

'=INDEX(Wertpapier!$BP$2153:$BP$2168;VERGLEICH($P$4;Wertpapier!$A$2153:$A$2158;0))' und

'=INDEX(Wertpapier!$G:$G;KKLEINSTE(WENN((Wertpapier!$CI$1:$CI$2000=$C$32);ZEILE($1:$2000));1)).

'=SUMMENPRODUKT((Wertpapier!$B$3:Wertpapier!$B$2018="Aktie")*(Wertpapier!$D$3:Wertpapier!$D$2018="Papier"))

'=INDEX(Wertpapier!$Q$2250:$AO$2250;VERGLEICH(JAHR(HEUTE());Wertpapier!$Q$2:$AO$2;0))

'=MAX($AB$3:$DZ$3)

Die zweite Formel ist eine Array-Formel.

Bild


Betrifft: AW: Index von: Ramses
Geschrieben am: 27.02.2005 18:49:47

Hallo

Starte den Makrorekorder
Gib die Formeln in die Zellen ein
Stoppe die Aufzeichnung

Nun hast du alle Formeln als "VBA-Code" aufgezeichnet und kannst sie verwenden

Gruss Rainer


Bild


Betrifft: @Rainer von: Norbert
Geschrieben am: 27.02.2005 20:48:51

Hallo Rainer,

halte diese Frage wieder für eine trollige.

Trotzdem ein Tipp: in eine Zelle kopieren, Makrorekorder starten, Zelle Markieren, F2, Enter -- und schon hast du die Formel im Makro.

Gruß
Norbert


Bild


Betrifft: Stammte irgendwann mal aus dem Excel-Center... von: Boris
Geschrieben am: 27.02.2005 21:05:59

Hi Rainer,

...klassischer Fall von postpubertärer Kinderei...

Grüße Boris


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formel"