Formatierung

Bild

Betrifft: Formatierung
von: Sammy Abu shab
Geschrieben am: 02.03.2005 15:02:07
Hallo Excelkönner!
habe ein großes Problem, mache Praktikum und eines meiner Aufgaben ist es, Daten in eine Exceldatei zu kopieren und Spaltenweise Zahlen zu addieren. Dummerweis habe ich Probleme mit einer Spalte (SPALTE D https://www.herber.de/bbs/user/19094.xls
), da Excel ein Format zu Grunde legt welches sich nicht mit der Summenformel addieren lässt (und natürlich sich auch nicht ändern lässt). Jetzt muss ich jede Zahl nochmal per Hand reinschreiben und kann sie anschließen erst addieren. Da diese Listen zum Tagesgeschäft gehören und um einiges länger sind, wäre ich sehr dankbar wenn sich jemand diesem Problem annehmen würde...Please

Bild

Betrifft: AW: Formatierung
von: Heinz Ulm
Geschrieben am: 02.03.2005 15:22:04
Hallo Sammy,
mit einer Hilfsspalte geht es :
Schreib mal die Formel in H2: =RECHTS(D2;LÄNGE(D2)-2)
Es müsste dann die "Zahl" mit Punkt rechts als Text stehen. Formel nach unten ziehen.
Dann markierst du die Spalte H und rufst BEARBEITEN - Ersetzen auf. Ersetze dann den . durch ,
Spalte H markieren und mit Bearbeiten - Inhalte einfügen; Werte wieder auf D kopieren.
Gruß Heinz
Bild

Betrifft: AW: Formatierung
von: c0bRa
Geschrieben am: 02.03.2005 15:25:35
siehe hier:
https://www.herber.de/bbs/user/19097.xls
wenn du zahlen unter 1000 euro hast brauchste das wechseln(...;",";"") nicht, aber so wärs besser ;)

Das Forum lebt auch von Rückmeldungen...
c0bRa
Bild

Betrifft: AW: Formatierung
von: Sammy Abu shab
Geschrieben am: 02.03.2005 15:34:26
Hallo Heinz!
Danke das du dich meiner annimmst, komme auch soweit mit. leider will er das ersetzen durch nicht machen... er sagt das er kein . findet. folglich steht bei mir jetzt 11.30, womit ich leider immernoch nicht arbeiten kann.
Bild

Betrifft: AW: Formatierung
von: Heinz Ulm
Geschrieben am: 02.03.2005 15:57:08
Hallo Sammy,
schau mal hier:
Tabelle3
 DEFGHIJK
1Ziel   Ausgang   
211,3       
312,45   11.3011,3  
447,78   12.4512,45  
578,12   47.7847,78  
698,56   78.1278,12  
758,78   98.5698,56  
887,96   58.7858,78  
9    87.9687,96  
10     394,95  
11    1.Suchen nach .  
12     Ersetzen durch ,  
13        
14        
15    2. die 1 in1  
16    I15 kopieren   
17        
18        
19    3. Die Spalte I markieren   
20        
21    4. Bearbeiten - Inhalte einfügen - multiplizieren   
22        
23    Dann müsste es aussehen wie Sp. D   
24        
25        
Formeln der Tabelle
I10 : =SUMME(I3:I9)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Heinz
Bild

Betrifft: AW: Formatierung
von: UweD
Geschrieben am: 02.03.2005 15:34:54
Hallo
per Makro gehts so:

Sub Euro()
    'Bereich vorher markieren...
    Dim Z
    For Each Z In Selection.Cells
        Z.NumberFormat = "$ #,##0.00"
        Z.Value = Application.Substitute(Z.Value, "€", "")
        Z.Value = Application.Substitute(Z.Value, ".", ",") * 1
    Next
End Sub

Hier zum Testen.. https://www.herber.de/bbs/user/19099.xls
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formatierung"