KKLEINSTE mit Buchstaben?

Bild

Betrifft: KKLEINSTE mit Buchstaben? von: Erich M.
Geschrieben am: 23.03.2005 07:28:02

Hallo EXCEL-Freunde,

habe folgende Formel, die die Spalte A aufsteigend (incl. Doppelte) sortiert:
=WENN(ISTFEHLER(KKLEINSTE(A:A;ZEILE()-2));"";KKLEINSTE(A:A;ZEILE()-2))

Funktioniert wenn in Spalte A nur Zahlen enthalten sind.

Gibt es eine Möglichkeit, die Formel so zu ändern, dass diese auch funktioniert:
- wenn in Spalte A nur Buchstaben/Namen
- wenn in Spalte A gemischt, z.B.: 15Anton ??

Probiere schon ne Weile und nichts geht!

Besten Dank für eine kurze Info!

mfg
Erich
http://www.toolex.de

Bild


Betrifft: AW: KKLEINSTE mit Buchstaben? von: UweD
Geschrieben am: 23.03.2005 08:18:13

Hallo

nach http://www.excelformeln.de/formeln.html?welcher=236


ginge es so

 
 AB
1aa15b
2aa
3faa
4rb
515bf
6bg
7wr
8gr
9rw
10ww
Formeln der Tabelle
B1 : {=INDEX($A$1:$A$10;VERGLEICH(KKLEINSTE(ZÄHLENWENN(A$1:A$10;"<"&A$1:A$10);ZEILEN(A$1:A1));ZÄHLENWENN(A$1:A$10;"<"&A$1:A$10);0))}

Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
 


Gruß UweD


Bild


Betrifft: AW: KKLEINSTE mit Buchstaben? von: Erich M.
Geschrieben am: 23.03.2005 20:10:58

Hallo Uwe,

Danke - funktioniert wunderbar!

mfg
Erich
http://www.toolex.de


Bild


Betrifft: AW: KKLEINSTE mit Buchstaben? von: IngoG
Geschrieben am: 23.03.2005 08:31:52

Hallo Erich,

mit folgender Matrixformel sollte es funzen:
(die formel arbeitet äquivalent zu kkleinste($A$4:$A$10;d4), Groß/kleinschreibung wird ignoriert)

=INDEX($A$4:$A$10;MIN(WENN(ZÄHLENWENN($A$4:$A$10;"<="&$A$4:$A$10)=D4;VERGLEICH($A$4:$A$10;$A$4:$A$10))))

Eingabe abschließen mit Strg-Shift-Enter

Bestimmt kann man noch etwas optimieren, ist aber schon mal eine Lösung

Gruß Ingo

PS eine Rückmeldung wäre nett...


Bild


Betrifft: AW: KKLEINSTE mit Buchstaben? von: Erich M.
Geschrieben am: 23.03.2005 20:11:43

Hallo Ingo,

den Bezug mit D4 verstehe ich nicht??
Bitte kurze Info!

mfg
Erich
http://www.toolex.de


 Bild

Beiträge aus den Excel-Beispielen zum Thema "KKLEINSTE mit Buchstaben?"