Ergebnisse per VBA?

Informationen und Beispiele zu den hier genannten Dialog-Elementen:
MsgBox
Bild

Betrifft: Ergebnisse per VBA? von: Erich M.
Geschrieben am: 26.03.2005 09:52:27

Hallo EXCEL-Freunde,

mit Zählenwenn als Formel kann ich ergebnisse ermitteln;
wie müsste denn hier der Code aussehen?
Die einzelnen Namen, Orte und Ziele sind fix und nicht veränderbar;
allerdings kommen diese unterschiedlich oft in den Spalten vor:

Tabelle2
 ABC
1NameOrtZiel
2AlbersAugsburgStuttgart
3HuberMünchenDresden
4AlbersHamburgBerlin
5MayerNürnbergStuttgart
6HuberAugsburgBerlin
7AlbersHamburgDresden
8MayerMünchenStuttgart
9   
10Ergebnisse  
11Name  
12Albers3 
13Huber2 
14Mayer2 
15   
16Ort  
17Augsburg2 
18München2 
19Hamburg2 
20Nürnberg1 
21   
22Ziel  
23Stuttgart3 
24Dresden2 
25Berlin2 
Formeln der Tabelle
B12 : =ZÄHLENWENN(A$2:A$8;A12)
B13 : =ZÄHLENWENN(A$2:A$8;A13)
B14 : =ZÄHLENWENN(A$2:A$8;A14)
B17 : =ZÄHLENWENN(B$2:B$8;A17)
B18 : =ZÄHLENWENN(B$2:B$8;A18)
B19 : =ZÄHLENWENN(B$2:B$8;A19)
B20 : =ZÄHLENWENN(B$2:B$8;A20)
B23 : =ZÄHLENWENN(C$2:C$8;A23)
B24 : =ZÄHLENWENN(C$2:C$8;A24)
B25 : =ZÄHLENWENN(C$2:C$8;A25)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Besten Dank für eine Hilfe!

mfg
Erich
http://www.toolex.de
Bild


Betrifft: AW: Ergebnisse per VBA? von: Hajo_Zi
Geschrieben am: 26.03.2005 09:59:22

Hallo Erich,

warum muß alles per VBA gemacht werden. Excel hat doch auch Klassefunktionen.

Application.Count


Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.




Bild


Betrifft: AW: Ergebnisse per VBA? von: Erich M.
Geschrieben am: 26.03.2005 18:01:16

Hallo Hajo,

da das ganze innerhalb eines Codes läuft, muss ich es zwangsläufig einbauen
(siehe meine antwort an ransi).

mfg
Erich
http://www.toolex.de


Bild


Betrifft: AW: Ergebnisse per VBA? von: ransi
Geschrieben am: 26.03.2005 10:50:23

hallo erich

markiere b12
geh in den VBA-editor
-direktfenster
-und da dann dies hier rein:
-?activecell.formula
-Enter

gibt für b12:
=COUNTIF(A$2:A$8,A12)

ransi


Bild


Betrifft: Zwischenlösung von: Erich M.
Geschrieben am: 26.03.2005 17:59:43

Hallo ransi,

bin einen Schritt weiter; jetzt habe ich noch das Problem, dass die Daten nicht im
gleichen Blatt sind; wie muss der code geändert werden; meine Versuche waren vergeblich:


Sub Test2()
' Wie muss der Code lauten, wenn die Daten im Sheet "Tabelle1" sind ??
Range("B12") = WorksheetFunction.CountIf(Columns(1), "Albers")
'' ?? Range("B12") = Sheets("Tabelle1").WorksheetFunction.CountIf(Columns(1), "Albers") ??
End Sub


mfg
Erich
http://www.toolex.de


Bild


Betrifft: ..doch noch gelöst von: Erich M.
Geschrieben am: 26.03.2005 18:19:51


Sub Test2()
Range("B12") = Application.WorksheetFunction.CountIf(Sheets("Tabelle1").Columns(1), "Albers")
End Sub



mfg
Erich
http://www.toolex.de


Bild


Betrifft: AW: Zwischenlösung von: Josef Ehrensberger
Geschrieben am: 26.03.2005 18:22:20

Hallo Erich!

Z.b. so.


      
Sub test()
Dim rng As Range
Set rng = Sheets("Tabelle1").Columns(1)

MsgBox Application.CountIf(rng, "Albers")

End Sub 


     Code eingefügt mit Syntaxhighlighter 3.0





Gruß Sepp


P.S.: Rückmeldung nicht vergessen!




Bild


Betrifft: Danke Sepp für die Alternative!! von: Erich M.
Geschrieben am: 26.03.2005 18:52:05



mfg
Erich
http://www.toolex.de


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Ergebnisse per VBA?"