nächstliegenden Wert finden

Bild

Betrifft: nächstliegenden Wert finden
von: Hans
Geschrieben am: 29.03.2005 15:37:51
Hallo!
Ich bin ein ziemlicher Excel-Goofy und fürchte - wenn ich mir hier so die Beiträge anschaue -, dass ich mich hier evtl. zum Affen mache.
Was solls...
es geht um folgende Fragestellung:
ein Wert wird berechnet. Excel soll nun in einer Tabelle/Datenbank (innerhalb excel), die meinetwegen die Daten
120 5 4 3 2 1
124 6 5 4 3 2
135 7 6 5 4 3
etc.

enthält, den nächstliegenden Wert in der ersten Spalte suchen. Also sagen wir mal es wurde 126 ausgerechnet, dann soll Excel die zweite Zeile finden und mit den Daten, die in der entsprechenden Zeile in den Spalten B-F zu finden sind, weiterrechnen.
Wie geht das? Muss das mit VBA programmiert werden oder kann man das mit ein
paar verschachtelten Funktionen hinbekommen? Wenn ja welche?
*I feel stupid*

Bild

Betrifft: AW: nächstliegenden Wert finden
von: Ramses
Geschrieben am: 29.03.2005 16:24:55
Hallo
Tabelle1
 ABCD
1WertWert1Wert2 
210211 
312022 
412633 
514044 
6    
7    
8    
9Gesucht124  
10Ergebnis   
11multipliziert4  
12    
Formeln der Tabelle
B11 : =SVERWEIS(B9;A2:C5;2;1)*SVERWEIS(B9;A2:C5;3;1)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Das sollte so funktionieren.
Genaue Informationen zur Funktion SVERWEIS erhältst du in der Online-Hilfe.
Diese Funktion sucht den genauen Wert, oder den nächstkleineren wenn der gesuchte Wert nicht vorkommt (letzter Parameter = 1 ) und multipliziert die Zahlen aus Spalte 2 und 3 (3. Parameter ) in der definierten Matrix (2. Parameter)
Gruss Rainer
Bild

Betrifft: AW: nächstliegenden Wert finden
von: Hans
Geschrieben am: 29.03.2005 18:22:13
SPITZE!
genau das habe ich gesucht! DANKE!
 Bild

Beiträge aus den Excel-Beispielen zum Thema "nächstliegenden Wert finden"