automatische Uhrzeit

Bild

Betrifft: automatische Uhrzeit
von: Konrad
Geschrieben am: 30.03.2005 11:22:47
Hallo,
kann Excel die aktuelle Uhrzeit in eine Zelle automatisch eintragen wenn die Zelle links davon mit dem Datum befüllt wird.
Vielen Dank für die Hilfe
Gruß
Konrad

Bild

Betrifft: AW: automatische Uhrzeit
von: Hajo_Zi
Geschrieben am: 30.03.2005 11:30:26
Hallo Konrad,
in VBA unter der Tabelle.
Option Explicit

Private Sub Worksheet_Change(ByVal Target As Range)
    If Target.Address <> "$A$1" Then Exit Sub
    With Target.Offset(0, 1)
        .Value = Time
        .NumberFormat = "h:mm:ss"
    End With
End Sub


Bitte keine Mail, Probleme sollten im Forum gelöst werden.
Microsoft MVP für Excel
Das Forum lebt auch von den Rückmeldungen.
Betriebssystem XP Home SP2 und Excel Version 2003 SP1.


Bild

Betrifft: AW: automatische Uhrzeit
von: Thommy
Geschrieben am: 30.03.2005 11:31:10
Hallo Konrad!
Meinst das so??
In Zelle A1 wird das Datum (z.b. heute) eingetragen und in Zelle B1 möchtest die aktuelle Uhrzeit haben??
Formel hiefür wäre (in B1): =WENN(A1="";"";JETZT())
Konnte ich Dir helfen??
lg Thommy
Bild

Betrifft: AW: automatische Uhrzeit
von: Hajo_Zi
Geschrieben am: 30.03.2005 11:42:54
Hallo Thommy,
die Funktion Jetzt() wird bei jeder Eingabe in der Tabelle aktualisiert.
Gruß Hajo
Das Forum lebt auch von den Rückmeldungen.
Bild

Betrifft: AW: automatische Uhrzeit
von: c0bRa
Geschrieben am: 30.03.2005 11:54:01
aus gegebenem anlass:
wenn du mit der zeit weiterrechnen willst, dann bitte in b1: =REST(JETZT();1)
danke ;)

c0bRa
Bild

Betrifft: AW: automatische Uhrzeit
von: Thommy
Geschrieben am: 30.03.2005 13:01:43
Hallo Hajo,
da hast recht ... hatte ich gar nicht bedacht!
lg Thommy
 Bild

Beiträge aus den Excel-Beispielen zum Thema "automatische Uhrzeit"