vergleichen + erseten wenn !

Bild

Betrifft: vergleichen + erseten wenn ! von: Uli
Geschrieben am: 30.03.2005 15:53:57

Hallo,

ich sitzte gerade und kämpfe mit einem Problem.
ich habe zwei Preislisten und die möchte ich vergleichen und dann Wert ersetzen. Nur in der eine Liste sind irgendwelche Nummern in Klammer hinter dem Land.
Kann ich das irgendwie entfernen lassen, oder einfach sagen:
vergleiche z.B. Land und Preis aus neue Preislist mit alte Preisliste,
wenn Land gleich dann ersetzen damit die "nummer in klammern" verschwindet, und übernehme neue Preis.

das funktioniert auch wenn das Land exact gleich geschrieben ist,
nur wenn das nicht der fall ist klappt es nicht.
ich habe dann versucht mit : *xyz* damit er nur ein Teil von dem "länderbezeichnung" vergleichen sollte aber ohne Erfolg

Villeicht ist es möglich in VBA, ich kann da zwar ein bischen , aber das hier kriege ich nicht hin.
z.B. in sheet 1 die neue Preisliste und in sheet 2 die alte Preislistm, beim Ausfürhren dern Makro ändert der dann in sheet 2 und markiert evtl. die Zellen wo geändert wurde.


Ich hoffe das Jemand mich helfen kann
Im voraus VIELEN DANK
Uli

siehe evtl.:
https://www.herber.de/bbs/user/20381.xls

Bild


Betrifft: AW: vergleichen + erseten wenn ! von: Frank Domke
Geschrieben am: 30.03.2005 16:42:33

Hallo Uli
ich habe Dir mal den Vergleich in Excel für Dein Beispiel geschrieben:
=WENN(B4=LINKS(E4;LÄNGE(B4));"gleich";"ungleich")
Vielleicht hilft Dir der Ansatz?
Viel Erfolg
Frank.


Bild


Betrifft: AW: vergleichen + erseten wenn ! von: UweN
Geschrieben am: 30.03.2005 16:46:32

Hallo Uli,

hilft Dir das vielleicht schon mal weiter ?
https://www.herber.de/bbs/user/20391.xls

Lösungsansatz ohne VBA mit Hilfspalte


Viele Grüße
Uwe


Bild


Betrifft: AW: vergleichen + erseten wenn ! von: HermannZ
Geschrieben am: 30.03.2005 17:13:52

Hallo Uli,

oder so mit folgender Formel; {=INDEX(F4:F11;VERGLEICH(B4;LINKS(E4:E11;FINDEN("(";E4:E11)-2);0))}

Matrix-Formel
nicht die geschweifte Klammer eingeben sondern
mit Shift-Strg-Enter abschließen

Gruß hermann


Bild


Betrifft: AW: vergleichen + erseten wenn ! von: Uli
Geschrieben am: 30.03.2005 17:58:48

DANKE an alle drei ....... es funktioniert :))))))


Bild


Betrifft: AW: vergleichen + erseten wenn ! von: FP
Geschrieben am: 30.03.2005 18:16:39

Hallo Uli,

da brauchst Du keine Array-Formel :-)

Sheet1
 BCDEFG
2neue liste   alte liste 
3Landpreisalter Preis Landpreis
4Argentina6,70,0 Afghanistan (351)3,3
5Ägypten3,44,4 Albanien (353)5,5
6Albanien4,55,5 Algerien (354)6,6
7Algerien5,66,6 Ägypten (349)4,4
8Afghanistan2,33,3   
9Australien7,80,0   
10Andorra8,90,0   
11Angola9,90,0   
Formeln der Tabelle
D4 : =WENN(ZÄHLENWENN(F:F;B4&"*");SVERWEIS(B4&"*";F:G;2;0);0)
D5 : =WENN(ZÄHLENWENN(F:F;B5&"*");SVERWEIS(B5&"*";F:G;2;0);0)
D6 : =WENN(ZÄHLENWENN(F:F;B6&"*");SVERWEIS(B6&"*";F:G;2;0);0)
D7 : =WENN(ZÄHLENWENN(F:F;B7&"*");SVERWEIS(B7&"*";F:G;2;0);0)
D8 : =WENN(ZÄHLENWENN(F:F;B8&"*");SVERWEIS(B8&"*";F:G;2;0);0)
D9 : =WENN(ZÄHLENWENN(F:F;B9&"*");SVERWEIS(B9&"*";F:G;2;0);0)
D10 : =WENN(ZÄHLENWENN(F:F;B10&"*");SVERWEIS(B10&"*";F:G;2;0);0)
D11 : =WENN(ZÄHLENWENN(F:F;B11&"*");SVERWEIS(B11&"*";F:G;2;0);0)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  


Servus aus dem Salzkammergut
Franz


 Bild

Beiträge aus den Excel-Beispielen zum Thema "vergleichen + erseten wenn !"