Bestand addieren / subtrahieren

Bild

Betrifft: Bestand addieren / subtrahieren
von: Michael Schimek
Geschrieben am: 31.03.2005 16:25:32
Ich habe eine Bestandstabelle, in der z. B. der derzeitige Bestand an Kugelschreiber mit 10 Stück eingetragen. Nun möchte ich in den beiden Spalten daneben jeweils die Zu- bzw. Abgänge eingeben.
Das Makro soll mir dann automatisch den derzeitigen Bestand (auf Grund Ab- oder Zugänge) anzeigen.
Für eine best. Zelle habe ich das schon gelöst. Aber ich brauch es ja für die gesamte Spalte in der ich Zu-/Abgänge eintrage und ich weiß nicht, wieviele Zeilen es sind.


Private Sub Worksheet_Change(ByVal Target As Excel.Range)
If Not Intersect(Target, Range("B1")) Is Nothing Then
Range("B1").Select
Selection.Copy
Range("B2").Select
Selection.PasteSpecial Paste:=xlAll, Operation:=xlSubtract, SkipBlanks:=False _
, Transpose:=False
'xladd
End If
End Sub

Ich hoffe, mir kann wer helfen. Hier die Beispiel-Datei: https://www.herber.de/bbs/user/20439.xls
Bild

Betrifft: AW: Bestand addieren / subtrahieren
von: ransi
Geschrieben am: 31.03.2005 16:56:39
hallo michael
was dein beispiel mit der frage zu tun hat habe ich nicht verstanden,
darum mal verdacht dieses:

Private Sub Worksheet_Change(ByVal Target As Range)
Dim zellezeile As Long
If Target.Column < 5 Or Target.Column > 7 Or Target.Count > 1 Then Exit Sub
zellezeile = Target.Row
Cells(zellezeile, 5) = Cells(zellezeile, 4) - Cells(zellezeile, 6) + Cells(zellezeile, 7)
'Cells(zellezeile, 4) = Cells(zellezeile, 5)
End Sub

ransi
Bild

Betrifft: AW: Bestand addieren / subtrahieren
von: Michael Schimek
Geschrieben am: 31.03.2005 19:02:29
sorry, Paula, deine Lösung ist nicht das, was ich brauche
ransi hat mir da schon ein Stück mehr weitergeholfen - dankeschööön
In der Tabelle werden aber laufend Daten eingegeben, d. h., wenn ich einen Zugang habe, dann erhöht er meinen Bestand - das passt.
Nur müsste ich jetzt natürlich den Wert aus Zugang wieder löschen können, ohne dass sich der Bestand verändert.
D. h.,
Bestand = 6,
jetzt gebe ich einen Zugang von 2 ein,
Bestand = 8
jetzt möchte ich aber, bevor ich die Datei für ein späteres Bearbeiten abspeichere, dass der Wert 2 bei Zugang wieder gelöscht werden kann und der Bestand trotzdem erhöht bei 8 bleibt
Bild

Betrifft: AW: Bestand addieren / subtrahieren
von: ransi
Geschrieben am: 31.03.2005 19:43:43


      
hallo Michael
das kompliziert das ganze ein wenig.
versuchs mal so:
Private Sub Worksheet_Change(ByVal Target As Range)
Dim zellezeile As Long
'Gültigkeitsbeich festlegen
'und fehlerabfangen bei eingabe von Nichtzahlen
If Target.Column < 6 _
    
Or Target.Column > 7 _
    
Or Target.Row < 3 Or Target.Count > 1 _
    
Or Target = "" _
    
Or Not IsNumeric(Target) Then Exit Sub
zellezeile = Target.Row
Cells(zellezeile, 4) = Cells(zellezeile, 5) 
'übertrag von "Bestand alt" nach "Bestand neu"
Select Case Target.Column
Case 6
    Cells(zellezeile, 7) = 
""
    Cells(zellezeile, 5) = Cells(zellezeile, 4) - Cells(zellezeile, 6)
Case 7
    Cells(zellezeile, 6) = 
""
    Cells(zellezeile, 5) = Cells(zellezeile, 4) + Cells(zellezeile, 7)
End Select
End Sub
ransi 

     Code eingefügt mit Syntaxhighlighter 3.0


Bild

Betrifft: AW: Bestand addieren / subtrahieren
von: Michael Schimek
Geschrieben am: 01.04.2005 11:01:08
dankeschön, passt optimal
klasse, danke
Bild

Betrifft: AW: Bestand addieren / subtrahieren
von: Paula
Geschrieben am: 31.03.2005 17:14:42
hi,
wie so nicht mal nur mit Tabellenfunktionen?
So, z.B
In F3 folgende Formel eintragen
=WENN(E3<D3;D3-E3;"")
Zelle F3 "anfassen", nach unten ziehen, um Formel zu kopieren
In G3 folgende Formel eintragen:
=WENN(E3>D3;E3-D3;"")
Zelle G3 "anfassen", nach unten ziehen, um Formel zu kopieren.
Hilf es?
bd Paula
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Bestand addieren / subtrahieren"