Zellinhalte einfärben

Bild

Betrifft: Zellinhalte einfärben
von: mike49
Geschrieben am: 20.04.2005 10:08:13
Hallo zusammen,
in meiner Tabelle sollen im Eingabebereich A2:A20 verschiedene Buchstabenkombinationen eingegeben werden können.
Wie kann man erreichen, dass bei Eingabe der Buchstabenkominationen "be" oder "ci" oder "zy" oder "my" sich diese rot einfärben (nicht der Zellhintergrund). Gleichzeitig sollen sich die durch den SVerweis eingetragenen dazugehörigen Zellinhalte der danebenliegenden Zellen ebenfalls rot einfärben.

 
 ABC
1Kürzel:Artikel:Preis:
2     
3     
4     
5     
6     
7     
8     
9     
10     
11     
12     
13     
14     
15     
16     
17     
18     
19     
20     
21 Summe:0,00 €
Formeln der Tabelle
B2 : =WENN(A2="";"";SVERWEIS(A2;Daten!$A$2:$C$20;2;FALSCH))
C2 : =WENN(A2="";"";SVERWEIS(A2;Daten!$A$2:$C$20;3;FALSCH))
B3 : =WENN(A3="";"";SVERWEIS(A3;Daten!$A$2:$C$20;2;FALSCH))
C3 : =WENN(A3="";"";SVERWEIS(A3;Daten!$A$2:$C$20;3;FALSCH))
B4 : =WENN(A4="";"";SVERWEIS(A4;Daten!$A$2:$C$20;2;FALSCH))
C4 : =WENN(A4="";"";SVERWEIS(A4;Daten!$A$2:$C$20;3;FALSCH))
B5 : =WENN(A5="";"";SVERWEIS(A5;Daten!$A$2:$C$20;2;FALSCH))
C5 : =WENN(A5="";"";SVERWEIS(A5;Daten!$A$2:$C$20;3;FALSCH))
B6 : =WENN(A6="";"";SVERWEIS(A6;Daten!$A$2:$C$20;2;FALSCH))
C6 : =WENN(A6="";"";SVERWEIS(A6;Daten!$A$2:$C$20;3;FALSCH))
B7 : =WENN(A7="";"";SVERWEIS(A7;Daten!$A$2:$C$20;2;FALSCH))
C7 : =WENN(A7="";"";SVERWEIS(A7;Daten!$A$2:$C$20;3;FALSCH))
B8 : =WENN(A8="";"";SVERWEIS(A8;Daten!$A$2:$C$20;2;FALSCH))
C8 : =WENN(A8="";"";SVERWEIS(A8;Daten!$A$2:$C$20;3;FALSCH))
B9 : =WENN(A9="";"";SVERWEIS(A9;Daten!$A$2:$C$20;2;FALSCH))
C9 : =WENN(A9="";"";SVERWEIS(A9;Daten!$A$2:$C$20;3;FALSCH))
B10 : =WENN(A10="";"";SVERWEIS(A10;Daten!$A$2:$C$20;2;FALSCH))
C10 : =WENN(A10="";"";SVERWEIS(A10;Daten!$A$2:$C$20;3;FALSCH))
B11 : =WENN(A11="";"";SVERWEIS(A11;Daten!$A$2:$C$20;2;FALSCH))
C11 : =WENN(A11="";"";SVERWEIS(A11;Daten!$A$2:$C$20;3;FALSCH))
B12 : =WENN(A12="";"";SVERWEIS(A12;Daten!$A$2:$C$20;2;FALSCH))
C12 : =WENN(A12="";"";SVERWEIS(A12;Daten!$A$2:$C$20;3;FALSCH))
B13 : =WENN(A13="";"";SVERWEIS(A13;Daten!$A$2:$C$20;2;FALSCH))
C13 : =WENN(A13="";"";SVERWEIS(A13;Daten!$A$2:$C$20;3;FALSCH))
B14 : =WENN(A14="";"";SVERWEIS(A14;Daten!$A$2:$C$20;2;FALSCH))
C14 : =WENN(A14="";"";SVERWEIS(A14;Daten!$A$2:$C$20;3;FALSCH))
B15 : =WENN(A15="";"";SVERWEIS(A15;Daten!$A$2:$C$20;2;FALSCH))
C15 : =WENN(A15="";"";SVERWEIS(A15;Daten!$A$2:$C$20;3;FALSCH))
B16 : =WENN(A16="";"";SVERWEIS(A16;Daten!$A$2:$C$20;2;FALSCH))
C16 : =WENN(A16="";"";SVERWEIS(A16;Daten!$A$2:$C$20;3;FALSCH))
B17 : =WENN(A17="";"";SVERWEIS(A17;Daten!$A$2:$C$20;2;FALSCH))
C17 : =WENN(A17="";"";SVERWEIS(A17;Daten!$A$2:$C$20;3;FALSCH))
B18 : =WENN(A18="";"";SVERWEIS(A18;Daten!$A$2:$C$20;2;FALSCH))
C18 : =WENN(A18="";"";SVERWEIS(A18;Daten!$A$2:$C$20;3;FALSCH))
B19 : =WENN(A19="";"";SVERWEIS(A19;Daten!$A$2:$C$20;2;FALSCH))
C19 : =WENN(A19="";"";SVERWEIS(A19;Daten!$A$2:$C$20;3;FALSCH))
B20 : =WENN(A20="";"";SVERWEIS(A20;Daten!$A$2:$C$20;2;FALSCH))
C20 : =WENN(A20="";"";SVERWEIS(A20;Daten!$A$2:$C$20;3;FALSCH))
C21 : =SUMME(C2:C20)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß
mike49
Bild

Betrifft: Geht alles mit bedingter Formatierung! owT
von: Luc:-?
Geschrieben am: 20.04.2005 10:15:40

Bild

Betrifft: AW: Geht alles mit bedingter Formatierung! owT
von: mike49
Geschrieben am: 20.04.2005 10:25:19
Hallo Luc,
dass dies über die bedingte Formatierung läuft, habe ich mir schon gedacht.
Die Frage ist nur "wie?"
Gruß
mike49
Bild

Betrifft: Brauchst wohl Beding'formel? z.Z.ld.k.Z. owT
von: Luc:-?
Geschrieben am: 20.04.2005 10:32:18

Bild

Betrifft: AW: Zellinhalte einfärben
von: th.heinrich
Geschrieben am: 20.04.2005 10:29:25
hallo Mike,
dies sollte es tun
Tabelle3
 A
1me
2 
Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =ODER(A1="me";A1="my";A1="mi")Abc
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  

gruss thomas
Bild

Betrifft: Danke Thomas. Funktioniert.
von: mike49
Geschrieben am: 20.04.2005 11:23:53
Gruß
mike49
 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellinhalte einfärben"