Herbers Excel-Forum - das Archiv

Prozentformel

Bild

Betrifft: Prozentformel
von: Tim

Geschrieben am: 02.01.2007 10:34:29
Hallo Forum,
in den Zellen A1 und B1 stehen Werte. Jetzt möchte ich in C1 die prozentuale Veränderung von A1 nach B1 ermitteln. Ich benötige nun die Formel für C1, die berücksichtigt, dass A1 und B1 (bzw nur A1 oder B1) auch negativ sein können.
Beispiele:
A1=10 B1=12 C1= +20%
A1=-10 B1=-12 C1= -20%
A1=-10 B1=12 C1= +220%
A1=-10 B1=-5 C1= +50%
usw.
Wenn die Formel dann noch Werte größer 100% als ">+100%" oder "<-100%" darstellt, ist es perfekt.
Vielen Dank für eure Hilfe.
Gruß
Tim
Bild

Betrifft: AW: Prozentformel
von: Peter Feustel
Geschrieben am: 02.01.2007 11:10:11
Hallo Tim
viellecicht so: =(B1-A1)/(A1/100)&" %"
Viele Grüße Peter
Eine kurze Nachricht, ob es läuft, wäre nett - danke.
Bild

Betrifft: AW: Prozentformel
von: Jörg Gradert

Geschrieben am: 02.01.2007 11:23:53
Hallo Tim,
=WENN((B1-A1)/ABS(A1)<-1;"<-100%";WENN((B1-A1)/ABS(A1)>1;">+100%";(B1-A1)/ABS(A1)))
fehlt nur noch das Abfangen des Fehlers DIV/0, der entsteht, wenn A1 leer bleibt.
Das kriegst Du mit einer weiteren Wenn() Klammer selbst hin.
Gruß Jörg
Bild

Betrifft: AW: Prozentformel
von: Tim
Geschrieben am: 02.01.2007 12:11:15
Vielen Dank für die Antworten.
Die Lösung von Jörg funktioniert prima.
Gruß
Tim
 Bild