Herbers Excel-Forum - das Archiv

Nummerierung

Bild

Betrifft: Nummerierung
von: Oliver Ratajczak

Geschrieben am: 05.01.2007 09:57:28
Folgendes Problem:
Ich habe eine Artikelliste. Diese Liste hat in Spalte A eine durchgehende Nummerierung. In der Spalte B stehen die Artikel. Da ich oft bestimmte Zeilen aus der Artikelliste herauslösche, um daraus ein Angebot zu fertigen, musste ich mir mit einer Formel helfen.
Die Formel = WENN($B1<>"";ANZAHL2($B1:$B$1);"") hat mir bis dato sehr gute Dienste geleistet. Sollte in einer Zelle in Spalte B mal kein Wert (Argument) stehen, so zählt Excel doch richtig.
So, nun hat sich meine Artikelliste aber mit der Zeit verändert und die Artikel sind sortiert nach Warengruppen und jede Warengruppe erhält in der Spalte B auch eine Überschrift und in der Spalte A steht dann POS. (Siehe auch Beispiel)
https://www.herber.de/bbs/user/39399.xls
Jetzt möchte ich meine Formel so optimieren, dass wenn in einer Zelle in Spalte B das Wort Warengruppe steht, er mir POS wiedergibt und dann weiter richtig zählt.
Meine Formel zählt die Argumente die in einer Range stehen, daher ist Sie für mich so nicht mehr praktikabel!
Wer weiß Rat?
Vorab schon einmal vielen Dank für Euere Hilfe!
Gruß
Oliver
Bild

Betrifft: AW: Nummerierung
von: Ramses

Geschrieben am: 05.01.2007 10:03:11
Hallo
Meinst du so ?
Tabelle1

 AB
1  
2POSWarengruppe1
301Cola
402Fanta
503Sprite
604Wasser
705Stilles Wasser
806Pepsi
907Red Bull
1008O-Saft
11  
12  
13  
14POSWarengruppe2
1509Schnitzel
1610Steak
1711Keule vom Lamm
1812Rinderhaxe
1913Schweinehaxe
2014Frikadelle
21  
22  
23  
24POSWarengruppe3
2515Saucenbinder
2616Stärke
2717Mehl
2818Butter
2919Eier
3020Gries
31  

Formeln der Tabelle
ZelleFormel
A2=WENN(LINKS(B2;11)="Warengruppe";"POS";WENN(B2="";"";ANZAHL2($B$2:B2)-ZÄHLENWENN($B$2:B2;"Warengruppe?")))
A3=WENN(LINKS(B3;11)="Warengruppe";"POS";WENN(B3="";"";ANZAHL2($B$2:B3)-ZÄHLENWENN($B$2:B3;"Warengruppe?")))
A4=WENN(LINKS(B4;11)="Warengruppe";"POS";WENN(B4="";"";ANZAHL2($B$2:B4)-ZÄHLENWENN($B$2:B4;"Warengruppe?")))
A5=WENN(LINKS(B5;11)="Warengruppe";"POS";WENN(B5="";"";ANZAHL2($B$2:B5)-ZÄHLENWENN($B$2:B5;"Warengruppe?")))
A6=WENN(LINKS(B6;11)="Warengruppe";"POS";WENN(B6="";"";ANZAHL2($B$2:B6)-ZÄHLENWENN($B$2:B6;"Warengruppe?")))
A7=WENN(LINKS(B7;11)="Warengruppe";"POS";WENN(B7="";"";ANZAHL2($B$2:B7)-ZÄHLENWENN($B$2:B7;"Warengruppe?")))
A8=WENN(LINKS(B8;11)="Warengruppe";"POS";WENN(B8="";"";ANZAHL2($B$2:B8)-ZÄHLENWENN($B$2:B8;"Warengruppe?")))
A9=WENN(LINKS(B9;11)="Warengruppe";"POS";WENN(B9="";"";ANZAHL2($B$2:B9)-ZÄHLENWENN($B$2:B9;"Warengruppe?")))
A10=WENN(LINKS(B10;11)="Warengruppe";"POS";WENN(B10="";"";ANZAHL2($B$2:B10)-ZÄHLENWENN($B$2:B10;"Warengruppe?")))
A11=WENN(LINKS(B11;11)="Warengruppe";"POS";WENN(B11="";"";ANZAHL2($B$2:B11)-ZÄHLENWENN($B$2:B11;"Warengruppe?")))
A12=WENN(LINKS(B12;11)="Warengruppe";"POS";WENN(B12="";"";ANZAHL2($B$2:B12)-ZÄHLENWENN($B$2:B12;"Warengruppe?")))
A13=WENN(LINKS(B13;11)="Warengruppe";"POS";WENN(B13="";"";ANZAHL2($B$2:B13)-ZÄHLENWENN($B$2:B13;"Warengruppe?")))
A14=WENN(LINKS(B14;11)="Warengruppe";"POS";WENN(B14="";"";ANZAHL2($B$2:B14)-ZÄHLENWENN($B$2:B14;"Warengruppe?")))
A15=WENN(LINKS(B15;11)="Warengruppe";"POS";WENN(B15="";"";ANZAHL2($B$2:B15)-ZÄHLENWENN($B$2:B15;"Warengruppe?")))
A16=WENN(LINKS(B16;11)="Warengruppe";"POS";WENN(B16="";"";ANZAHL2($B$2:B16)-ZÄHLENWENN($B$2:B16;"Warengruppe?")))
A17=WENN(LINKS(B17;11)="Warengruppe";"POS";WENN(B17="";"";ANZAHL2($B$2:B17)-ZÄHLENWENN($B$2:B17;"Warengruppe?")))
A18=WENN(LINKS(B18;11)="Warengruppe";"POS";WENN(B18="";"";ANZAHL2($B$2:B18)-ZÄHLENWENN($B$2:B18;"Warengruppe?")))
A19=WENN(LINKS(B19;11)="Warengruppe";"POS";WENN(B19="";"";ANZAHL2($B$2:B19)-ZÄHLENWENN($B$2:B19;"Warengruppe?")))
A20=WENN(LINKS(B20;11)="Warengruppe";"POS";WENN(B20="";"";ANZAHL2($B$2:B20)-ZÄHLENWENN($B$2:B20;"Warengruppe?")))
A21=WENN(LINKS(B21;11)="Warengruppe";"POS";WENN(B21="";"";ANZAHL2($B$2:B21)-ZÄHLENWENN($B$2:B21;"Warengruppe?")))
A22=WENN(LINKS(B22;11)="Warengruppe";"POS";WENN(B22="";"";ANZAHL2($B$2:B22)-ZÄHLENWENN($B$2:B22;"Warengruppe?")))
A23=WENN(LINKS(B23;11)="Warengruppe";"POS";WENN(B23="";"";ANZAHL2($B$2:B23)-ZÄHLENWENN($B$2:B23;"Warengruppe?")))
A24=WENN(LINKS(B24;11)="Warengruppe";"POS";WENN(B24="";"";ANZAHL2($B$2:B24)-ZÄHLENWENN($B$2:B24;"Warengruppe?")))
A25=WENN(LINKS(B25;11)="Warengruppe";"POS";WENN(B25="";"";ANZAHL2($B$2:B25)-ZÄHLENWENN($B$2:B25;"Warengruppe?")))
A26=WENN(LINKS(B26;11)="Warengruppe";"POS";WENN(B26="";"";ANZAHL2($B$2:B26)-ZÄHLENWENN($B$2:B26;"Warengruppe?")))
A27=WENN(LINKS(B27;11)="Warengruppe";"POS";WENN(B27="";"";ANZAHL2($B$2:B27)-ZÄHLENWENN($B$2:B27;"Warengruppe?")))
A28=WENN(LINKS(B28;11)="Warengruppe";"POS";WENN(B28="";"";ANZAHL2($B$2:B28)-ZÄHLENWENN($B$2:B28;"Warengruppe?")))
A29=WENN(LINKS(B29;11)="Warengruppe";"POS";WENN(B29="";"";ANZAHL2($B$2:B29)-ZÄHLENWENN($B$2:B29;"Warengruppe?")))
A30=WENN(LINKS(B30;11)="Warengruppe";"POS";WENN(B30="";"";ANZAHL2($B$2:B30)-ZÄHLENWENN($B$2:B30;"Warengruppe?")))

Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML    Download  
Gruss Rainer
Bild

Betrifft: AW: Nummerierung
von: Oliver Ratajczak
Geschrieben am: 05.01.2007 10:10:56
....
Test! Klappt!
Manchmal braucht man einfach einen guten Schubs.
Vielen Dank, das ist des Rätzels Lösung!
Merci
Oliver
 Bild