Herbers Excel-Forum - das Archiv

Urlaubsantraege ausfuellen

Bild

Betrifft: Urlaubsantraege ausfuellen
von: sonja

Geschrieben am: 08.01.2007 19:52:07
Hallo,
ich habe folgendes Problem:
https://www.herber.de/bbs/user/39492.xls
Die beantragten Urlaubstage, in Q5 - AG5,
sollen in B21 - AF32 automatisch eingetragen werden
und mit einem U, für Urlaub, gekennzeichnet werden.
Dabei sollen die Sonn.- und Feiertage berücksichtigt werden.
Kann das funktionieren, auch so dass man es für die nächsten Jahre benutzen kann?
Die beweglichen Feiertage könnten ja evtl. irgendwo händisch eingegeben werden.
Oder geht das auch automatisch?
Ich wäre für Eure Hilfe sehr dankbar. (Mein Chef sicher auch)
Schon einmal Danke und schönen Abend.
Sonja
Bild

Betrifft: AW: Urlaubsantraege ausfuellen
von: Rudi Maintaire

Geschrieben am: 09.01.2007 09:45:38
Hallo,
Jahr in L1, Feiertage in Tabelle2!A2:A21:
Formel in B21:AF32:
=WENN(UND(DATUM($L$1;ZEILE()-20;SPALTE()-1)>=$Q$5;DATUM($L$1;ZEILE()-20;SPALTE()-1)<=$AG$5;WOCHENTAG(DATUM($L$1;ZEILE()-20;SPALTE()-1);2)<6;ZÄHLENWENN(Tabelle2!$A$2:$A$21;DATUM($L$1;ZEILE()-20;SPALTE()-1))=0);"U";"")
Gruß
Rudi
Eine Kuh macht Muh, viele Kühe machen Mühe
Bild

Betrifft: AW: Urlaubsantraege ausfuellen
von: Heinz H

Geschrieben am: 09.01.2007 10:24:08
Hallo Rudi
Habe auch interresse für Deine Formel.
Habe schon selbst probiert ohne Erfolg.
Wie gehört Bitte die Formel abgeändert,habe die Formel für Feiertage im selben Blatt in AR24:AR38
Danke Heinz
Tabelle1
 AR
24Mo   01. Jän.07
25Sa    06. Jän.07
26So    08. Apr.07
27Mo 09. Apr.07
28Di     01. Mai.07
29Do    17. Mai.07
30So    27. Mai.07
31Mo    28. Mai.07
32Do  07. Jun.07
33Mi    15. Aug.07
34Fr      26. Okt.07
35Do   01. Nov.07
36Sa   08. Dez.07
37Di    25. Dez.07
38Mi 26. Dez.07
Formeln der Tabelle
AR24 : =DATUM($L$1;1;1)
AR25 : =DATUM($L$1;1;6)
AR26 : =RUNDEN((TAG(MINUTE($L$1/38)/2+55)&".4."&$L$1)/7;)*7-6
AR27 : =$AR$26+1
AR28 : =DATUM($L$1;5;1)
AR29 : =$AR$26+39
AR30 : =$AR$26+49
AR31 : =$AR$26+50
AR32 : =$AR$26+60
AR33 : =DATUM($L$1;8;15)
AR34 : =DATUM($L$1;10;26)
AR35 : =DATUM($L$1;11;1)
AR36 : =DATUM($L$1;12;8)
AR37 : =DATUM($L$1;12;25)
AR38 : =DATUM($L$1;12;26)
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Bild

Betrifft: AW: Urlaubsantraege ausfuellen
von: Rudi Maintaire

Geschrieben am: 09.01.2007 11:34:37
Hallo,
=WENN(UND(DATUM($L$1;ZEILE()-20;SPALTE()-1)>=$Q$5;DATUM($L$1;ZEILE()-20;SPALTE()-1)<=$AG$5;WOCHENTAG(DATUM($L$1;ZEILE()-20;SPALTE()-1);2)<6;ZÄHLENWENN($AR$24:$AR$38;DATUM($L$1;ZEILE()-20;SPALTE()-1))=0);"U";"")
Gruß
Rudi
Eine Kuh macht Muh, viele Kühe machen Mühe
Bild

Betrifft: AW: Urlaubsantraege ausfuellen
von: Heinz H
Geschrieben am: 09.01.2007 11:45:29
Hallo Rudi
Danke für Deine Formel. Habe beim Test aber immer nur die Fehlermeldung "#NAME?" bekommen.
Weisst Du wo der Fehler liegt ??
Danke & Gruß Heinz
Bild

Betrifft: AW: Urlaubsantraege ausfuellen
von: Rudi Maintaire
Geschrieben am: 09.01.2007 11:59:30
Hallo,
keine Ahnung. Funktionsnamen falsch geschrieben?
Gruß
Rudi
Eine Kuh macht Muh, viele Kühe machen Mühe
Bild

Betrifft: AW: Urlaubsantraege ausfuellen
von: fcs

Geschrieben am: 09.01.2007 12:57:25
Hallo Sonja,
habe Rudi's Formel etwas modifiziert, so dass die Monatskürzel in Spalte A und die Monatstage verwendet werden statt der Zeilen und Spaltennummern. Sowie eine Sonderformel für den 29. Februar eingefügt.
Im Blatt Feiertag werden die Feiertage des in Tabelle1 in Zelle L1 eingegebenen Jahres automatisch berechnet.
https://www.herber.de/bbs/user/39510.xls
Gruß
Franz
Bild

Betrifft: AW: Urlaubsantraege ausfuellen
von: sonja
Geschrieben am: 09.01.2007 19:20:55
Hallo Franz,
Danke für die Hilfe, funktioniert wunderbar.
Kann man evtl. noch die freien Tage (Samstage,Sonn.-u. Feiertage)
schwarz kennzeichnen?
schönen Gruß
sonja
Bild

Betrifft: AW: Urlaubsantraege ausfuellen
von: sonja
Geschrieben am: 09.01.2007 19:15:40
Hallo Rudi,
besten Dank für die Hilfe.
schönen Tag
sonja
 Bild