Microsoft Excel

Herbers Excel/VBA-Archiv

Auto ausfüllen / bearbeiten "falsche" Angaben

Betrifft: Auto ausfüllen / bearbeiten "falsche" Angaben von: andreas.mollet@inolution.com
Geschrieben am: 06.03.2007 15:50:46

Tach ...

Ich bin fast überzeugt, dass das Thema schon mal behandelt wurde, aber das Problem ist dabei wohl die richtige Suche ... leider bin ich dabei gescheitert ...

Also mein Problem ist folgendes:

In Tabelle 1 stehen zugehörige Daten in Spalten (ab Feld C8 abwärts) und ich brauche diese nun in Tabelle 2 in Zeilen Ab Feld N11 aber in Zeilen nach rechts ...

soweit so gut, doch will ich nun meine Formel (die da heisst: [=WENN(intern!C8=0;" ";intern!C8]) per Automatisches Ausfüllen oder einfach ziehen aktualisieren, macht er immer bei der Spaltennummer n+1 anstatt bei der Zeile n+1 ...

Also im Feld O11 steht dann [=WENN(intern!D8=0;" ";intern!D8)] ... ich bräuchte aber [=WENN(intern!C9=0;" ";intern!C9)]

logischwerweise macht er (habe meinen PC je nach Situation Hans oder Fritz getauft ^^) wenn ich nach unten ziehe genauso verkehrt :-( ....

Da es sich doch um einige Daten handelt, suche ich verzeifelt ne Möglichkeit, diese nicht alle manuell eingeben zu müssen ... ach ja, die Datenmenge ist flexibel und wird aus einem externen programm regelmässig abgefüllt, eine einmalige Sache nützt mir also leider nicht ....

Ich danke bereits jetzt und hoffe auf Rettung

Vielen Dank

Andy

PS: Bin sowohl mit Transponieren (da es ja noch keine Werte hat) sowohl mit Matrix (das war mir zu hoch) gescheitert... aber eben ;-) ...

  


Betrifft: AW: Auto ausfüllen / bearbeiten "falsche" Angaben von: AndreasG
Geschrieben am: 06.03.2007 16:19:03

Hallo Andreas,

guckst du hier: http://www.excelformeln.de/formeln.html?welche r=164

Grüsse
Andreas


  


Betrifft: AW: Auto ausfüllen / bearbeiten "falsche" Angaben von: Andreas
Geschrieben am: 07.03.2007 09:43:29

Hallo Namensvetter

Vielen Dank für den Link, mein Problem konnte ich damit zwar nicht lösen, aber ich habe dadurch die richtigen Suchworte für meine Lösung gefunden - Dankeschön ...

Wie ich eigentlich vermutet habe, war meine Lösung viel einfacher, fast schon banal ... (zum Glück hab ich bei Exsel nur gut ausgefüllt ;-) ...

Die Lösung war doch über transponieren möglich ... hier noch die Formel, vielleicht hat ja jemand mal dasselbe Problem:

[=WENN(MTRANS(intern!$B$8:$U$12)=0;" ";(MTRANS(intern!$B$8:$U$12)))]

Der eigentliche Trick war das [Ctrl][Shift][Enter] das mir bis anhin nicht bekannt war

Gruss
Andreas


 

Beiträge aus den Excel-Beispielen zum Thema "Auto ausfüllen / bearbeiten "falsche" Angaben"