Das Archiv des Excel-Forums

String mit Buchstaben & Zahlen suchen und kopieren

Bild

Betrifft: String mit Buchstaben & Zahlen suchen und kopieren
von: maruseru

Geschrieben am: 28.07.2008 11:01:46

Hallo werte Profis
In Spalte C is die ID der Mitarbeiter abgebildet. Nun möchte ich nach allen IDs suchen die ein A und Zahlen (6 Ziffern) enthalten. Die Werte sollen dann jeweils in Spalte D kopiert werden.
Gruss
Maruseru
https://www.herber.de/bbs/user/54168.xls

Bild

Betrifft: AW: String mit Buchstaben & Zahlen suchen und kopieren
von: Tino
Geschrieben am: 28.07.2008 11:17:52
Hallo,
meinst du so?

 CD
1USERIDEMAIL
2A07194 
3A104330A104330
4A104345A104345
5A104497A104497
6A104497A104497
7A104549A104549
8A108077A108077
9A118029A118029
10A294733A294733
11A658077A658077
12A896979A896979
13A993360A993360
14AVONSCAL 
15AWALKE13 
16AZIPPER 
17BDIGIOVA 

Formeln der Tabelle
ZelleFormel
D2=WENN(ZÄHLENWENN(C2;"A??????")>0;WENN(ISTZAHL(--RECHTS(C2;6)); C2;""); "")
D3=WENN(ZÄHLENWENN(C3;"A??????")>0;WENN(ISTZAHL(--RECHTS(C3;6)); C3;""); "")
D4=WENN(ZÄHLENWENN(C4;"A??????")>0;WENN(ISTZAHL(--RECHTS(C4;6)); C4;""); "")
D5=WENN(ZÄHLENWENN(C5;"A??????")>0;WENN(ISTZAHL(--RECHTS(C5;6)); C5;""); "")
D6=WENN(ZÄHLENWENN(C6;"A??????")>0;WENN(ISTZAHL(--RECHTS(C6;6)); C6;""); "")
D7=WENN(ZÄHLENWENN(C7;"A??????")>0;WENN(ISTZAHL(--RECHTS(C7;6)); C7;""); "")
D8=WENN(ZÄHLENWENN(C8;"A??????")>0;WENN(ISTZAHL(--RECHTS(C8;6)); C8;""); "")
D9=WENN(ZÄHLENWENN(C9;"A??????")>0;WENN(ISTZAHL(--RECHTS(C9;6)); C9;""); "")
D10=WENN(ZÄHLENWENN(C10;"A??????")>0;WENN(ISTZAHL(--RECHTS(C10;6)); C10;""); "")
D11=WENN(ZÄHLENWENN(C11;"A??????")>0;WENN(ISTZAHL(--RECHTS(C11;6)); C11;""); "")
D12=WENN(ZÄHLENWENN(C12;"A??????")>0;WENN(ISTZAHL(--RECHTS(C12;6)); C12;""); "")
D13=WENN(ZÄHLENWENN(C13;"A??????")>0;WENN(ISTZAHL(--RECHTS(C13;6)); C13;""); "")
D14=WENN(ZÄHLENWENN(C14;"A??????")>0;WENN(ISTZAHL(--RECHTS(C14;6)); C14;""); "")
D15=WENN(ZÄHLENWENN(C15;"A??????")>0;WENN(ISTZAHL(--RECHTS(C15;6)); C15;""); "")
D16=WENN(ZÄHLENWENN(C16;"A??????")>0;WENN(ISTZAHL(--RECHTS(C16;6)); C16;""); "")
D17=WENN(ZÄHLENWENN(C17;"A??????")>0;WENN(ISTZAHL(--RECHTS(C17;6)); C17;""); "")

Gruß Tino

www.VBA-Excel.de



Bild

Betrifft: AW: geht auch mit WENN u. UND
von: Tino

Geschrieben am: 28.07.2008 11:53:54
Hallo,
dies Funktioniert auch mit nur einer WENN- Funktion in Verbindung mit UND
 CD
1USERIDEMAIL
2A07194 
3A104330A104330
4A104345A104345
5A104497A104497
6A104497A104497
7A104549A104549
8A108077A108077
9A118029A118029
10A294733A294733
11A658077A658077
12A896979A896979
13A993360A993360
14AVONSCAL 
15AWALKE13 
16AZIPPER 
17BDIGIOVA 

Formeln der Tabelle
ZelleFormel
D2=WENN(UND(ISTZAHL(--RECHTS($C2;6)); ZÄHLENWENN($C2;"A??????")=1); $C2;"")
D3=WENN(UND(ISTZAHL(--RECHTS($C3;6)); ZÄHLENWENN($C3;"A??????")=1); $C3;"")
D4=WENN(UND(ISTZAHL(--RECHTS($C4;6)); ZÄHLENWENN($C4;"A??????")=1); $C4;"")
D5=WENN(UND(ISTZAHL(--RECHTS($C5;6)); ZÄHLENWENN($C5;"A??????")=1); $C5;"")
D6=WENN(UND(ISTZAHL(--RECHTS($C6;6)); ZÄHLENWENN($C6;"A??????")=1); $C6;"")
D7=WENN(UND(ISTZAHL(--RECHTS($C7;6)); ZÄHLENWENN($C7;"A??????")=1); $C7;"")
D8=WENN(UND(ISTZAHL(--RECHTS($C8;6)); ZÄHLENWENN($C8;"A??????")=1); $C8;"")
D9=WENN(UND(ISTZAHL(--RECHTS($C9;6)); ZÄHLENWENN($C9;"A??????")=1); $C9;"")
D10=WENN(UND(ISTZAHL(--RECHTS($C10;6)); ZÄHLENWENN($C10;"A??????")=1); $C10;"")
D11=WENN(UND(ISTZAHL(--RECHTS($C11;6)); ZÄHLENWENN($C11;"A??????")=1); $C11;"")
D12=WENN(UND(ISTZAHL(--RECHTS($C12;6)); ZÄHLENWENN($C12;"A??????")=1); $C12;"")
D13=WENN(UND(ISTZAHL(--RECHTS($C13;6)); ZÄHLENWENN($C13;"A??????")=1); $C13;"")
D14=WENN(UND(ISTZAHL(--RECHTS($C14;6)); ZÄHLENWENN($C14;"A??????")=1); $C14;"")
D15=WENN(UND(ISTZAHL(--RECHTS($C15;6)); ZÄHLENWENN($C15;"A??????")=1); $C15;"")
D16=WENN(UND(ISTZAHL(--RECHTS($C16;6)); ZÄHLENWENN($C16;"A??????")=1); $C16;"")
D17=WENN(UND(ISTZAHL(--RECHTS($C17;6)); ZÄHLENWENN($C17;"A??????")=1); $C17;"")

Gruß Tino

www.VBA-Excel.de



Bild

Betrifft: AW: geht auch mit WENN u. UND
von: maruseru
Geschrieben am: 28.07.2008 16:10:28
Hallo Tino
Die zweite Variante ist noch raffinierter.
Frage:
Wie sieht es aus wenn ich neben den IDs A+(6 Ziffern) noch solche mit einen F+(sechs Ziffern) haben?
Ist dies überhaupt möglich?
Gruss
Maruseru

Bild

Betrifft: AW: geht auch mit WENN u. UND
von: Tino

Geschrieben am: 28.07.2008 16:16:54
Hallo,
bin im schwimmbad daher schreibe ich vom pocket, teste mal und mach aus dem A ein ?.
sonst die und-funktion mit einer oder erweitern.
Gruß Tino

Bild

Betrifft: AW: geht auch mit WENN u. UND
von: maruseru
Geschrieben am: 28.07.2008 17:12:43
Hallo Tino
Viel Spass im Schwimmbad. Mit der Hilfe von Martin habe ich nun auch genügend Zeit für einen Abstecher in den See. Auch Dir nochmals als wirklicher Profi vielen Dank für die raschen Antworten, die mir sehr geholfen haben.
Gruss
Maruseru

Bild

Betrifft: AW: geht auch mit WENN u. UND
von: mpb

Geschrieben am: 28.07.2008 16:22:37
Hallo,
=WENN(UND(ISTZAHL(--RECHTS($C3;6)); ODER(ZÄHLENWENN($C3;"A??????")=1;ZÄHLENWENN($C3;"F??????")=1)); $C3;"")
lässt sowohl A+6 Ziffern als auch F+6 Ziffern durch.
Gruß
Martin

Bild

Betrifft: AW: geht auch mit WENN u. UND
von: maruseru
Geschrieben am: 28.07.2008 17:10:38
Hallo Martin
Mich als guter Excel Kenner oder gar Profi zu beschreiben würde Dir und all die anderen wirklichen Könner nicht gerecht werden.
Echt vielen Dank für die rasche Antwort.
Gruss
Maruseru

 Bild

Excel-Beispiele zum Thema "String mit Buchstaben & Zahlen suchen und kopieren"

Nach Textimport Strings in Zahlen wandeln download Textstring in berechenbare Formel umwandeln download
Zahlenstring mit Formel auslesen und Fehlermeldung verhindern download Wertermittlung in Abhängigkeit eines Zeichens in einem String download
Sortierung mit Formel-Leerstrings am Ende download Stringeingaben von HHMM und HHMMSS in Zeit wandeln download
Aufteilen eines Strings mit Zeilenumbrüchen download Aufhebung der Suchstringbegrenzung von 255 Zeichen download
Strings, die wie Zahlen aussehen, in Zahlen umwandeln download Aus einem String mit Datumsangabe das Jahr auslesen download
String mit Prüfziffer über Dialogeingabe erstellen download Teilstrings vergleichen und markieren download
Eingabe in Großbuchstaben wandeln download Nur Buchstaben in eine UserForm-TextBox download
Zeichenfolge in Ziffern und Buchstaben aufteilen download Ersten mit einem neuen Buchstaben beginnenden Namen fett schreiben download
Letzte Zeile mit einem bestimmten Anfangsbuchstaben markieren download Umwandlung einer Zeichenfolge in Spalte A in Großbuchstaben download
In einer Namensliste Großbuchstaben einsetzen download Buchstaben aus Textdatei entfernen und neu speichern download
Buchstabenindex des Arbeitsblattes mit der Fundzelle download Vorkommen von Zahlenreihen in Spalten download
Zeichenfolgen in Zahlen nach Textimport download Zahlenformatierung mit Punkt nach der 1. Ziffer download
Namen von TextBoxes hochzählen download Zählen formatierter Zellen download
Autofilter auch mit Ziffern von Zahlen download Addition der absoluten Zahlen download
Eingabe von positiven Zahlen erzwingen download Zufallszahlen generieren, die sich nicht wiederholen download
Summenformel unter Zahlenreihe eintragen download Nur AJM in TextBox akzeptieren und Anzahl zählen download
Teilergebnisse in Zahlenreihe eintragen und löschen download Alle Formeln und Zahlen löschen download
Werte nur mit Zahlenformaten übertragen download Worte in einem vorgegebenen Bereich zählen download
Anzahl in einer Liste vorkommender Namen zählen download Zellwerte über SpinButton und ScrollBar hochzählen download
Label in Zelle A1 bei jedem Ausdruck um 1 hochzählen download Anzahl Artikelnummern auf Deckblatt nach Blättern zählen download
Als Text vorhandene Werte in Zahlen umwandeln download Den jeweils letzten Wert einer Zahlenreihe als Multiplikator download
Mittelwert einer Zahlenreihe bis zur Zeile mit der Formel download Lottozahlen-Generator download
Lücken aus Zahlenreihe listen download Zahlen in Abhängigkeit von ihrem Wert multiplizieren download
Gleiche Zufallszahlen zählen und in Diagramm anzeigen download Zufallszahlen bis zum 4-fachen Wert generieren download
Reihenfolge einer Zahlenreihe nach dem Zufallsprinzip variieren download Anzeige eines Zahlwortes synchron zur Textbox-Zahleneingabe download
Zahlen unter Berücksichtigung von Monat und Jahr summieren download Tabelle gem. hinterlegten Zahlenformaten formatieren download
Zählen von in einer Formel vorkommenden Zahlen download Addition der 10 höchsten Werte einer Zahlenreihe download
Spaltenbreite gemäß den in den Zellen stehenden Zahlen festlegen download Zeilen zählen, in denen zwei Bedingungen zutreffen download
Leerzeichen zwischen Zeichen- und Zahlenfolge entfernen download Alle Zellen mit einer vorgegebenen Hintergrundfarbe zählen download
Zahlen eines Bereiches jeweils 4 mal in eine Spalte schreiben. download Kennzeichnung von Lottogewinnzahlen download
Zahlen-Formatierungs-Dialog aus UserForm aufrufen download Zahlenmarkierungen in einer Lottoliste download
Datensätze zählen, die in einigen Spalten identisch sind download Zeit in vorgegebenem Intervall hochzählen download
Alle ungeraden Zahlen markieren download Zeichen als Zahlen darstellen download
Teilungszahlen und Sitzfolge nach dem Höchstzahlverfahren download Eingeblendete Zeilen mit Werten zählen download
Zellinhalt suchen und Zelle auswählen download Suchbegriff über mehrere Tabellenblätter suchen. download
Suchen und weitersuchen download Zahl +/- 1 suchen download
Ein Zeichen in einer Formel suchen download Datum suchen und Wert eintragen download
Wert in Tabelle suchen und in UserForm ausgeben download Letzte Zelle mit Inhalt suchen download
Textdatei nach Begriff durchsuchen und Fundzeile importieren download Wert in Array suchen, ohne jedes Datenfeld abzufragen download
Wert in Tabellenblatt suchen und alle Fundwerte in zweite Tabelle download Begriffe in ausgeblendeter Spalte suchen und Fundzeile markieren download
Wert aus UserForm-TextBox in Tabelle suchen und in ListBox listen download Suchbegriff aus einer UserForm-Textbox in Tabelle suchen und melden download
Suchwert in zweiter Tabelle suchen und Fundzeile eintragen download Suchen von Nachnamen in Zeichenfolgen download
Dateien in einem Verzeichnis und Unterverzeichnissen suchen download Datum suchen und Adresse der Fundzelle ausgeben download
Begriffe in zweiter Tabelle suchen und Werte anfügen download Text aus UserForm-TextBox in Tabelle suchen download
Zweidimensionale Matrix mit der SVERWEIS-Funktion durchsuchen download Suchbegriff in vorhergehenden Tabellen suchen download
Werte aus UserForm-ComboBox suchen und Fundstelle kopieren download Neueste Textdatei eines Verzeichnisses suchen und umbenennen download
Artikelnummern suchen und jeweils letzte Fundstelle listen download Wörter eines Satzes in Indizliste suchen download
Wert aus UserForm-TextBox suchen und Fundstelle kopieren download Zellwert nach Doppelklick in Tabelle suchen download
Suchen in 2. Tabelle und Ersetzen der Quelldaten download Wert in Tabelle 2 suchen und Fundstellen übertragen download
Suchbegriff in Tabelle suchen und Fundzeilen auswählen download Suchbegriffe aus Tabelle im Excel-WebArchiv suchen download
Wert aus ComboBox in TextBox, dann in Tabelle suchen download Artikelnummer über InputBox suchen und eintragen download
Anwendung auf Fesplatte suchen download Tabelle nach ComboBox-Auswahl durchsuchen download
Werte suchen, eintragen und löschen download Zeile 1 nach Wert der aktiven Zelle durchsuchen download
Suchbegriff in Tabelle suchen und Fundzeilenindex zurückgeben download Wert in zweiter Tabelle suchen und als Kommentar ausgeben download
Wert in externer Mappe suchen und mit Format übernehmen. download Artikelnummern nach Kriterien suchen und Datensätze kopieren download
Wert in ComboBox einlesen, suchen, editieren, ausgeben download Grafikdateien suchen download
Suchen der Nachbarzelle der Zelle mit dem Maximalwert download Text in Textdateien suchen und Fundzeilen in Tabelle ausgeben download
Begriff suchen und Fundzeilen in anderes Blatt kopieren download Zahl suchen und an den Fundstellen Zeile einfügen download
Name und Vorname suchen, Werte und Fundstellen importieren download Begriff in der ersten Spalte einer ListBox suchen download
Blätter in andere Arbeitsmappen kopieren download Module von Mappe zu Mappe kopieren download
Arbeitsblatt 40 mal kopieren download Schriftgröße beim Kopieren verdoppeln download
Beim Kopieren auch die Zeilenhöhe und Spaltenbreite übernehmen download Tabellencode nach Kopieren des Blattes löschen download
Arbeitsmappe blitzschnell kopieren download VBE-Namen der Blattmodule beim Kopieren festlegen download
Blattinhalt von einer zur anderen Arbeitsmappe kopieren download Formel bis zur letzten Zeile der Nebenspalte kopieren download
Datei kopieren, wenn noch nicht vorhanden download Zeilenweise von Blatt zu Blatt kopieren download
Erste Druckseite in eine neue Arbeitsmappe kopieren download Durch DoppelKlick Spalte in zweites Arbeitsblatt kopieren download
Teilergebnisse einer Serie von Tabellen in anderes Blatt kopieren download Bei Eintrag in Spalte A aktuelle Zeile kopieren download
Filtern und Kopieren download Zeile mit aktiver Zelle in anderes Blatt kopieren download
Zeilen in Abhängigkeit des Wertes in Spalte A kopieren download Einen von einer Schlüsselziffer abhängigen Bereich kopieren download
Vorgegebene Anzahl von Einträgen in 2. Blatt kopieren download Über InputBox festzulegenden Bereich kopieren download
Passwortgeschützte Mappe öffnen, Daten kopieren, schliessen download Tabellenblatt kopieren und dreistellig fortlaufend numerieren download
Jede zweite Zelle kopieren download Gruppe von Optionsfeldern kopieren und Makro zuweisen download
Nicht zusammenhängenden Bereich in nächste Zeile kopieren download Nur sichtbare Zellen in anderes Arbeitsblatt kopieren download
Zeile in Abhängigkeit zur Eingabe in Blätter kopieren download Werte prüfen und kopieren download
Bei Eintrag von X Zeile in andere Tabelle kopieren download Daten kopieren wenn kein Datum oder Datum > Heute download
Blattinhalte dreier Blätter in neues Blatt kopieren download Kopieren und Umbenennen eines Blattes download
Nur Zeilen mit bestimmtem Inhalt kopieren download Bild in zweites Blatt an gleiche Position kopieren download
Alle Zeilen ohne Wert in vorgegebener Spalte kopieren download Bei Eintrag Zeile in 2. Blatt kopieren und Tabellen sortieren download
Bildergruppe in anderes Blatt kopieren download Bei Eingabe Formel in der Nebenspalte nach unten kopieren download
Auswahl in andere Arbeitsmappe kopieren, speichern, schließen download Aktive Zeile kopieren und löschen download
Datensätze, die öfter als 3 mal vorkommen, kopieren download Den jeweils darüberliegenden Wert in Leerzellen kopieren download
Alle Zeilen mit einem Suchbegriff in nächstes Blatt kopieren download Dateien listen und Blätter in neue Arbeitsmappe kopieren download