Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

String mit Buchstaben & Zahlen suchen und kopieren

String mit Buchstaben & Zahlen suchen und kopieren
28.07.2008 11:01:00
maruseru
Hallo werte Profis
In Spalte C is die ID der Mitarbeiter abgebildet. Nun möchte ich nach allen IDs suchen die ein A und Zahlen (6 Ziffern) enthalten. Die Werte sollen dann jeweils in Spalte D kopiert werden.
Gruss
Maruseru
https://www.herber.de/bbs/user/54168.xls

7
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: String mit Buchstaben & Zahlen suchen und kopieren
28.07.2008 11:17:52
Tino
Hallo,
meinst du so?
 CD
1USERIDEMAIL
2A07194 
3A104330A104330
4A104345A104345
5A104497A104497
6A104497A104497
7A104549A104549
8A108077A108077
9A118029A118029
10A294733A294733
11A658077A658077
12A896979A896979
13A993360A993360
14AVONSCAL 
15AWALKE13 
16AZIPPER 
17BDIGIOVA 

Formeln der Tabelle
ZelleFormel
D2=WENN(ZÄHLENWENN(C2;"A?")>0;WENN(ISTZAHL(--RECHTS(C2;6)); C2;""); "")
D3=WENN(ZÄHLENWENN(C3;"A?")>0;WENN(ISTZAHL(--RECHTS(C3;6)); C3;""); "")
D4=WENN(ZÄHLENWENN(C4;"A?")>0;WENN(ISTZAHL(--RECHTS(C4;6)); C4;""); "")
D5=WENN(ZÄHLENWENN(C5;"A?")>0;WENN(ISTZAHL(--RECHTS(C5;6)); C5;""); "")
D6=WENN(ZÄHLENWENN(C6;"A?")>0;WENN(ISTZAHL(--RECHTS(C6;6)); C6;""); "")
D7=WENN(ZÄHLENWENN(C7;"A?")>0;WENN(ISTZAHL(--RECHTS(C7;6)); C7;""); "")
D8=WENN(ZÄHLENWENN(C8;"A?")>0;WENN(ISTZAHL(--RECHTS(C8;6)); C8;""); "")
D9=WENN(ZÄHLENWENN(C9;"A?")>0;WENN(ISTZAHL(--RECHTS(C9;6)); C9;""); "")
D10=WENN(ZÄHLENWENN(C10;"A?")>0;WENN(ISTZAHL(--RECHTS(C10;6)); C10;""); "")
D11=WENN(ZÄHLENWENN(C11;"A?")>0;WENN(ISTZAHL(--RECHTS(C11;6)); C11;""); "")
D12=WENN(ZÄHLENWENN(C12;"A?")>0;WENN(ISTZAHL(--RECHTS(C12;6)); C12;""); "")
D13=WENN(ZÄHLENWENN(C13;"A?")>0;WENN(ISTZAHL(--RECHTS(C13;6)); C13;""); "")
D14=WENN(ZÄHLENWENN(C14;"A?")>0;WENN(ISTZAHL(--RECHTS(C14;6)); C14;""); "")
D15=WENN(ZÄHLENWENN(C15;"A?")>0;WENN(ISTZAHL(--RECHTS(C15;6)); C15;""); "")
D16=WENN(ZÄHLENWENN(C16;"A?")>0;WENN(ISTZAHL(--RECHTS(C16;6)); C16;""); "")
D17=WENN(ZÄHLENWENN(C17;"A?")>0;WENN(ISTZAHL(--RECHTS(C17;6)); C17;""); "")

Gruß Tino

www.VBA-Excel.de


Anzeige
AW: geht auch mit WENN u. UND
28.07.2008 11:53:54
Tino
Hallo,
dies Funktioniert auch mit nur einer WENN- Funktion in Verbindung mit UND
 CD
1USERIDEMAIL
2A07194 
3A104330A104330
4A104345A104345
5A104497A104497
6A104497A104497
7A104549A104549
8A108077A108077
9A118029A118029
10A294733A294733
11A658077A658077
12A896979A896979
13A993360A993360
14AVONSCAL 
15AWALKE13 
16AZIPPER 
17BDIGIOVA 

Formeln der Tabelle
ZelleFormel
D2=WENN(UND(ISTZAHL(--RECHTS($C2;6)); ZÄHLENWENN($C2;"A?")=1); $C2;"")
D3=WENN(UND(ISTZAHL(--RECHTS($C3;6)); ZÄHLENWENN($C3;"A?")=1); $C3;"")
D4=WENN(UND(ISTZAHL(--RECHTS($C4;6)); ZÄHLENWENN($C4;"A?")=1); $C4;"")
D5=WENN(UND(ISTZAHL(--RECHTS($C5;6)); ZÄHLENWENN($C5;"A?")=1); $C5;"")
D6=WENN(UND(ISTZAHL(--RECHTS($C6;6)); ZÄHLENWENN($C6;"A?")=1); $C6;"")
D7=WENN(UND(ISTZAHL(--RECHTS($C7;6)); ZÄHLENWENN($C7;"A?")=1); $C7;"")
D8=WENN(UND(ISTZAHL(--RECHTS($C8;6)); ZÄHLENWENN($C8;"A?")=1); $C8;"")
D9=WENN(UND(ISTZAHL(--RECHTS($C9;6)); ZÄHLENWENN($C9;"A?")=1); $C9;"")
D10=WENN(UND(ISTZAHL(--RECHTS($C10;6)); ZÄHLENWENN($C10;"A?")=1); $C10;"")
D11=WENN(UND(ISTZAHL(--RECHTS($C11;6)); ZÄHLENWENN($C11;"A?")=1); $C11;"")
D12=WENN(UND(ISTZAHL(--RECHTS($C12;6)); ZÄHLENWENN($C12;"A?")=1); $C12;"")
D13=WENN(UND(ISTZAHL(--RECHTS($C13;6)); ZÄHLENWENN($C13;"A?")=1); $C13;"")
D14=WENN(UND(ISTZAHL(--RECHTS($C14;6)); ZÄHLENWENN($C14;"A?")=1); $C14;"")
D15=WENN(UND(ISTZAHL(--RECHTS($C15;6)); ZÄHLENWENN($C15;"A?")=1); $C15;"")
D16=WENN(UND(ISTZAHL(--RECHTS($C16;6)); ZÄHLENWENN($C16;"A?")=1); $C16;"")
D17=WENN(UND(ISTZAHL(--RECHTS($C17;6)); ZÄHLENWENN($C17;"A?")=1); $C17;"")

Gruß Tino

www.VBA-Excel.de


Anzeige
AW: geht auch mit WENN u. UND
28.07.2008 16:10:00
maruseru
Hallo Tino
Die zweite Variante ist noch raffinierter.
Frage:
Wie sieht es aus wenn ich neben den IDs A+(6 Ziffern) noch solche mit einen F+(sechs Ziffern) haben?
Ist dies überhaupt möglich?
Gruss
Maruseru

AW: geht auch mit WENN u. UND
28.07.2008 16:16:54
Tino
Hallo,
bin im schwimmbad daher schreibe ich vom pocket, teste mal und mach aus dem A ein ?.
sonst die und-funktion mit einer oder erweitern.
Gruß Tino

AW: geht auch mit WENN u. UND
28.07.2008 17:12:00
maruseru
Hallo Tino
Viel Spass im Schwimmbad. Mit der Hilfe von Martin habe ich nun auch genügend Zeit für einen Abstecher in den See. Auch Dir nochmals als wirklicher Profi vielen Dank für die raschen Antworten, die mir sehr geholfen haben.
Gruss
Maruseru

Anzeige
AW: geht auch mit WENN u. UND
28.07.2008 16:22:00
mpb
Hallo,
=WENN(UND(ISTZAHL(--RECHTS($C3;6)); ODER(ZÄHLENWENN($C3;"A?")=1;ZÄHLENWENN($C3;"F?")=1)); $C3;"")
lässt sowohl A+6 Ziffern als auch F+6 Ziffern durch.
Gruß
Martin

AW: geht auch mit WENN u. UND
28.07.2008 17:10:38
maruseru
Hallo Martin
Mich als guter Excel Kenner oder gar Profi zu beschreiben würde Dir und all die anderen wirklichen Könner nicht gerecht werden.
Echt vielen Dank für die rasche Antwort.
Gruss
Maruseru

301 Forumthreads zu ähnlichen Themen


Hallo,
ich bin ein VBA Neuling und der Makroaufzeichner bringt mich nicht weiter, da dieser immer selectiert und aktiviert.
Ich brauche ein etwas allgemeineren Code.
Ok was ich habe sind folgende Inputdaten:
.............A......B.........C.............D
1
2............
Anzeige

Hallo,
ich habe da ein kleines Problem, vielleicht kann mir hier geholfen werden.
In einer Tabelle stehen in der ersten Spalte (A) die fld. Nr. 1 bis 10 und in der Spalte (B) dazu gehörige Zahlenreihen, in der weiteren Spalte (D) fld. Nr. 11 bis 20 und in Spalte (E) wieder die dazu gehö...

Hi,
ich möchte gerne folgendes per Makro erledigen:
Ich habe eine Exceltabelle "IMPORT", in der gibt es ziemlich viele Datensätze (geht von A bis M und runter ab Zeile10 bis je nachdem bis 500 oder 1000)
In der Tabelle gibt es Datensätze, die würde ich gerne automatisch (oder bess...
Anzeige

Hallo Fachleute,
Ich stecke bei folgendem Excel problem fest:
Ich habe eine relativ komplexe Exceldatei mit der ich die Ergebnisse aus einem Simulationsprogramm auswerte. Alle Auswertung bezieht sich auf Werte aus einem Blatt "Datei" mit einer festen Struktur. D.h. ich habe in Zelle A 1...

Schönen guten Abend!
Ich habe folgendes "Problem":
Im Feld A1 steht ein längerer Text, welcher nach mehreren bestimmten Ausdrücken(zB. "1]","2]","3]","4]") durchsucht werden soll. Immer wenn einer dieser Ausdrücke gefunden wird, soll der gefundene Ausdruck in das jeweils nächste leere F...

Schönen guten Tag!
Ich habe folgendes "Problem":
Im Feld A1 steht ein längerer Text, welcher nach mehreren bestimmten Ausdrücken(zB. "1]","2]","3]","4]") durchsucht werden soll. Immer wenn einer dieser Ausdrücke gefunden wird, soll der gefundene Ausdruck in das jeweils nächste leere Fel...
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige