Microsoft Excel

Herbers Excel/VBA-Archiv

String mit Buchstaben & Zahlen suchen und kopieren

Betrifft: String mit Buchstaben & Zahlen suchen und kopieren von: maruseru
Geschrieben am: 28.07.2008 11:01:46

Hallo werte Profis

In Spalte C is die ID der Mitarbeiter abgebildet. Nun möchte ich nach allen IDs suchen die ein A und Zahlen (6 Ziffern) enthalten. Die Werte sollen dann jeweils in Spalte D kopiert werden.

Gruss
Maruseru

https://www.herber.de/bbs/user/54168.xls

  

Betrifft: AW: String mit Buchstaben & Zahlen suchen und kopieren von: Tino
Geschrieben am: 28.07.2008 11:17:52

Hallo,
meinst du so?

 CD
1USERIDEMAIL
2A07194 
3A104330A104330
4A104345A104345
5A104497A104497
6A104497A104497
7A104549A104549
8A108077A108077
9A118029A118029
10A294733A294733
11A658077A658077
12A896979A896979
13A993360A993360
14AVONSCAL 
15AWALKE13 
16AZIPPER 
17BDIGIOVA 

Formeln der Tabelle
ZelleFormel
D2=WENN(ZÄHLENWENN(C2;"A??????")>0;WENN(ISTZAHL(--RECHTS(C2;6)); C2;""); "")
D3=WENN(ZÄHLENWENN(C3;"A??????")>0;WENN(ISTZAHL(--RECHTS(C3;6)); C3;""); "")
D4=WENN(ZÄHLENWENN(C4;"A??????")>0;WENN(ISTZAHL(--RECHTS(C4;6)); C4;""); "")
D5=WENN(ZÄHLENWENN(C5;"A??????")>0;WENN(ISTZAHL(--RECHTS(C5;6)); C5;""); "")
D6=WENN(ZÄHLENWENN(C6;"A??????")>0;WENN(ISTZAHL(--RECHTS(C6;6)); C6;""); "")
D7=WENN(ZÄHLENWENN(C7;"A??????")>0;WENN(ISTZAHL(--RECHTS(C7;6)); C7;""); "")
D8=WENN(ZÄHLENWENN(C8;"A??????")>0;WENN(ISTZAHL(--RECHTS(C8;6)); C8;""); "")
D9=WENN(ZÄHLENWENN(C9;"A??????")>0;WENN(ISTZAHL(--RECHTS(C9;6)); C9;""); "")
D10=WENN(ZÄHLENWENN(C10;"A??????")>0;WENN(ISTZAHL(--RECHTS(C10;6)); C10;""); "")
D11=WENN(ZÄHLENWENN(C11;"A??????")>0;WENN(ISTZAHL(--RECHTS(C11;6)); C11;""); "")
D12=WENN(ZÄHLENWENN(C12;"A??????")>0;WENN(ISTZAHL(--RECHTS(C12;6)); C12;""); "")
D13=WENN(ZÄHLENWENN(C13;"A??????")>0;WENN(ISTZAHL(--RECHTS(C13;6)); C13;""); "")
D14=WENN(ZÄHLENWENN(C14;"A??????")>0;WENN(ISTZAHL(--RECHTS(C14;6)); C14;""); "")
D15=WENN(ZÄHLENWENN(C15;"A??????")>0;WENN(ISTZAHL(--RECHTS(C15;6)); C15;""); "")
D16=WENN(ZÄHLENWENN(C16;"A??????")>0;WENN(ISTZAHL(--RECHTS(C16;6)); C16;""); "")
D17=WENN(ZÄHLENWENN(C17;"A??????")>0;WENN(ISTZAHL(--RECHTS(C17;6)); C17;""); "")




Gruß Tino

www.VBA-Excel.de




  

Betrifft: AW: geht auch mit WENN u. UND von: Tino
Geschrieben am: 28.07.2008 11:53:54

Hallo,
dies Funktioniert auch mit nur einer WENN- Funktion in Verbindung mit UND

 CD
1USERIDEMAIL
2A07194 
3A104330A104330
4A104345A104345
5A104497A104497
6A104497A104497
7A104549A104549
8A108077A108077
9A118029A118029
10A294733A294733
11A658077A658077
12A896979A896979
13A993360A993360
14AVONSCAL 
15AWALKE13 
16AZIPPER 
17BDIGIOVA 

Formeln der Tabelle
ZelleFormel
D2=WENN(UND(ISTZAHL(--RECHTS($C2;6)); ZÄHLENWENN($C2;"A??????")=1); $C2;"")
D3=WENN(UND(ISTZAHL(--RECHTS($C3;6)); ZÄHLENWENN($C3;"A??????")=1); $C3;"")
D4=WENN(UND(ISTZAHL(--RECHTS($C4;6)); ZÄHLENWENN($C4;"A??????")=1); $C4;"")
D5=WENN(UND(ISTZAHL(--RECHTS($C5;6)); ZÄHLENWENN($C5;"A??????")=1); $C5;"")
D6=WENN(UND(ISTZAHL(--RECHTS($C6;6)); ZÄHLENWENN($C6;"A??????")=1); $C6;"")
D7=WENN(UND(ISTZAHL(--RECHTS($C7;6)); ZÄHLENWENN($C7;"A??????")=1); $C7;"")
D8=WENN(UND(ISTZAHL(--RECHTS($C8;6)); ZÄHLENWENN($C8;"A??????")=1); $C8;"")
D9=WENN(UND(ISTZAHL(--RECHTS($C9;6)); ZÄHLENWENN($C9;"A??????")=1); $C9;"")
D10=WENN(UND(ISTZAHL(--RECHTS($C10;6)); ZÄHLENWENN($C10;"A??????")=1); $C10;"")
D11=WENN(UND(ISTZAHL(--RECHTS($C11;6)); ZÄHLENWENN($C11;"A??????")=1); $C11;"")
D12=WENN(UND(ISTZAHL(--RECHTS($C12;6)); ZÄHLENWENN($C12;"A??????")=1); $C12;"")
D13=WENN(UND(ISTZAHL(--RECHTS($C13;6)); ZÄHLENWENN($C13;"A??????")=1); $C13;"")
D14=WENN(UND(ISTZAHL(--RECHTS($C14;6)); ZÄHLENWENN($C14;"A??????")=1); $C14;"")
D15=WENN(UND(ISTZAHL(--RECHTS($C15;6)); ZÄHLENWENN($C15;"A??????")=1); $C15;"")
D16=WENN(UND(ISTZAHL(--RECHTS($C16;6)); ZÄHLENWENN($C16;"A??????")=1); $C16;"")
D17=WENN(UND(ISTZAHL(--RECHTS($C17;6)); ZÄHLENWENN($C17;"A??????")=1); $C17;"")




Gruß Tino

www.VBA-Excel.de




  

Betrifft: AW: geht auch mit WENN u. UND von: maruseru
Geschrieben am: 28.07.2008 16:10:28

Hallo Tino

Die zweite Variante ist noch raffinierter.
Frage:
Wie sieht es aus wenn ich neben den IDs A+(6 Ziffern) noch solche mit einen F+(sechs Ziffern) haben?
Ist dies überhaupt möglich?

Gruss
Maruseru


  

Betrifft: AW: geht auch mit WENN u. UND von: Tino
Geschrieben am: 28.07.2008 16:16:54

Hallo,
bin im schwimmbad daher schreibe ich vom pocket, teste mal und mach aus dem A ein ?.
sonst die und-funktion mit einer oder erweitern.

Gruß Tino


  

Betrifft: AW: geht auch mit WENN u. UND von: maruseru
Geschrieben am: 28.07.2008 17:12:43

Hallo Tino

Viel Spass im Schwimmbad. Mit der Hilfe von Martin habe ich nun auch genügend Zeit für einen Abstecher in den See. Auch Dir nochmals als wirklicher Profi vielen Dank für die raschen Antworten, die mir sehr geholfen haben.

Gruss
Maruseru


  

Betrifft: AW: geht auch mit WENN u. UND von: mpb
Geschrieben am: 28.07.2008 16:22:37

Hallo,

=WENN(UND(ISTZAHL(--RECHTS($C3;6)); ODER(ZÄHLENWENN($C3;"A??????")=1;ZÄHLENWENN($C3;"F??????")=1)); $C3;"")

lässt sowohl A+6 Ziffern als auch F+6 Ziffern durch.

Gruß
Martin


  

Betrifft: AW: geht auch mit WENN u. UND von: maruseru
Geschrieben am: 28.07.2008 17:10:38

Hallo Martin

Mich als guter Excel Kenner oder gar Profi zu beschreiben würde Dir und all die anderen wirklichen Könner nicht gerecht werden.
Echt vielen Dank für die rasche Antwort.

Gruss
Maruseru


 

Beiträge aus den Excel-Beispielen zum Thema "String mit Buchstaben & Zahlen suchen und kopieren"