Microsoft Excel

Herbers Excel/VBA-Archiv

Datum und dazugehöriger Wert addieren | Herbers Excel-Forum


Betrifft: Datum und dazugehöriger Wert addieren von: Hans
Geschrieben am: 09.01.2010 12:40:50

Hallo Leute,

ich habe ein Problem bei einer Auswertung.

Ich möchte die Anzahl eines jeden Tages einer Spalte haben .. und dann die Summe der Werte die eine Spalte daneben stehen.

Also in Spalte A stehten untereinander das Datum ... und in Spalte B die dazugehörigen Werte.

Als Beispiel .. ich benötige eine Formel die mit die Anzahl der Daten vom 02.12.2009 ausgibt und die Summer der jeweils daneben stehenden Preis.

Ich hoffe jemand kann mir helfen

  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Hajo_Zi
Geschrieben am: 09.01.2010 12:43:46

Hallo Hans,

Summewenn()

GrußformelHomepage


  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Josef Ehrensberger
Geschrieben am: 09.01.2010 12:45:29

Hallo Hans,

Tabelle1

 ABCDEFGH
1DatumWert  DatumAnzahlSumme 
201.12.200910  02.12.2009345 
301.12.200920      
402.12.200915      
502.12.200920      
602.12.200910      
703.12.200920      

Formeln der Tabelle
ZelleFormel
F2=ZÄHLENWENN(A:A;E2)
G2=SUMMEWENN(A:A;E2;B:B)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Hans
Geschrieben am: 09.01.2010 12:58:26

Danke euch Beiden

Ich hatte es auch so .. aber es Funktionierte nich.

Nun weiss ich auch weshalb ... Das Datum wird per VBA in die Tabelle eingetragen und steht dort mit der Uhrzeit .. also zb 01.12.2009 12:22:44

Könnt Ihr mir helfen wie ich
a) die vorhandenen Werte auf das reine Datum im Format TT:MM:JJJJ ändern kann. Wenn ich es über "Zelle formatieren" änderen will funktioniert es nicht.

b) wie ich das Format des Datums im VBA festlegen kann das es in den o.g. Format gespeichert wird.

Gruß Hans


  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Hajo_Zi
Geschrieben am: 09.01.2010 13:05:35

Hallo Hans,


Tabelle1

 ABCDEF
24DatumWert    DatumSumme
251.12.09 7:2310    01.12.200930
261.12.09 9:2320       
272.12.09 0:0015       
282.12.09 0:0020       
292.12.09 0:0010       
303.12.09 0:0020       

verwendete Formeln
Zelle Formel
F25 {=SUMME(WENN(TEXT(A25:A30;"TT.MM.JJ")*1=E25;B25:B30))}
{} Matrixformel mit Strg+Umschalt+Enter abschließen

Tabellendarstellung in Foren Version 5.3



Gruß Hajo


  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Josef Ehrensberger
Geschrieben am: 09.01.2010 13:07:46

Hallo Hans,

zu 1: Lass mal diesen Code über die Tabelle laufen, evtl. Bereich anpassen.

' **********************************************************************
' Modul: Modul2 Typ: Allgemeines Modul
' **********************************************************************

Option Explicit

Sub uhrzeitentfernen()
  Dim rng As Range
  
  For Each rng In Range("A:A").SpecialCells(xlCellTypeConstants, xlNumbers)
    If IsDate(rng) Then rng = Clng(rng)
  Next
  
End Sub


Zu 2: Das hängt vom Code ab. Evtl. mit CLng(), aber zeig doch mal den Code.


Gruß Sepp



  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Hans
Geschrieben am: 09.01.2010 13:28:14

Ich habe eine Zelle in der mit "=jetzt()" das Datum .. der Name der Zelle ist auch "Datum

Im VBA nutze ich einfach diese Zelle mit

Selection.Offset(0, 3) = Datum

lg

Hans


  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Josef Ehrensberger
Geschrieben am: 09.01.2010 13:32:24

Hallo Hans,

warum der Umweg über eine Zelle? Warum Selection?

Selection.Offset(0, 3) = Date

Gruß Sepp



  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Hans
Geschrieben am: 09.01.2010 13:46:19

Hallo Sepp, danke für die Hilfe.

Das VBA Skript schreibt alle Wert die in einem Tabellenblatt eingegeben werden in eine Zeile in der Datei Auftrag.xls

 .....     
 Datum = Range("datum")
        
        Windows("Auftrag.xls").Activate
        With Sheets("Daten").Range("A1:A" & Cells(Rows.Count, 1).End(xlUp).Row)
            Set c = .Find(spe8, LookIn:=xlValues)
                If Not c Is Nothing Then
                    c.Select
                    GoTo weiter
                End If
                Cells(Cells(Rows.Count, 1).End(xlUp).Row + 1, 1).Select 'letzte leere zelle
                GoTo weiter
        End With
weiter:
        ActiveCell.Select
        ActiveCell = spe8
        Selection.Offset(0, 1) = RechnungsNr
        Selection.Offset(0, 2) = KundenNr
        Selection.Offset(0, 3) = GeraeteNummer
        Selection.Offset(0, 4) = ExterneNummer
        Selection.Offset(0, 5) = AuftragsDatum
        Selection.Offset(0, 6) = RechnungsDatum
......
ActiveWorkbook.Save


Noch etwas, bei dem Skript das du mir zum löschen der Uhrzeit gegeben hast entsteht ein problem

ab 12 Uhr wird es auf den nächten Tag geschrieben.

lg

Hans


  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: BoskoBiati
Geschrieben am: 09.01.2010 13:55:22

Hallo,

die Formel geht auch mit Deinen Werten, wenn man sie etwas abwandelt:

Tabelle2

 ABCDE
915.12.2009 10:30415.12.200929
1015.12.2009 11:005   
1116.12.2009 10:007   
1217.12.2009 08:008   

Formeln der Tabelle
ZelleFormel
D9=ZÄHLENWENN(A9:A12;">="&C9)-ZÄHLENWENN(A9:A12;">="&C9+1)
E9=SUMMENPRODUKT((A9:A12>=C9)*(A9:A12<C9+1)*(B9:B12))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß

Bosko


  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Josef Ehrensberger
Geschrieben am: 09.01.2010 14:07:21

Hallo Hans,

hab ehrlichgesagt, keine Lust diesen Code aufzudröseln, da sind mir zuviele Activates und Selects drinnen.
Ausserdem ist das ja nur ein Teil des Codes.

Nimm diese Formeln, das sollte funzen.

Tabelle1

 ABCDEFGH
1DatumWert  DatumAnzahlSumme 
201.12.200910  02.12.2009345 
301.12.200920      
402.12.200915      
502.12.200920      
602.12.200910      
703.12.200920      
8        

Formeln der Tabelle
ZelleFormel
F2=SUMMENPRODUKT((GANZZAHL(A2:A1000)=E2)*1)
G2=SUMMENPRODUKT((GANZZAHL(A2:A1000)=E2)*B2:B1000)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4




Gruß Sepp



  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Hans
Geschrieben am: 09.01.2010 15:08:26

Ihr seit klasse und habt mein Wochenende gerettet.

Eine Frage habe ich noch .... dann gebe ich auch Ruhe.

Das letzte Beispiel von Sepp funktioniert 1A

=SUMMENPRODUKT((GANZZAHL(A2:A1000)=E2)*B2:B1000)
Wie müsste die Formel lauten wenn eine weitere Bedingung erfüllt ist.
In Spalte C stehen Zahlen
Es soll die Gesammtsumme gezählt werden wenn das Datum stimmt UND der Wert in Spalte C z.b 333 ist.

https://www.herber.de/bbs/user/67102.xls


lg
Hans


  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: BoskoBiati
Geschrieben am: 09.01.2010 15:14:23

Hallo,

dann einfach noch *(c1:c100=333) einfügen.

Gruß

Bosko


  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Hajo_Zi
Geschrieben am: 09.01.2010 13:12:17

Hallo Hans,

es ist mir jetzt erst beim zweiten lesen aufgefallen. Ist es vielleicht kein Datum sondern Text? Mal mit TYp() prüfen.

Gruß Hajo


  

Betrifft: AW: Datum und dazugehöriger Wert addieren von: Hans
Geschrieben am: 09.01.2010 13:51:19

Hallo Hajo ..

bei TYP () kommt eine 1 raus

Gruß Hans


Beiträge aus den Excel-Beispielen zum Thema "Datum und dazugehöriger Wert addieren"