Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
524to528
524to528
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Datum Sortieren - Anfügen der Jahreszahl

Datum Sortieren - Anfügen der Jahreszahl
01.12.2004 15:50:20
Joe
Hallo,
Ich schreib grad ein Programm, welches verschiedene Daten, z.b. Liefertemine oder Fertigstellungsdaten durch eine Verknüpfung und Datenimport aus einer anderen Exceltabelle rausholt. Ich hab jetzt folgendes Problem, diese Datumangaben sind ohne Jahreszahl und sehn folgendermaßen aus
1.3
30.9.
30.10.
15.10.
15.10.
26.11.
Es stehen also alle Unterschiedlich da, da sie von verschiedenen Leuten eingetragen wurden. So ist es mir auch nicht möglich diese Daten richtig zu sortieren. Wenn jetzt eine Jahreszahl dahinterstehen würde ginge das.
Kann ich jetzt irgendwie ein Programm schreiben, welches nach dem Monat geht und dann sagt, das Datum, das > Monat 6 ist ist das Jahr 2004, und das Datum, das Wär schön, wenn mir da jemand weiterhelfen könnte
Gruß Joe

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
=(A1&(2004+(MONAT((A1&2004))<6)))*1
u_
AW: Datum Sortieren - Anfügen der Jahreszahl
01.12.2004 17:31:50
HermannZ
Hallo Joe,
Ein Beispiel,
A1
 AB
189Datum ergänzen 
190  
19101.04.01.04.2005
19201.05.01.05.2005
19323.06.23.06.2004
19412.07.12.07.2004
19512.08.12.08.2004
19601. Mrz01.03.2005
19730.09.30.09.2004
19830.10.30.10.2004
19915.10.15.10.2004
20015.10.15.10.2004
20126.11.26.11.2004
202 herunterkopieren
203  
Formeln der Tabelle
B191 : =WENN(ISTFEHLER(MONAT(A191));WENN(TEIL(WECHSELN(A191;".";"");3;99)*1<6;A191&2005;A191&2004);WENN(MONAT(A191)<6;TEXT(TAG(A191)&"."&MONAT(A191)&"."&"2005";"TT.MM.JJJJ");TEXT(TAG(A191)&"."&MONAT(A191)&"."&"2004";"TT.MM.JJJJ")))
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  
Gruß Hermann
Anzeige
Da ist die Version von u_ doch aber...
u_
Hi Hermann,
...um einiges kürzer ;-))
Nochmal 7 Zeichen weniger mit:
=(A1&2005-(MONAT(A1&0)&gt6))*1
Grüße Boris
AW: Ich gebe dir recht aber..
HermannZ
Hallo Boris,
als ich die Zahlen kopiert habe habe ich gemerkt das 1.3 kein Text sondern als Datum formatiert war darum die länge anders habe ich das nicht hinbekommen.wenn das nicht gewesen wäre hätte ich bestimmt nicht diesen Wurm produziert.
Gruß Hermann
AW: Ich gebe dir recht aber..
Joe
Vielen Dank an alle für die Hilfe, habs jetzt hinbekommen.
Gruß Joe

315 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige