Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Grösser gleich und Oder in Formel

Grösser gleich und Oder in Formel
22.01.2020 13:51:34
hkoepp63
Hallo Zusammen,
Ich habe mal eine Frage an die Spezis.
Wie kann ich in einer Formel >= mit oder verknüpfen.
Ausgang (dank Werners Hilfe):

(Hilfstabelle!K$2:K$500>=F$2)

Wunsch:

(Hilfstabelle!K$2:K$500>=(oder(F$2;"x"))

funktioniert leider nicht.
Hintergrund ist, in einer Tabelle steht anstatt eines Datums nur ein "x" für den Starttermin.
Diese Daten werden dann natürlich durch die Formel nicht berücksichtigt.
Vielen Dank im Voraus.
Grüße
Hinnerk

20
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: verlinke mal auf Deinen vorher. thread owT
22.01.2020 13:57:40
neopa
Gruß Werner
.. , - ...
AW: Grösser gleich und Oder in Formel
22.01.2020 14:01:54
SH95
Hallo Hinnerk
=ODER(Hilfstabelle!K$2:K$500>=F$2;Hilfstabelle!K$2:K$500="X")
so?
Gruß
Stefan
AW: Grösser gleich und Oder in Formel
22.01.2020 14:23:25
Janosch
Hallo Hinnerk,
du musst die "ODER-Bedingung" schon zuerst nennen:
"ODER(BEDINGUNG1=WAHR/FALSCH;BEDINGUNG2=WAHR/FALSCH)" ~f~
In deinem Beispiel ungefähr so:
~f~"ODER(F2="x";Hilfstabelle!K$2:K$500>="WAS auch immer hier geprüft wird")"
Viele Grüße und viel Erfolg!
Janosch
AW: Grösser gleich und Oder in Formel
22.01.2020 14:23:52
Janosch
Ahh der Stefan war schneller als ich :)
AW: Grösser gleich und Oder in Formel
22.01.2020 14:36:04
hkoepp63
Ist vielleicht besser wenn ich die ganze Formel einfüge:
=WENNFEHLER(@INDEX(Hilfstabelle!D:D;AGGREGAT(15;6;ZEILE(Hilfstabelle!D$2:D$500) /ODER(Hilfstabelle!K$2:K$500>=F$2;Hilfstabelle!K$2:K$500="x")/(Hilfstabelle!H$2:H$500 "") /(Hilfstabelle!AB$2:AB$500 ="nicht bereit")/ODER(Hilfstabelle!K$2:K$500
Die Formel zeigt keinen Fehler, aber auch kein Ergbnis.
Anzeige
AW: dann könntest Du auch ...
22.01.2020 14:46:13
neopa
Hallo Hinnerk,
... Deine entsprechend neue/ergänzte Datei einstellen.
Gruß Werner
.. , - ...
AW: Grösser gleich und Oder in Formel
22.01.2020 14:38:22
SF
Hola,
nicht
ODER(Hilfstabelle!K$2:K$500>=F$2;Hilfstabelle!K$2:K$500="x")

sondern
(Hilfstabelle!K$2:K$500>=F$2)+(Hilfstabelle!K$2:K$500="x")
Gruß,
steve1da
Anzeige
AW: Grösser gleich und Oder in Formel
22.01.2020 14:44:10
hkoepp63
Hola zurück.
Die Formel funktioniert zwar, bringt aber nicht das gewünschte ergebnis...
Grüße
Hinnerk
AW: Grösser gleich und Oder in Formel
22.01.2020 14:47:08
hkoepp63
@neopa C
Werner, kannst Du Dir ggf. die Formel einmal ansehen.
Du hattest mir die orgiginale Version erstellt.
Vielen Dank
Grüße
Hinnerk
AW: siehe oben, Datei wäre sinnvoll owT
22.01.2020 14:53:11
neopa
Gruß Werner
.. , - ...
AW: Grösser gleich und Oder in Formel
22.01.2020 14:55:35
hkoepp63
Hier die Lösung von Werner
Arbeitsblatt mit dem Namen 'Auswertung'
AA	AB	AC	AD	AE	AF
1	Tab_Namen	0	 	B:B	I:I	Z:Z
2	ABC20_21	5	ABC20_21	AA 0101	01.02.2020	Bereit
3	ABC20_22	12	ABC20_21	AA 0201	01.03.2020	Nicht Bereit
4	ABC20_23	18	ABC20_21	AA 0202	05.03.2020	Nicht Bereit
5	ABC20_25	23	ABC20_21	AA 0203	 	Bereit
6	 	 	ABC20_21	AA 0301
7	 	 	ABC20_22	AB 0101	01.02.2020	Bereit
8	 	 	ABC20_22	AB 0201	01.03.2020	Nicht Bereit
Zelle	Formel
AB2	=WENN(AA2="";"";ANZAHL2(INDIREKT(AA2&"!B:B"))-1+MAX(AB1:AB1))
AC2	=INDEX($AA:$AA;VERGLEICH(ZEILE()-2;$AB:$AB)+1)&""
AD2	=WENN(AC2="";"";INDEX(INDIREKT($AC2&"!"&AD$1);ZÄHLENWENN($AC$2:$AC2;$AC2)+1))
Verwendete Systemkomponenten: [Windows (32-bit) NT 6.02] MS Excel 2010
Diese Tabelle wurde mit Tab2Html (v2.6.0) erstellt. ©Gerd alias Bamberg
Inb der Beispiel Tabelle ist bei ABC20_21 bei den beiden letzten Daten ein x eingetragen.
https://www.herber.de/bbs/user/134619.xlsx
Grüße
Hinnerk
Anzeige
AW: wo ist die Hilfstab.? und warum ...
22.01.2020 15:13:43
neopa
Hallo Hinnerk,
... und warum hast Du die Formeln ab Spalte AA noch nicht eingetragen?
Gruß Werner
.. , - ...
AW: wo ist die Hilfstab.? und warum ...
24.01.2020 12:55:58
hkoepp63
Hallo Zusammen,
entschuldigt die Verspätung. Bisschen viel... Aber das haben wir wohl alle irgendwie.
Anbei die komplettierte Tabelle wie von Werner gewünscht
Wie gesagt, ich muss irgendwie abfangen, dass die Einträge mit "x" auch angezeigt werden.
https://www.herber.de/bbs/user/134665.xlsx
Vielleicht habt ihr ja eine Idee.
Vielen Dank im Voraus.
Grüße
Hinnerk
AW: nun ...
24.01.2020 16:31:52
neopa
Hallo Hinnerk,
... zunächst festgestellt: Du hast fast alle Formeln in Deiner Hilfstabelle als klassische Matrixformeln abgeschlossen (was zu der {}-führt), was ich Dir so nicht angegeben habe und auch so nicht notwendig ist. Die dortigen Ergebnisse sind trotzdem gewährleistet.
Im Weiteren steht in Deiner Formel in B3 nun bei mir (in Excel 2016):
=WENNFEHLER(_xlfn.SINGLE(INDEX(Hilfstabelle!D:D;... Die Funktion SINGLE() kennt meine XL2016 Version nicht und ist auch nicht nötig, genauso wenig wie auch für diese Formel kein Matrixformelabschluß notwendig ist.
Deine eingegebene Formel kann kein Ergebnis ergeben, weil diese sich ersten auf Vergleichswerte in F2 und H2 bezieht, die wirklichen Vergleichswerte jedoch in F1 und H1 stehen. Hinzu kommt, dass die ODER-Beziehungen (durch die + Verknüpfung) einer zusätzlichen Klammerung bedürfen.
Also in B2:
=WENNFEHLER(INDEX(Hilfstabelle!D:D;AGGREGAT(15;6;ZEILE(Hilfstabelle!D$2:D$500)/
((Hilfstabelle!E$2:E$500&gt=F$1)+(Hilfstabelle!E$2:E$500="x"))/
(Hilfstabelle!F$2:F$500="nicht bereit")/
((Hilfstabelle!E$2:E$500&lt=H$1)+(Hilfstabelle!E$2:E$500="x"));ZEILE(B1)));"")

und diese nach unten kopieren.
Gruß Werner
.. , - ...
Anzeige
AW: nun ... Windows 365 Fehler
27.01.2020 07:56:05
hkoepp63
Guten Morgen Werner,
vielen Dank für Deine Hilfe.
Die geschweiften Klammern scheinen wegen der Umstellung auf 365 sich eingeschlichen zu haben, genauso mit dem "at" Zeichen. Ich habe allerdings in meiner Tabelle diese Zeichen nicht.
Mit der geänderten Formel kommt es jetzt zu doppelten Einträgen...
AA 0201
AA 0202
AA 0301
AB 0201
AB 0202
AB 0202
AB 0202
AC 0302
Anbei die Datei:
https://www.herber.de/bbs/user/134723.xlsx
Grüße
Hinnerk
AW: wohl eine Windows 365 "Funktionalität" ...
27.01.2020 10:22:48
neopa
Hallo Hinnerk,
... die diese "Information" ({} einer Matrixfunktion(alität)sformel in ältere Excelversionen (ich nutze XL 2010) übergibt, hier aber nicht benötigt wird.
Den Fehler in meiner Formel sollte ich ich jetzt festgestellt haben. Da ein Textwert wie "x" oder auch "" immer größer ist als jeder Zahlenwert (somit auch Datums-) ist in der dargestellten 2. Formelzeile das +(Hilfstabelle!E$2:E$500="x") nicht angebracht.
Die Formel in B3 muss demnach nur wie folgt lauten:
=WENNFEHLER(INDEX(Hilfstabelle!D:D;AGGREGAT(15;6;ZEILE(Hilfstabelle!D$2:D$25)/
(Hilfstabelle!E$2:E$25&gt=F$1)/(Hilfstabelle!F$2:F$25="nicht bereit")/
((Hilfstabelle!E$2:E$25&lt=H$1)+(Hilfstabelle!E$2:E$25="x"));ZEILE(B1)));"")
Gruß Werner
.. , - ...
Anzeige
AW: wohl eine Windows 365 "Funktionalität" ...
27.01.2020 14:01:37
hkoepp63
Hallo Werner,
ich habe noch einmal alles überprüft und alle "at" rausgenommen.
Leider funktioniert Deine angepasste Formel nicht wie gewünscht...
Das ist das Ergebnis bei mir:
Teilabschnitt Nummer
AA 0201
AA 0202
AB 0201
AB 0202
AC 0201
AC 0302
AD 0201
AD 0301
Das sollte das Ergebnis aus ABC20_21 sein:
Teilabschnitt Nummer Baustart Aktuell
AA 0101 01.02.2020
AA 0201 01.03.2020
AA 0202 05.03.2020
AA 0203 x
AA 0301 x
Noch einmal zum Verständnis. Es muss eine "oder" Funktionalität sein. Also entweder datum liegt zwischen >=F1 und oder beinhaltet "x"
Habe ich hier einen Denkfehler?
Anbei noch einmal die Tabelle.
https://www.herber.de/bbs/user/134755.xlsx
Vielen Dank.
Grüße
Hinnerk
Anzeige
AW: wohl eine Windows 365 "Funktionalität" ...
27.01.2020 15:02:42
hkoepp63
Hallo Werner,
ich habe den Fehler gefunden und in meiner Tabelle angepasst.
Beim Übertragen von der Test auf die Live Tabelle bin ich in der Zeile verrutscht.
Die entgültige Formel:
=WENNFEHLER(INDEX(Hilfstabelle!D:D;AGGREGAT(15;6;ZEILE(Hilfstabelle!D$2:D$25)/
(Hilfstabelle!E$2:E$25>=F$1)
/((Hilfstabelle!E$2:E$25

ohne den Teil "nicht Bereit" funktioniert dann auch so wie gewünscht.
Vielen herzlichen Dank noch einmal für Deine Geduld und die Hilfe (aller Beteiligten).
Beste Grüße
Hinnerk
AW: bitteschön owT
27.01.2020 19:53:07
neopa
Gruß Werner
.. , - ...
Anzeige

342 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige