Microsoft Excel

Herbers Excel/VBA-Archiv

SVERWEIS oder eine andere Formel

Betrifft: SVERWEIS oder eine andere Formel von: Smikkel
Geschrieben am: 04.11.2020 15:11:49

Hallo zusammen,

ich habe einen Wert mit 2 anderen verschiedenen Kriterien. Dieser Wert ist wieder zu finden in einer weiteren Tabelle und liegt zwischen 2 Werten in 2 Spalten. Die beiden Kriterien nehmen auch noch Einfluss auf den Bereich.

Ich habe hier eine Beispieldatei, im Erklären bin ich eine Niete :)

https://www.herber.de/bbs/user/141310.xlsx

Ich weiß einfach nicht welche Formal ich darauf anwenden kann.

Vielleicht kann jemand helfen :)

Liebe Grüße

Betrifft: AW: SVERWEIS oder eine andere Formel
von: SF
Geschrieben am: 04.11.2020 15:24:29

Hola,

schmeiß die verbundenen Zellen raus und schreib die von-bis Bereiche in die leeren Zellen. Dann:
=SUMMENPRODUKT((A3>=Tabelle2!$A$4:$A$23)*(A3<=Tabelle2!$B$4:$B$23)*(B3=Tabelle2!$C$4:$C$23) *(C3=Tabelle2!$D$3:$F$3)*(Tabelle2!$D$4:$F$23))

Gruß,
steve1da

Betrifft: AW: SVERWEIS oder eine andere Formel
von: Smikkel
Geschrieben am: 05.11.2020 06:54:54

Danke steve1da!
Ich werde mal schauen welche Lösung für mich am Besten ist.
Vielen Dank!

Betrifft: AW: mit INDEX() und VERGLEICH() ...
von: neopa C
Geschrieben am: 04.11.2020 15:34:54

Hallo Smikkel,

... kannst Du Deine Datenstruktur auch beibehalten.

in E3: =INDEX(Tabelle2!D:F;VERGLEICH(A3;Tabelle2!A:A)+B3-1;VERGLEICH(C3;Tabelle2!D$3:F$3;0))

und nach unten kopieren.

Gruß Werner
.. , - ...

Betrifft: AW: mit INDEX() und VERGLEICH() ...
von: Smikkel
Geschrieben am: 05.11.2020 06:54:09

Vielen Dank Werner!
Funktioniert prima.

Betrifft: AW: gerne owT
von: neopa C
Geschrieben am: 05.11.2020 11:49:22

Gruß Werner
.. , - ...

Beiträge aus dem Excel-Forum zum Thema "SVERWEIS oder eine andere Formel"