Live-Forum - Die aktuellen Beiträge
Datum
Titel
15.07.2024 16:00:57
15.07.2024 15:41:38
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
280to284
280to284
Aktuelles Verzeichnis
Verzeichnis Index
Verzeichnis Index
Übersicht Verzeichnisse
Inhaltsverzeichnis

Zellen vergleichen Datum und Uhrzeit

Zellen vergleichen Datum und Uhrzeit
16.07.2003 09:31:39
Holger Nikisch
Hallo,
wie sieht der VB - Code aus für folgendes Problem: Es soll in einer Spalte zb. A
eine Auflistung von Datum und Uhrzeit befinden, so wie im unteren Beispiel, z.B.
Zeile 1: 01.01.2003 21:59:21
Zeile 2: 02.01.2003 22:00:00 ?????
Zeile 3: 02.01.2003 00:10:09
Zeile 4: 02.01.2003 05:00:24
Zeile 5: 03:01.2003 23:24:17
usw.
Das Datumwechsel erfolgt immer um 22:00:00 Uhr NICHT um 00:00:00 Uhr.
Mein Problem besteht darin, das ich aber ein Datumwechsel um 00:00:00 Uhr haben möchte, damit ich weitere Auswertungen machen kann?
Wie bekomme ich das hin.....
Zeile 1: 01.01.2003 21:59:21
Zeile 2: 01.01.2003 22:00:00
Zeile 3: 02.01.2003 00:10:09
Zeile 4: 02.01.2003 05:00:24
Zeile 5: 02:01.2003 23:24:17
usw.
Vielen Dank schon im vorraus
Holger Nikisch

3
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Zellen vergleichen Datum und Uhrzeit
16.07.2003 13:17:55
Holger Nikisch
Hallo,
ich möchte mich für Eure Hilfe recht herzlich bedanken.
mfg
Holger Nikisch

AW: Zellen vergleichen Datum und Uhrzeit
16.07.2003 11:45:24
Klaus-Dieter
Hallo Holger,
versuch es mal mit diesem Makro:

Sub datum_aendern()
Dim r As Integer, dat As Date
For r = 1 To 5
If Format(Cells(r, 1), "hh:mm") >= "22:00" Then
dat = Left(Cells(r, 1), 2) - 1 & Mid(Cells(r, 1), 3, 6) & " " & Right(Cells(r, 1), 8)
Cells(r, 1) = dat
End If
Next r
End Sub

Gruß Klaus-Dieter
Klaus-Dieter's Excel und VBA Seite

AW: Zellen vergleichen Datum und Uhrzeit
16.07.2003 10:28:03
Stephan
=WENN(B2<=24;A1;A2)
wobei in Spalte A das Datum steht, in Spalte B die Uhrzeit.
U.U. kannst Du Probleme mit dem Format bekommen.

Anzeige

365 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige