Microsoft Excel

Herbers Excel/VBA-Archiv

Alternative zu Wenn()

Betrifft: Alternative zu Wenn() von: Henning
Geschrieben am: 19.08.2014 10:21:27

Hallo,

ich möchte eine Referenzliste mit verschiedenen Datumsweten (Feiertage, etc.) abfragen und einen festen Wert (z.B. Feiertag") ausgeben. Bisher löse ich das so (die Liste und dementsprechend die Formel sind im Original viel länger):

=WENN(ODER(($B2=Eingabe!$Q$27);($B2=Eingabe!$Q$28);($B2=Eingabe!$Q$29));"Feiertag";"")

Das die Referenzliste immer länger wird ist das nun doch zu umständlich. Bestimmt gibt es eine ganz einfache Lösung, auf die ich gerade nicht komme.

Vielen Dank für Eure Hilfe.

Gruß
Henning

  

Betrifft: AW: Alternative zu Wenn() von: Klaus M.vdT.
Geschrieben am: 19.08.2014 10:26:18

Hallo Henning,

wenn die Bereiche Zusammenhängen, behelfe dir mit ZÄHLENWENN:

=WENN(ZÄHLENWENN(Eingabe!Q27:Q29;B2)>0;"Feiertag";"")
Grüße,
Klaus M.vdT.


  

Betrifft: AW: Alternative zu Wenn() von: Rudi Maintaire
Geschrieben am: 19.08.2014 10:26:19

Hallo,
=wenn(zählenwenn(eingabe!Q:Q;B2);"Feiertag;"")

Gruß
Rudi


  

Betrifft: AW:Eine Moeglichkeit... von: hary
Geschrieben am: 19.08.2014 10:28:21

Moin
..ist Zaehlenwenn. Du kannst auch der Liste einen Namen vergeben.



Tabelle2

 ABCDE
101.01.201502.01.201503.01.201504.01.201505.01.2015
2Feiertag Feiertag  
3     
4     
5     
6Bsp.    
701.01.2015    
803.01.2015    
9usw.    

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
A2:E2=WENN(ZÄHLENWENN($A$7:$A$10;A1);"Feiertag";"")  =IF(COUNTIF(R7C1:R10C1,R[-1]C),"Feiertag","")

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: dann wähle WAHL() und VERGLEICH()e ... von: neopa C (paneo)
Geschrieben am: 19.08.2014 10:41:01

Hallo Henning,

... =WAHL(1+ISTZAHL(VERGLEICH(B2;Q25:Q27;));"";"Feiertag")

denn die drei Antworten zuvor nutzen mehr WENNs in ihrer Formel als Du in Deiner ;-)

Gruß Werner
.. , - ...


  

Betrifft: Index statt Wahl von: Rudi Maintaire
Geschrieben am: 19.08.2014 10:51:00

Hallo,
so geht's auch:
=INDEX({""."Feiertag"};1+ISTZAHL(VERGLEICH(B2;Q:Q;)))

Gruß
Rudi


  

Betrifft: INDEX() ist aber ein Zeichen länger ;-) ... owT von: neopa C (paneo)
Geschrieben am: 19.08.2014 10:59:55

Gruß Werner
.. , - ...


  

Betrifft: du liebst ihn aber doch ;-) owT von: Rudi Maintaire
Geschrieben am: 19.08.2014 11:08:27




  

Betrifft: bin aber manchmal WäHL() erisch ... ;-) von: neopa C (paneo)
Geschrieben am: 19.08.2014 11:35:20

Gruß Werner
.. , - ...


  

Betrifft: Merci:-) von: Henning
Geschrieben am: 19.08.2014 13:49:47

Vielen Dank an alle! Das ist sehr hilfreich :-)
Gruß
Henning


 

Beiträge aus den Excel-Beispielen zum Thema "Alternative zu Wenn()"