Microsoft Excel

Herbers Excel/VBA-Archiv

Zahlen addieren

Betrifft: Zahlen addieren von: walter
Geschrieben am: 20.09.2014 06:49:22

Hallo Sportfreunde,
Ich möchte die Werte in Spalte "I"&"J" addieren,bekomme aber nur
#WERT als Ergebnis.
Diese Formel habe ich eingesetzt.
SUMMENPRODUKT(($D$2:$D$370=$AG2)*($I$2:$I$370))+SUMMENPRODUKT(($E$2:$E$370=$AG2)*($J$2:$J$370))
Kann mir Jemand helfen?

Gruß
Walter

  

Betrifft: AW: Zahlen addieren von: walter
Geschrieben am: 20.09.2014 07:02:26

Hallo Sportfreunde,
Ich möchte die Werte in Spalte "I"&"J" addieren,bekomme aber nur #WERT als Ergebnis.
In den Zellen I2 bis I370 stehen Formeln!
Diese Formel habe ich eingesetzt.
SUMMENPRODUKT(($D$2:$D$370=$AG2)*($I$2:$I$370))+SUMMENPRODUKT(($E$2:$E$370=$AG2)*($J$2:$J$370))
Kann mir Jemand helfen?

Gruß
Walter


  

Betrifft: AW: Zahlen addieren von: ransi
Geschrieben am: 20.09.2014 10:26:17

Hallo

ICh denke in $J$2:$J$370 steht irgendwo ein Text statt einer Zahl.

ransi


  

Betrifft: AW: Zahlen addieren von: walter
Geschrieben am: 20.09.2014 17:27:57

Hallo ransi,
Danke für Deien Antwort, habe die Spalten noch einmal formatiert,
aber immer noch die gleiche Fehlermeldung.
Wenn nach ca.30 Ergebnisse die restlichen Zellen gelöscht werden, dan funktioniert das
Zählen.
Versuche mal die Dateikleiner zu machen.
Gruß
Walter


  

Betrifft: AW: Zahlen addieren von: hary
Geschrieben am: 20.09.2014 17:45:01

Moin Walter
Oder hast du leere Zellen mit einem Leerzeichen drin?
Evtl. durch eine Formel.
gruss hary


  

Betrifft: Wenn du TextZahlen in einigen Zellen hast, ... von: Luc:-?
Geschrieben am: 20.09.2014 20:00:21

…Walter,
nutzt formatieren allein nichts. Du musst außerdem alles mit 1 multi­plizieren (dieser Hinweis und Anleitung dafür wurde im Forum schon oft gegeben!). Allerdings stören TextZahlen die von dir gewählte FmlForm nicht, das Ergebnis wird trotzdem richtig. Texte (auch eine sog leere Zeichenkette der Länge 0) stören deine FmlForm aber schon, denn eine Berechnung mittels einfacher Verknüpfung über einen arith­metischen Operator kann nicht­numerische Texte nicht abfangen, eine Fkt schon, wenn sie so pgmiert ist, was hier der Fall wäre. Ein Fehlerwert hingegen kann von einer Fkt zwar prinzipiell auch abgefangen wdn (von Operatoren ebenfalls nicht), das ist aber bei der von dir verwendeten nicht der Fall.
Die klassische Form deiner Fml würde Texte generell (auch leere ZKn), also auch TextZahlen abfangen (nicht umwandeln!), aber ebenfalls keine Fehlerwerte. Teste deshalb doch versuchsweise mal diese Form:
=SUMME(SUMMENPRODUKT(--($D$2:$D$370=$AG2);$I$2:$I$370);SUMMENPRODUKT(--($E$2:$E$370=$AG2); $J$2:$J$370))
Gruß, Luc :-?


  

Betrifft: anstelle SUMME() einfach + doch vorausgesetzt ... von: neopa C (paneo)
Geschrieben am: 21.09.2014 14:39:33

Hallo Luc,

... das Walter wirklich diese Art Summierung auch wirklich benötigt/will.
Denn =SUMMENPRODUKT(--($D$2:$D$370=$AG2);$I$2:$I$370)+SUMMENPRODUKT(--($E$2:$E$370=$AG2);$J$2:$J$370) summiert alle Zahlenwerte aus Spalte I und J wenn in Spalte D oder in Spalte E die Bedingung gilt.

Es ist aber nicht ganz auszuschließen das Walter die Summierung der Werte aus I und J sucht, wenn in Spalte D und gleichzeitig in Spalte E die Bedingung gilt.

Dann würde die Formel {=SUMME(WENN(($D$2:$D370=$AG2)*($E$2:$E$370=$AG2)*ISTZAHL($I$2:$I$370)*ISTZAHL($J$2:$J$370);$I$2:$I$370+$J$2:$J$370))} zum Ergebnis führen.

@ Walter, die {} ist nicht einzugeben sondern die Formel ist mit STRG+SHIFT+RETURN abschließen!
Die Teilfomel ISTZAHL($J$2:$J$370) darin ist nach Deinen bisherigen Angaben möglicherweise auch nicht notwendig, schadet aber auch nicht.

Gruß Werner
.. , - ...


  

Betrifft: Tja, Werner, hier ging's doch primär um das ... von: Luc:-?
Geschrieben am: 21.09.2014 16:22:09

…Nicht-Fktionieren von Walters Fml, wobei letztlich nicht klar ist, ob sie nun falsche oder gar keine Werte liefert. Bisher gingen alle AWer (auch ich) davon aus, dass Letzteres der Fall ist — deshalb auch mein Kontroll-Fml-Vorschlag.
Eine andere Anordnung der Vgle liefert natürlich auch ein anderes Ergebnis. Soweit wollte ich aus dem genannten Grund aber nicht gehen, weil ich erstmal davon ausgehe (auch mangels ggf andere Schlüsse zulassender Beschreibung), dass Walter weiß, was er tut…
Gruß, Luc :-?


 

Beiträge aus den Excel-Beispielen zum Thema "Zahlen addieren"