Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema Userform
BildScreenshot zu Userform Userform-Seite mit Beispielarbeitsmappe aufrufen
Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

3 mal Zählen

Betrifft: 3 mal Zählen von: Vulferin
Geschrieben am: 19.09.2014 22:48:53

Hallo zusammen
Danke diesem Forum ist meine Liste so geil geworden
und schon fällt mir noch was ein

Ich würde gerne 3 TextBoxen haben
1 Textbox so zählen wie oft in Spalte L "Wahr" steht
2 Textbox soll zählen wie oft in SPalte N "Wahr" steht
3 die was schwierigere soll zählen wieviel zellen mit Roterschrift sind

ich kann schon per autofilter filtern
ActiveSheet.Range("$A$1:$T$3").AutoFilter Field:=11, Criteria1:=RGB(255, 0 _
, 0), Operator:=xlFilterFontColor

aber ich würde diese 3 Ergebniss als Infomation auf die Userform bringen

  

Betrifft: AW: 3 mal Zählen von: Matthias L
Geschrieben am: 20.09.2014 00:29:44

Hallo

2 x zählen

TextBox1.Text = Application.WorksheetFunction.CountIf(Columns("L"), True)
TextBox2.Text = Application.WorksheetFunction.CountIf(Columns("N"), True)

Kann man natürlich auch in einer Zelle realisieren und mit der entspr. Textbox verknüpfen

Tabelle1

 LN
1 WAHR
2WAHR 
3 WAHR
4  
5WAHR 
6  
7 WAHR
8 WAHR
9WAHR 
10 WAHR
11 WAHR
12 WAHR
13WAHR 
14  
15  
16  
17WAHR 
18 WAHR
19  
20 WAHR
2259

Formeln der Tabelle
ZelleFormel
L22=ZÄHLENWENN(L1:L20;WAHR)
N22=ZÄHLENWENN(N1:N20;WAHR)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4





Das 3. mal zählen (Farbe: rote Schrift)
könnte evtl. mit einem Excel4Makro funktionieren.
Such mal nach Zelle.Zuordnen. Da gibts ne Menge Beispiele.

Oder gib mal in der Recherche: rote Schrift zählen ein.

Gruß Matthias


  

Betrifft: AW: Autofilterergebnis Zählen von: Daniel
Geschrieben am: 20.09.2014 10:33:04

Hi

Wenn du die Farben gefiltert hast, kannst du die Anzahl folgendermaßen ermitteln

with ActiveSheet.Range("$A$1:$T$3")
    .AutoFilter Field:=11, Criteria1:=RGB(255, 0, 0), Operator:=xlFilterFontColor
    Textbox3.text = .Columns(1).specialcells(xlcelltypevisible).cells.count - 1
Gruß Daniel


  

Betrifft: AW: 3 mal Zählen von: Vulferin
Geschrieben am: 20.09.2014 15:43:54

hi zusammen
ich habe das mal damit versucht
weil imprinzip reicht mir das auch das er mit die Zellen mit Inhalt zählt

Textbox26 = Application.WorksheetFunction.Count(Range("K")) aber hier gibt er mir einen falschen wert aus.
er sagt neun sind aber 31
ich glaube das er bei der ersten leeren Zelle hängenbleiobt
weil das sind 9 am stück


  

Betrifft: nur Count und Range("K") ? von: Matthias L
Geschrieben am: 20.09.2014 19:18:20

Hallo

Probier mal so:

TextBox26 = Application.WorksheetFunction.CountA(Range("K:K"))

oder
TextBox26 = Application.WorksheetFunction.CountA(Columns(11))
Gruß Matthias


 

Beiträge aus den Excel-Beispielen zum Thema "3 mal Zählen"