Microsoft Excel

Herbers Excel/VBA-Archiv

Arbeitszeit berechnen

Betrifft: Arbeitszeit berechnen von: Josef
Geschrieben am: 01.10.2014 14:20:03

Hallo Zusammen,

ich möchte meine Arbeitszeit berechnen und zwar mit folgenden Daten

A1 Arbeitsbeginn

A2 Arbeitsende

in A3 soll die geleistet Arbeitzeit stehen, ist die Zelle A1 und A2 leer soll in A3 Frei stehen.

Mit freundlichen GRüßen
Josef

  

Betrifft: AW: Arbeitszeit berechnen von: yummi
Geschrieben am: 01.10.2014 14:26:26

Hallo Josef,

hättest dir auch die frage von uwe (direkt darunter) anschauden können ;-)

Private Sub Worksheet_SelectionChange(ByVal Target As Range)
 If Cells(1, 1) Or Cells(2, 1) = "" Then
  Cells(3, 1) = ""
   Else
  Cells(3, 1) = (Cells(2, 1) - Cells(1, 1)) * 24
 End If

End Sub

Gruß
yummi


  

Betrifft: AW: Arbeitszeit berechnen von: Josef
Geschrieben am: 01.10.2014 14:43:13

Danke yummi,

aber ich habe alle Arbeitstage auf einen Tabellenblatt und für jedes Monat ein Blatt

Gruß
Josef


  

Betrifft: AW: Arbeitszeit berechnen von: yummi
Geschrieben am: 01.10.2014 14:45:40

Hallo Josef,

dann für jedes Blatt die funktion in das Change ereignis rein. Wenn unklar lad mal deine Datei hoch

Gruß
yummi


  

Betrifft: AW: Arbeitszeit berechnen von: Josef
Geschrieben am: 01.10.2014 14:57:51

Hallo yummi,

so sieht mein Arbeitsblatt aus:

https://www.herber.de/bbs/user/92930.xlsx

Gruß
Josef


  

Betrifft: AW: Arbeitszeit berechnen von: yummi
Geschrieben am: 01.10.2014 15:05:22

Hallo Josef,

welche WErte sollen denn jetzt berechnet werden? Von A1 A2 und A3 ist auf dem Blatt wohl nicht die Rede.
Kannst Du mal die Werte eintragen, die du machen willst und dann sagen in welcher Zelle du welche Berechnungen haben willst.


Soll z.b. in AH jeweils die Summe der Zeile erscheinen?

Gruß
yummi


  

Betrifft: AW: Arbeitszeit berechnen von: yummi
Geschrieben am: 01.10.2014 15:20:31

Hallo Josef,

wenn du in C6 Anfangszeit und C8 Endzeit einträgst dann in C9: =C8-C6
oder brauchst du industrieminuten?
Gruß
yummi


  

Betrifft: AW: Arbeitszeit berechnen von: Josef
Geschrieben am: 01.10.2014 15:33:16

Hallo Jummi,

mit der angegebenen Formel wird die Arbeitszeit abzüglich einer Pause von 30 Minuten nach 6 Stunden Arbeitszeit berechnet ich möchte die Formel so erweitern das wenn keine Zeit eingetragen ist automatisch FREI in der Zelle angezeigt wird.

Gruß
Josef


  

Betrifft: im einfachsten Fall =A2-A1 ...aber ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 14:50:16

Hallo Josef,

... google mal nach Excel und Arbeitszeit ... bei mir werden 302.000 Treffer angezeigt.


Gruß Werner
.. , - ...


  

Betrifft: AW: im einfachsten Fall =A2-A1 ...aber ... von: Josef
Geschrieben am: 01.10.2014 15:03:19

Hallo Werner,



habe schon eine Formel mit der ich meine Zeit berechnen kann


aber wenn keine Arbeitszeit angegeben ist soll in der Zelle Frei stehen und das ist mein Problem

Gruß
Josef


  

Betrifft: dann einfach WENN() vorangestellt ... von: neopa C (paneo)
Geschrieben am: 01.10.2014 15:15:58

Hallo Josef,

... für den einfachsten Fall: =WENN((A2=0)+(A1=0);"";...)


Gruß Werner
.. , - ...


  

Betrifft: AW: Arbeitszeit berechnen von: Josef
Geschrieben am: 01.10.2014 15:15:39

Hallo yummi,

hier das Tabellenblatt:

https://www.herber.de/bbs/user/92931.xlsx

ich schaffe es einfach nicht wenn keine Zeit steht soll FREI stehen.

Gruß
Josef


  

Betrifft: AW: Arbeitszeit berechnen von: hary
Geschrieben am: 01.10.2014 15:36:28

Moin Josef
und nach rechts ziehen.



sa2

 C
96:30

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
C9=WENN((C$6=0)+(C$8=0);"frei";WENN(REST(C6-C8;1)>6/24;REST(C6-C8;1)-0,5/24;REST(C6-C8;1)-0/24))  =IF((R6C=0)+(R8C=0),"frei",IF(MOD(R[-3]C-R[-1]C,1)>6/24,MOD(R[-3]C-R[-1]C,1)-0.5/24,MOD(R[-3]C-R[-1]C,1)-0/24))

http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.02 einschl 64 Bit

gruss hary


  

Betrifft: AW: Arbeitszeit berechnen von: Josef
Geschrieben am: 01.10.2014 15:42:02

Hallo Hary,

super klappt wunderbar.

vielen, vielen Dank Euch allen für Eure Hilfe !!!

Gruß
Josef


 

Beiträge aus den Excel-Beispielen zum Thema "Arbeitszeit berechnen"