Microsoft Excel

Herbers Excel/VBA-Archiv

Zählen von Zeilen

Betrifft: Zählen von Zeilen von: Lemmi
Geschrieben am: 06.10.2014 11:52:17

Hallo zusammen,

ich habe eine Werte Tabelle in dem ich die Zeilen zählen will.

Es soll gezählt werden wenn ein Vorgabewert überschritten worden ist. Eine Mehrfachüberschreitung in einer Zeile wird max. mit einem Zähler hoch gezählt.
Es soll gezählt werden wenn ein Vorgabewert unterschritten worden ist. Eine Mehrfachunterschreitung in einer Zeile wird max. mit einem Zähler hoch gezählt.
Werte die gleich dem Vorgabewert entsprechen werden als innerhalb der Grenzwerte nicht gezählt.
Sind in einer Zeile sowohl Über- als auch Unterschreitungen vorhanden so zählt dies auch bei einer mehrfachüberschreitung nur mit einem count weiter.

Zeilen innerhalb dieser Grenzwerte werden nicht gezählt.

Hierzu habe ich eine Tabelle angefertig:

https://www.herber.de/bbs/user/92978.xlsx

Gruß
Lemmi

  

Betrifft: AW: Zählen von Zeilen von: yummi
Geschrieben am: 06.10.2014 12:04:30

Hallo Lemmi,

besispielsweise für Spalte F:

=ZÄHLENWENN(F8:F13; ">"&F16) &" / " & ZÄHLENWENN(F8:F13; "<"&F17)
Gruß
yummi


  

Betrifft: mit HÄÜFIGKEIT in einer Matrixformel ... von: neopa C (paneo)
Geschrieben am: 06.10.2014 12:04:38

Hallo Lemmi,

... so:

 EFGHIJ
6PosSpalte 1Spalte 2Spalte 3Spalte 4Spalte 5
7      
817001426001664832
92191021310611600848
1031528-3210011560780
1141840115978900790
1259101549851662650
1368002506901662831
14      
15      
16 190014010001664832
17 920-317001000700
18      
196     

Formeln der Tabelle
ZelleFormel
E19{=SUMME(N(HÄUFIGKEIT(WENN((F8:J13>F$16:J$16)+(F8:J13<F$17:J$17); ZEILE(F8:F13)); ZEILE(A8:A13))>0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Rot markiert habe ich die Zelle, die Du nicht farbig hinterlegt hattest. Dazu solltest Du auch besser bedingte Formatierung nutzen, als nur Markierung nach "Sicht".

Gruß Werner
.. , - ...


  

Betrifft: AW: mit HÄÜFIGKEIT in einer Matrixformel ... von: Lemmi
Geschrieben am: 06.10.2014 13:44:34

Hallo neopa C (paneo),


das sieht gut aus!
Ich habe aber vergessen, dass ich Zeilen habe, die keine Inhalte ausweisen. Diese müsste ich wieder abziehen!


Kann dies die Formel ggf. auch berücksichtigen!
Im Beispiel würde ich z. B. Die Zeile 6 ohne Inhalte haben.
Die Formel müsste dann einen Wert 5 ausgeben.


Ich hatte in der Verganngenheit ja schon eine ähnliche Anfrage: Kamm aber nicht mit den Leerzeilen zurecht.
Eine zweite Frage:
Wie sieht die Formel aus wenn ich die Anzahl der Grenzwerte in Zeile 16 und 17 mit Leerzeilen abfrage.

Abfrage ist in Zeile 16: alles was größer ist.
Abfrage in Zeile 17: ist alles was kleiner ist
Leerzeilen sollen nicht mitgezählt werden.


Gruß
Lemmi


  

Betrifft: dann eine weitere Bedingung einbinden ... von: neopa C (paneo)
Geschrieben am: 06.10.2014 13:53:51

Hallo Lemmi,

... so:

{=SUMME(N(HÄUFIGKEIT(WENN(((F8:J13>F$16:J$16)+(F8:J13"");ZEILE(F8:F13));  ZEILE(A8:A13))>0)) } 
Gruß Werner
.. , - ...


  

Betrifft: AW: dann eine weitere Bedingung einbinden ... von: Lemmi
Geschrieben am: 06.10.2014 14:32:50

Hallo Werner,

Du bist so schnell! ....passt alles!
Ich verfasse kaum die Frage und es ist schon eine Lösung von Dir da! Danke!



Würdest Du mir auch die Formel der zweiten Frage geben können?

Eine zweite Frage:
Wie sieht die Formel aus wenn ich die Anzahl der Grenzwerte in Zeile 16 und 17 mit Leerzeilen abfrage.

Abfrage ist in Zeile 16: alles was größer ist.
Abfrage in Zeile 17: ist alles was kleiner ist
Leerzeilen sollen nicht mitgezählt werden.

Gruß
Lemmi


  

Betrifft: nun Darstellung mit mit der Jeanie ... von: neopa C (paneo)
Geschrieben am: 06.10.2014 14:41:33

Hallo lemmi,

... da wurde meine Formel durch HTML-Code offensichtlich "vermatscht".

Deshalb stelle ich diese nun wieder mit der Jeanie ein


 EFGHIJ
6PosSpalte 1Spalte 2Spalte 3Spalte 4Spalte 5
7      
817001426001664832
92191021310611600848
1031528-3210011560780
1141840115978900790
1259101549851662650
136     
14      
15      
16 190014010001664832
17 920-317001000700
18      
195     

Formeln der Tabelle
ZelleFormel
E19{=SUMME(N(HÄUFIGKEIT(WENN(((F8:J13>F$16:J$16)+(F8:J13<F$17:J$17))*(F8:J13<>""); ZEILE(F8:F13)); ZEILE(A8:A13))>0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: AW: nun Darstellung mit mit der Jeanie ... von: Lemmi
Geschrieben am: 07.10.2014 07:47:52

Hallo neopa C (paneo,


die Formel läuft!
Ich habe aber das Probelm das ich bei der Auswertung eine ganze Menge Datenzeilen habe.
Mehr als 200 Spalten und 20000 Zeilen.
Hier bekomme ich immer die Meldung "...nicht genügend Ressourcen".

Was oder wie könnte ich dies verbessern?


Wäre es Dir noch möglich die Formel in E16 und E17 mir zu übermitteln.
Komme nicht mit den Leerzeilen zurecht.


Gruß
Lemmi


  

Betrifft: dann, bei einer deratigen Datenmenge ... von: neopa C (paneo)
Geschrieben am: 07.10.2014 08:38:23

Hallo Lemmi,

... könnte eine Hilfsspaltenlösung angebracht sein. Allerdings würde ich, wenn Du willst, das gern mal direkt untersuchen. Mit derartigen großen Datenmengen habe ich nämlich sonst nichts zu tun.
Kannst Du mir mal Deine Datei direkt zusenden?

Gruß Werner
.. , - ...


  

Betrifft: AW: dann, bei einer deratigen Datenmenge ... von: Lemmi
Geschrieben am: 07.10.2014 08:49:50

Hallo,

ja könnte eine Datei vorbereiten!

Bitte E-Mail übermitteln.

Gruß
Lemmi


  

Betrifft: nun denn ... von: neopa C (paneo)
Geschrieben am: 07.10.2014 09:00:20

Hallo Lemmi,

... und zwar an (exceltechnisch verschlüsselt):
=WECHSELN("neopaCode";"Co";ZEICHEN(64)&"email.")


Gruß Werner
.. , - ...


  

Betrifft: AW: nun denn ... von: Lemmi
Geschrieben am: 07.10.2014 09:14:49

Hallo neopa C (paneo,

..ich verstehe noch nicht ganz!
Was muss ich tun!

Gruß
Lemmi


  

Betrifft: dazu ... von: neopa C (paneo)
Geschrieben am: 07.10.2014 09:18:21

Hallo Lemmi,

... kopiere: =WECHSELN("neopaCode";"Co";ZEICHEN(64)&"email.") und füge es in eine frei Excelzelle. Als Ergebnis erhältst Du das gewünschte. Nun verständlich?

Gruß Werner
.. , - ...


  

Betrifft: AW: dazu ... von: Lemmi
Geschrieben am: 07.10.2014 09:41:37

Hallo neopa C (paneo,

Datei ist unterwegs!

Gruß
Lemmi


  

Betrifft: gugg mer mal ... von: neopa C (paneo)
Geschrieben am: 07.10.2014 10:26:31

Hallo Lemmi,

... allerdings dann wahrscheinlich erst am späteren Nachmittag.


Gruß Werner
.. , - ...


  

Betrifft: hab ich jetzt ... und ... von: neopa C (paneo)
Geschrieben am: 07.10.2014 14:22:59

Hallo Lemmi,

... hab in Deiner Datei einfach wild Daten durch ziehendes kopieren ergänzt.

Mit folgenden Formeln werden bei mir 4,14 Mio Datenwerte mit folgenden drei Formeln auf einem altersschwachen PC noch in vertretbarer Zeit ausgewertet (das Abspeichern der Datei dauert viel länger):

 C
520129
623800
723800

Formeln der Tabelle
ZelleFormel
C5{=SUMME(N(HÄUFIGKEIT(WENN(I10:DZ29999>I$5:DZ$5;ZEILE(A10:A29999)); ZEILE(A10:A29999))>0))}
C6{=SUMME(N(HÄUFIGKEIT(WENN((I10:FZ29999<I$7:FZ$7)*(I10:FZ29999<>""); ZEILE(A10:A29999)); ZEILE(A10:A29999))>0))}
C7{=SUMME(N(HÄUFIGKEIT(WENN(((I10:FZ29999<I$7:FZ$7)+(I10:FZ29999<I$7:FZ$7))*(I10:FZ29999<>""); ZEILE(A10:A29999)); ZEILE(A10:A29999))>0))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Werner
.. , - ...


  

Betrifft: AW: hab ich jetzt ... und ... von: Lemmi
Geschrieben am: 07.10.2014 18:10:49

Hallo Werner,

das Ganze sieht ersteinaml sehr gut aus.
zum Testen in mehreren Dateien werde ich allerdings erst Fr. kommem!


Danke!
Gruß
Lemmi


  

Betrifft: dann bis Freitag ... von: neopa C (paneo)
Geschrieben am: 08.10.2014 07:50:37

Hallo Lemmi,

... da Du erst noch testen willst, ist es auch nicht notwendig, dass der Thread auf offen gesetzt ist.


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Zählen von Zeilen"