Vergleich und Ausgabe eines Names untereinander

Bild

Betrifft: Vergleich und Ausgabe eines Names untereinander
von: Roffel89
Geschrieben am: 11.09.2015 09:09:04

Hallo liebe Forum User,
ich bräuchte dringend mal Hilfe bei einem Excel Problem und zwar geht es um Folgendes:
Sehe angehängte Dateien.
Ich habe zwei Tabellen:
1. Tabelle: (Blatt 1) Ist quasi eine Art Deckblatt Summary und soll mir einen Namen wiedergeben der in der Tabelle 2 auf Blatt 2 zu finden ist. Und es soll den Namen nur wiedergeben, wenn in Tabelle 2. dieser Name in Spalte F das Wort "gesperrt" und in Spalte H "freigeben" zu finden ist.
Die Formel soll dann quasi die ganze Tabelle 2. prüfen und die Namen mit den Treffern dann in der Tabelle 1. untereinandder ausgeben.
Versteht man meine Fragen überhaupt so?^^
Ich habe bisher ein wenig mit der Formel Index rumgebastelt, aber da kam ich nicht auf das gewünschte Ergebnis...
Wäre super dankbar, wenn mir jemand weiterhelfen könnte.
Viele Grüße

Bild

Betrifft: AW: Vergleich und Ausgabe eines Names untereinander
von: Roffel89
Geschrieben am: 11.09.2015 09:12:41
Userbild

Bild

Betrifft: AW: Vergleich und Ausgabe eines Names untereinander
von: Roffel89
Geschrieben am: 11.09.2015 09:13:48
Userbild

Bild

Betrifft: AW: Vergleich und Ausgabe eines Names untereinander
von: SF
Geschrieben am: 11.09.2015 09:16:52
Hola,
warum schreibst du nicht dazu, welche Formel du schon hast?
http://www.office-loesung.de/p/viewtopic.php?f=166&t=702017
Gruß,
steve1da

Bild

Betrifft: AW: Vergleich und Ausgabe eines Names untereinander
von: Roffel89
Geschrieben am: 11.09.2015 09:33:16
Hallo,
meine erste Lösung war:
=WENN(UND('30112015'!F2="freigegeben";'30112015'!H2="gesperrt");'30112015'!A2;" ")
diese erfüllt aber nicht meine Aufgabenstellung. Hier muss man ja in Aufgabenblatt 1 immer die Zeilenanzahl anpassen manuell und ich will ja, dass nur die Treffer direct untereinander angezeigt werden.
Viele Grüße

Bild

Betrifft: Namenstreffer auflisten
von: WF
Geschrieben am: 11.09.2015 09:30:37
Hi,
in Tabelle2 stehen in Spalte A die Namen, in F "gesperrt" oder nichts, in H "freigeben" oder nichts.
Das konfuse Zeug Deiner Folgebeiträge ignoriere ich.
In Tabelle1 in A1 folgende Arrayformel:
{=INDEX(Tabelle2!A:A;KKLEINSTE(WENN((Tabelle2!F$1:F$99="gesperrt")*(Tabelle2!H$1:H$99="freigeben"); ZEILE($1:$99));ZEILE(A1))) }
runterkopieren
Salut WF

Bild

Betrifft: AW: Namenstreffer auflisten
von: Roffel89
Geschrieben am: 11.09.2015 09:41:36
Hallo WF,
vielen Dank für deine Hilfe.
Nun sieht meine Formel so aus:
30112015 ist der Name vom Tabellenblatt 2. und C14 die Zelle, in der ich die Formel reinhauen würde.
Leider funktioniert das noch nicht. Siehst du da direct einen Fehler?
{=INDEX(30112015!A:A;KKLEINSTE(WENN((30112015!F$1:F$99="gesperrt")*30112015!H$1:H$99="freigegeben"); ZEILE($1:$99));ZEILE(C14))) }
Viele Grüße

Bild

Betrifft: ZEILE ist ein Zähler und MUSS mit 1 beginnen
von: WF
Geschrieben am: 11.09.2015 09:54:35
Hi,
und eine Klammer fehlt.
in C14:
{=INDEX('30112015'!A:A;KKLEINSTE(WENN(('30112015'!F$1:F$99="gesperrt") *('30112015'!H$1:H$99="freigegeben"); ZEILE($1:$99));ZEILE(X1))) }
ZEILE hat also nichts mit der Spalte - die ist wurscht - zu tun. Die Spaltenbezeichnung dient nur dem Runterkopieren; ich hab X genommen.
WF

Bild

Betrifft: AW: ZEILE ist ein Zähler und MUSS mit 1 beginnen
von: Roffel89
Geschrieben am: 11.09.2015 10:27:02
Hallo WF,
vielen herzlichen Dank. Hätte ja nicht mehr daran geglaubt, aber jetzt hat es mit deiner Hilfe tatsächlich geklappt.
Wenn ich es jetzt runterkopiere und es quasi weiter runterziehe als es Treffer gibt, kommt der Fehler:#Zahl! Gibt es da eine Möglichkeit das eleganter zu lösen. Quasi das die Zelle einfach leer bleibt oder sowas?
Beste Grüße

Bild

Betrifft: AW: ZEILE ist ein Zähler und MUSS mit 1 beginnen
von: SF
Geschrieben am: 11.09.2015 11:33:08
Hola,
pack einfach Wennfehler() drum rum:

{wennfehler(INDEX('30112015'!A:A;KKLEINSTE(WENN(('30112015'!F$1:F$99="gesperrt")  *('30112015'!H$1:H$99="freigegeben"); ZEILE($1:$99));ZEILE(X1)));"") }
Gruß,
steve1da

Bild

Betrifft: AW: ZEILE ist ein Zähler und MUSS mit 1 beginnen
von: Roffel89
Geschrieben am: 11.09.2015 11:57:23
Super, klappt. Vielen Dank steve1da!
VG

Bild

Betrifft: =WENNFEHLER(Formel;"")
von: WF
Geschrieben am: 11.09.2015 11:38:07
.

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Vergleich und Ausgabe eines Names untereinander "