Microsoft Excel

Herbers Excel/VBA-Archiv

Zellbezug aus Tabelle - horizontal & vertikal

Betrifft: Zellbezug aus Tabelle - horizontal & vertikal von: Ursula
Geschrieben am: 05.02.2020 17:53:47

Hallo zusammen

Kann mir jemand bei der folgenden Formel helfen?

Ich wollte es mit sverweis lösen, dies geht jedoch nicht:

Habe 2 Tabellenblätter:

Erstes Tabellenblatt: in der Spalte C muss der Bezug hergestellt werden zum entsprechenden Wert (aus Spalte A und B) aus dem 2ten Tabellenblatt einerseits:
1.) den Wert aus der vertikalen Spalte heraussucht und
2.) den dazugehörigen wert aus der Zeile

Tabellenblatt 1:, mit Resultat in Spalte C:

A , B, C
1c, 2, 300
2c, 1, 20
3c, 4, 4

Tabellenblatt 2:

A, B, C, D, E
0, 1, 2, 3, 4
1c, 200, 300, 400, 500
2c, 20, 30, 40, 50
3c, 1, 2, 3, 4

Gibt es dazu ein Formel?

Vielen Dank Ursula

Betrifft: AW: mit SVERWEIS() und VERGLEICH() ...
von: neopa C
Geschrieben am: 05.02.2020 18:02:00

Hallo Ursula,

... so: in C1: =SVERWEIS(A1;Tabelle2!A:Z;VERGLEICH(B1;Tabelle2!$1:$1;0))

und Formel nach unten kopieren. Formel bei Bedarf noch mit WENNFEHLER() klammern.

Gruß Werner
.. , - ...

Betrifft: AW: mit SVERWEIS() und VERGLEICH() ...
von: Ursula
Geschrieben am: 05.02.2020 21:04:33

Hallo Werner

Super - das klappt bestens :-))

Herzlichen Dank !!
Ursula

Betrifft: AW: Zellbezug aus Tabelle - horizontal & vertikal
von: SF
Geschrieben am: 05.02.2020 18:02:52

Hola,

natürlich geht das mit dem Sverweis.
Den Spaltenindex holst du dir über einen Vergleich(). Ansonsten:

https://www.herber.de/excelformeln/pages/Koordinaten_aus_Suchbegriff_in_Zeile_und_Spalte_bestimmen.html

Gruß,
steve1da

Betrifft: AW: Zellbezug aus Tabelle - horizontal & vertikal
von: Ursula
Geschrieben am: 05.02.2020 21:06:04

Danke steve1da!
Ich habe grad die Formel von Werner kopiert und das klappt gut.
LG Ursula

Beiträge aus dem Excel-Forum zum Thema "Zellbezug aus Tabelle - horizontal & vertikal"