Microsoft Excel

Herbers Excel/VBA-Archiv

Wenn-Formel - Arbeitszeit

Betrifft: Wenn-Formel - Arbeitszeit von: Horst
Geschrieben am: 12.09.2004 23:38:39

Hallo und schönen (Rest-)Sonntag,
ich habe meine Arbeitsmappe vorsichtshalber schon mal hochgeladen.
https://www.herber.de/bbs/user/10818.xls

Es geht um die Berechnung der täglichen (gleitenden) Arbeitszeit. In Spalte C können aber auch U=Urlaub; K=Krank oder D=Dienstreise eingetragen werden, mit der Folge, dass die tägliche Sollarbeitszeit von 7:36 Std gutgeschrieben wird.

Bei einer Arbeitszeit von mehr als 6 Std. muss eine halbstündige Mittagspause eingelegt werden. Eine halbe Stunde insgesamt wird in jedem Fall gekürzt, auch wenn nur 15 Min. Mittagspause gemacht wurde (insgesamt also 30 Min.)

Mein Problem:
Sobald die erste Zeit in Spalte C eingetragen wurde, errechnet Excel eine negative Zeit aus und schreibt sie in Spalte H.
Wie kann ich erreichen, dass Excel erst rechnet, wenn in Spalte F die letzte Zahl des jeweiligen Tages eingegeben wurde?

Ich probiere schon seit zwei Tagen herum, in der Recherche konnte ich auch nichts finden.

Für die Mühe schon mal vielen Dank im voraus.
MfG

  


Betrifft: AW: Wenn-Formel - Arbeitszeit von: M@x
Geschrieben am: 13.09.2004 00:01:08

Hi Horst
schreib in J folgende Formel
=WENN(ODER(C4="";D4="";E4="";F4="");;H4-I4)
löst das dein Problem??

Gruss

M@x


  


Betrifft: AW: Wenn-Formel - Arbeitszeit von: Horst
Geschrieben am: 13.09.2004 19:33:40


Guten Abend M@x,
vielen Dank für deine Mühe, leider hat dein Vorschlag mein Problem nicht gelöst.

Für weitere Vorschläge (nicht nur von M@x) wäre ich sehr dankbar.
mfg


  


Betrifft: AW: Wenn-Formel - Arbeitszeit von: Paula
Geschrieben am: 13.09.2004 20:33:49

hi Max,

Horst Vorschlag ist schon halb richtig.
Ändere auch die Zellen H3 ff. wie folgt
=WENN(ODER(C3="";F3="");;WENN(G3="";WENN(ISTZAHL(F3)*UND(SUMME(D3-C3)+(F3-E3)<Q$1);(D3-C3)+(F3-E3);(D3-C3)+(F3-E3)-P3);G3))

Viel Glück
Paula


  


Betrifft: AW: Wenn-Formel - Arbeitszeit von: Paula
Geschrieben am: 13.09.2004 20:46:57

hi Max,

Sorry, hier eine kleine Korrektur:
Ändere auch die Zellen H3 ff. wie folgt
=WENN(ODER(C3="";D3="";E3="";F3="");;WENN(G3="";WENN(ISTZAHL(F3)*UND(SUMME(D3-C3)+(F3-E3)<Q$1);(D3-C3)+(F3-E3);(D3-C3)+(F3-E3)-P3);G3))

So, jetzt müsste es funzen

Viel Glück
Paula


  


Betrifft: AW: Wenn-Formel - Arbeitszeit von: Horst
Geschrieben am: 14.09.2004 07:59:40

Hallo Paula,
vielen Dank. Es funzt.

mfg


 

Beiträge aus den Excel-Beispielen zum Thema "Wenn-Formel - Arbeitszeit"