sehr sehr viele Bedingungen???

Bild

Betrifft: sehr sehr viele Bedingungen???
von: Marcel
Geschrieben am: 25.04.2005 16:06:42
Hallo Excelfeunde,
ich habe da mal eine Aufgabe die mir irgendwie unlösbar erscheint, sind einfach zu viele Bedingungen zu erfüllen. Ich hoffe Ihr könnt mir da weiterhelfen, ist aber wohl eher was für Mathematiker. vilen Dank schonmal Marcel
Es soll eine Summe in Zelle O11 gebildet werden, wenn eine Zahl im Bereich $B$19:$B$10000 auf TB POO gleich der Zahl in Zelle $C$3 auf TB LZB ist und wenn auf TB POO im Bereich $C$19:$C$10000 ein Wert gleich der Zelle A11 auf TB LZB ist und wenn auf TB POO im Bereich $E$19:$E$10000 die letzten 5 Zahlen 75639 sind.
Wenn diese Bedingungen erfüllt sind, dann sollen im Bereich $D$19:$D$10000 auf TB POO die Zellwerte mit dem Bereich $B$18:$B$10000 auf TB OKW vergleichen werden und die Summe aus dem Bereich $G$18:$G$10000 von TB OKW gebildet werden.
https://www.herber.de/bbs/user/21680.xls

Bild

Betrifft: AW: sehr sehr viele Bedingungen???
von: MichaV
Geschrieben am: 25.04.2005 17:39:02
Hi,
... dann sollen im Bereich $D$19:$D$10000 auf TB POO die Zellwerte mit dem Bereich $B$18:$B$10000 auf TB OKW vergleichen werden und die Summe aus dem Bereich $G$18:$G$10000 von TB OKW gebildet werden.
...wozu der Vergleich? Irgendwie fehlt da eine Bedingung. Schwer, den Durchblick zu halten, bei all den Vergleichen, was? ;o) Also schieb mal noch eine weitere Bedingung nach, dann kann Dir geholfen werden.
Gruß- Micha
Bild

Betrifft: AW: sehr sehr viele Bedingungen???
von: Marcel
Geschrieben am: 26.04.2005 10:26:23
Hallo Micha,
vielen Dank für die schnelle Antwort, vielleicht habe ich das Problem schlecht beschrieben. Ich versuchs nochmal anders zu formulieren. Vielleicht ist es dann einfacher.
es soll eine Summe gebildet werden, folgende Bedingungen erfüllt sind.
1) auf TB LZB in Zelle $C$3 setht eine Zahl, diese Zahl muss auch im TB POO im Bereich $B$19:$B$10000 gefunden werden.
2) auf TB LZB in Zelle A11 steht eine Zahl, diese Zahl muss auch im TB POO im Bereich $C$19:$C$10000 gefunden werden.
3)auf TB POO im Bereich $E$19:$E$10000 müssen die letzten 5 Zahlen 75639 sein.
4) Sind diese Bedingungen, hier z.B. in Zeile 20 auf POO, erfüllt dann soll auf TB POO im Bereich $D$19:$D$10000 die Zahlen mit dem Bereich $B$18:$B$10000 auf TB OKW verglichen werden. stimmt eine Zahl (auf Zeilenebene), dann soll die Summe aus dem Bereich $G$18:$G$10000 von TB OKW gebildet werden.
Gruss
Marcel
Bild

Betrifft: AW: sehr sehr viele Bedingungen???
von: Marcel
Geschrieben am: 26.04.2005 11:19:11
Hallo Micha,
habe in der XLS Datei nur einen Ausschnitt bereitgestellt, um auch auch ein Ergebnis zu erzielen kannst du vielleicht mal die Zahl 250168194 in irgendeine Zelle in Spalte B auf TB OKW schreiben, die Summe aus der Spalte G TB OKW ist dann das Ergebnis in Zelle O22 auf TB LZB, ich habs mal so versucht, komme aber irgendwie nicht weiter.
=SUMMENPRODUKT((A23=POO!$B$19:$B$10000)*($C$3=POO!$C$19:$C$10000)*RECHTS(POO!$E$19:POO!$E$10000;5)=75639)*(SUMMEWENN(POO!$D$19:$D$51;OKW!$C$19:$C$51;OKW!$G$18:$G$50))
Gruss
Marcel
Bild

Betrifft: AW: sehr sehr viele Bedingungen???
von: Marcel
Geschrieben am: 26.04.2005 11:26:56
hab mich vertippt, die Formel sollte so heissen
=SUMMENPRODUKT((A23=POO!$B$19:$B$10000)*($C$3=POO!$C$19:$C$10000)*(RECHTS(POO!$E$19:POO!$E$10000;5)=75639)*(SUMMEWENN(POO!$D$19:$D$10000;OKW!$C$19:$C$10000;OKW!$G$18:$G$10000)))
Bild

Betrifft: AW: sehr sehr viele Bedingungen???
von: MichaV
Geschrieben am: 26.04.2005 11:34:45
Hi Marcel,
ich setz mich heut abend ran, wenns noch nicht erledigt ist. Kann ich auch ein bischen üben. Aber irgendwie ein bischen krank, diese Abfrage, findest Du nicht (die letzten 5 Zeilen sollen xxx sein usw)?
Meinst du, das kann man noch ein bischen vereinfachen, vielleicht durch eine andere Datenstruktur oder sowas?
Bis heut abend- Micha
Bild

Betrifft: AW: sehr sehr viele Bedingungen???
von: Marcel
Geschrieben am: 26.04.2005 11:39:52
Hallo Micha,
ja ist schon wirklich etwas naja merkwürdig, aber das Excelsheet kommt aus Business Warehouse und die Daten lassen sich leider nicht anders abgreifen.
Sorry, aber was meinst du mit die letzten 5 Zeilen sollen xxx sein?
Gruss
Marcel
Bild

Betrifft: Neuer Thread
von: Martin Beck
Geschrieben am: 29.04.2005 11:28:27
Hier gehts weiter:
https://www.herber.de/forum/messages/605511.html
 Bild

Beiträge aus den Excel-Beispielen zum Thema "sehr sehr viele Bedingungen??? "