Microsoft Excel

Herbers Excel/VBA-Archiv

Durchschnitt bilden unter bestimmten Bedingungen

Betrifft: Durchschnitt bilden unter bestimmten Bedingungen von: Reni
Geschrieben am: 02.10.2014 11:16:14

Hallo,
ich würde gerne das Durchschnittsalter von allen Personen bilden, die den gleichen Namen in zwei verschiedenen Tabellen haben:

Zum Beispiel:

Tabelle 1:
Name Alter
Hans 19
Peter 49
Mario 54

Tabelle 2:
Name
Stefan
Hans
Mario

Es soll also nur das Alter von Hans und Mario zur Berechnung herangezogen werden.
Ich habe es schon mit SVERWEIS versucht, aber dort wird nur eine Zelle verglichen. Kann mir bitte jemand einen Tipp geben, wie ich es lösen könnte?

Gruß,
Reni

  

Betrifft: mit MITTELWERT(WENN(...);...) von: neopa C (paneo)
Geschrieben am: 02.10.2014 11:24:16

Hallo Reni,

... so:

 E
151,5

Formeln der Tabelle
ZelleFormel
E1{=MITTELWERT(WENN(ISTZAHL(VERGLEICH(A2:A99;Tabelle1!A2:A99;)); Tabelle1!B2:B99))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4

Gruß Werner
.. , - ...


  

Betrifft: 51,5 von Dir sind falsch von: WF
Geschrieben am: 02.10.2014 12:26:40

Hans ist 19, Mario 54 - Mittelwert ist 36,5 wie bei M.vdT.

WF


  

Betrifft: richtig, ich hatte die Daten anders zu stehen, ... von: neopa C (paneo)
Geschrieben am: 02.10.2014 13:00:00

Hallo WF,

... wenn sie richtig stehen (wie vorgegeben!), dann muss natürlich mein Bezug innerhalb VERGLEICH() genau gedreht stehen. Siehe nachstehend.

Sorry, Reni, wenn ich Dich damit evtl. verwirrt haben sollte.

Tab2

 ABCDE
1Name   36,5
2Stefan    
3Hans    
4Mario    
5     

Formeln der Tabelle
ZelleFormel
E1{=MITTELWERT(WENN(ISTZAHL(VERGLEICH('Tab1'!A2:A99;A2:A99;)); 'Tab1'!B2:B9))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!


Tab1

 AB
1NameAlter
2Hans19
3Peter49
4Mario54
5  


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


Gruß Werner
.. , - ...


  

Betrifft: na ja, 51,5 hattest Du explizit geschrieben von: WF
Geschrieben am: 02.10.2014 13:19:50

und bei nur 2 Zahlen kann man den Mittelwert zur Kontrolle auch im Kopf rechnen.

WF


  

Betrifft: der Mittelwert aus 49 und 54 = 51,5 da ... von: neopa C (paneo)
Geschrieben am: 02.10.2014 13:38:16

Hallo WF,

... eben die Daten von mir falsch zugeordnet waren (ich hatte mal nicht kopiert sondern abgeschrieben, aber eben mehrfach falsch).

Dass ich damit Reni evtl. verwirrt habe, habe ich ja bereits bedauert und hier ja auch die korrekte Datengrundlage und meine diesbzgl. korrekte Formel nachträglich noch komplett zur Verfügung gestellt.

Und das ich im Kopf noch den Mittelwert von zwei Werten richtig überschlagen kann, kannst Du mir ja vielleicht noch abnehmen. Aber wenn ich (selbstverschuldet) zwei falsche Werte dem zu Grunde lege habe, dann natürlich nicht. Natürlich ärgere ich mich deswegen auch, aber es gibt auch schlimmeres.

Gruß Werner
.. , - ...


  

Betrifft: AW: Durchschnitt bilden unter bestimmten Bedingungen von: Klaus M.vdT.
Geschrieben am: 02.10.2014 11:25:19

Hallo Reni,
einfach eine Hilfsspalte.
Tabelle1:
Spalte A: Name
Spalte B: Alter
Spalte C: Hilfsspalte

Tabelle2:
Spalte A: Name

Tabelle1
ab C2 (in C1 stehen Überschriften) die Formel herunterkopieren:

=WENN(ZÄHLENWENN(Tabelle2!A:A;A2)>0;B2;"")
Jetzt bildest du einfach den Mittelwert aus Spalte C.


Alternative ohne Hilfsspalte:
{=MITTELWERT(WENN(ZÄHLENWENN(Tabelle2!A:A;A2:A100)>0;B2:B100;""))}

Als Matrixformel, die {} nicht mit eingeben sondern durch STRG+SHIFT+ENTER erzeugen. Ist im Gegensatz zur Hilfsspaltenlösung aber kriechend langsam.

Grüße,
Klaus M.vdT.


  

Betrifft: den Bereich auf das notwendige beschränken ... von: neopa C (paneo)
Geschrieben am: 02.10.2014 11:30:14

Hallo Klaus,

... dann ist es nicht "kriechend langsam."

Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Durchschnitt bilden unter bestimmten Bedingungen"