Monatskalender mit wöchentlicher Stundenabrechnung

Bild

Betrifft: Monatskalender mit wöchentlicher Stundenabrechnung
von: SimHa
Geschrieben am: 21.09.2015 13:53:26

Hallo Zusammen,
für meine Arbeit soll ich eine Exceldatei entwickeln in der die Studentischen Hilfskräfte ihre Stunden eintragen können. Im Moment kann man unter anderem per Dropdown-Menü Monat und die vertraglich festgelegten Wochenstunden auswählen.
Die Stunden sollen Wochenweise abgerechnet werden.
Es gilt dabei zu überprüfen ob aufgrund zu viel geleisteter Arbeitsstunden in der Woche, der durchschnittliche Stundenlohn den gesetzlich vorgeschriebenen Mindeststundenlohn von 8,50 € unterschreitet. Z.B. Jmd ist für 12 Std/Woche angestellt und verdient 9,90€/Std, arbeitet aber 16 Std.. daraus folg 12*9,90 ist 118,80...teilt man dies durch die geleisteten 16 Std, so käme ein Stundenlohn von 7,425 € raus. Nun soll eine Warnung erscheinen.
Dies Funktioniert mit meinen derzeitigen File.
Problem ist nun folgendes:
Beginnt/endet ein Monat unter der Woche, so müssten die Wochenarbeitstage anteilig gerechnet werden. Z.B. Monat beginnt mit einem Dienstag so müssen noch 4/5 von den 12 Stunden gearbeitet werden. Dies sollte in der Rechnung berücksichtigt und richtig angezeigt werden. Hat hierzu jmd eine Idee wie das funktionieren könnte?
Etwas zu meinem File:
A=DATUM($E$4;MONAT($B$4&0);TAG(B7))
B=DATUM(E4;MONAT(B4&0);1)
C=Eingabe Uhrzeit
D=Eingabe Endzeit
E=Eingabe Pausendauer
F=WENN(D7="";"";(STUNDE(D7)+MINUTE(D7)/60-(STUNDE(C7)+MINUTE(C7)/60)-E7))
G=WENN(A7="";"";WENN(WOCHENTAG(A7;2)=5;SUMME(F1:F7);""))
H6==WENN(G7="";"";SUMME($G$7:G7;$H$5))
I7=WENN(H7="";"";(1+(($E$4)-JAHR($C$5))*52+ISOKALENDERWOCHE(B7)-ISOKALENDERWOCHE($C$5))*$I$4)
Was auch noch interessant wäre, wäre ob und wenn ja, wie das funktionieren würde wenn ich über das Monatsdropdown ein neues Monat auswähle, dass dabei ein neues Tabellenblatt mit dem gewählten Kalendermonat erstellt wird? Funktioniert das?
Für eure Hilfe wäre ich sehr dankbar!
MfG SimHa

Bild

Betrifft: Bild
von: SimHa
Geschrieben am: 21.09.2015 13:54:49
Userbild

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summe nach makro Filter"