Microsoft Excel

Herbers Excel/VBA-Archiv

probleme beim summieren

Betrifft: probleme beim summieren von: genmaicha
Geschrieben am: 26.08.2004 16:14:27



ich summiere einige zellen und es gelingt mir nicht weil ich in bestimmten zellen eine formel habe die manchmal den wert #NV anzeigt. dieser wert wird dann in die gesammtsumme übernommen. die formel in dieser zelle lautet :=SVERWEIS(F24;A$72:B$226;2;FALSCH). wie kann ich den sverweis so ändern, dass wenn der wert 0 ist nicht #NV sonder null erscheint?

  


Betrifft: AW: probleme beim summieren von: HermannZ
Geschrieben am: 26.08.2004 16:17:59

Hallo genmaicha,

hier eine Formel von Boris damit läst das umgehen.

Summe
 A
392Summe wenn eine oder mehrere Zelle #NV
393 
394 
3951
3961
397#NV
3982
Formeln der Tabelle
A398 : =SUMMEWENN(A395:A397;"<1E+307")
 
Diagramm - Grafik - Excel Tabellen einfach im Web darstellen    Excel Jeanie HTML  3.0    Download  



Gruß hermann


  


Betrifft: AW: probleme beim summieren von: AndreasSt
Geschrieben am: 26.08.2004 16:18:46


Hallo,

=wenn(Istfehler(SVERWEIS(F24;A$72:B$226;2;FALSCH);0;SVERWEIS(F24;A$72:B$226;2;FALSCH)))

Gruß
Andreas


  


Betrifft: AW: probleme beim summieren von: Günther Oppold
Geschrieben am: 26.08.2004 16:19:19

Hallo

versuchs mit:
=wenn(istfehler(SVERWEIS(F24;A$72:B$226;2;FALSCH));0;SVERWEIS(F24;A$72:B$226;2;FALSCH))


Günther
PS: Höflichkeit ist eine Zier viel weiter kommt man ohne ihr - oder wie????


  


Betrifft: AW: probleme beim summieren von: Andreas Walter
Geschrieben am: 26.08.2004 16:20:10

Das ist ein FAQ und steht in der Recherche
Du hast
=SVERWEIS(F24;A$72:B$226;2;FALSCH)

Schreib
=wenn(istfehler(SVERWEIS(F24;A$72:B$226;2;FALSCH);0;SVERWEIS(F24;A$72:B$226;2;FALSCH))


  


Betrifft: AW: probleme beim summieren von: Jens
Geschrieben am: 26.08.2004 16:36:35

Hallo
diese Lösung ist für NULL oder NICHTS in F24:

=WENN(F24=0;0;SVERWEIS(F24;A$72:B$226;2;FALSCH))

Gruß - Jens


 

Beiträge aus den Excel-Beispielen zum Thema "probleme beim summieren"