Herbers Excel-Forum - das Archiv

Bestimmte Werte ersetzen

Bild

Betrifft: Bestimmte Werte ersetzen
von: Daniel

Geschrieben am: 28.02.2005 19:53:54
Hallo Zusammen!
Ich muss eine Aufgabe bewältigen, die wie ich denke, nur per Mako vernünftig lösbar ist. Ansonsten wäre das zu viel manueller Aufwand, da man in meiner Originaldatei über 50.000 Zeilen prüfen müsste.
Ich hoffe daher, dass mir jemand weiterhelfen kann.
Alles Weitere habe ich gleich in einer Beispieldatei beschrieben:
https://www.herber.de/bbs/user/18963.xls
Vielen Dank für Hilfe,
Daniel
Bild

Betrifft: Matrixformel
von: IngoG

Geschrieben am: 01.03.2005 20:43:09
Hallo Daniel,
hab mal eine Lösung mit Matrixformel gestrickt...
in zelle n2 gibst Du folgende Formel ein:
=WENN(M2="PT";MIN(WENN((D2=$D$2:$D$50000)*($E$2:$E$50000=E2)*($M$2:$M$50000="PT");$G$2:$G$50000));G2)
Eingabe abschließen mit Strg-Shift-Enter
die Formel anschließend nach unten ziehen...
Damit nicht ständig gerechnet wird kannst Du anschließend einfach die spalte kopieren und mit Bearbeuten/inhalte einfügen/Werte über die spalte g kopieren...
Vielleicht hlft Dir die Lösung ja weiter
Gruß Ingo
 Bild
Excel-Beispiele zum Thema "Bestimmte Werte ersetzen"
Befindet sich die aktive Zelle in einem bestimmten Bereich? Werte eins bestimmten Monats summieren
Werte 1 und 0 in einem bestimmten Verhältnis zufällig anordnen Alle Links zu einer bestimmten Arbeitsmappe löschen
Anzahl eines bestimmten Wochentages im Monat Alle Dateien ab einem bestimmten Datum listen
Daten eines bestimmten Jahres filtern Word mit bestimmtem Dokument starten
Bestimmte Anzahl von Zeichen zulassen Zeilen löschen, wenn in bestimmten Spalten keine Werte stehen