Microsoft Excel

Herbers Excel/VBA-Archiv

Summieren von Zahlen | Herbers Excel-Forum


Betrifft: Summieren von Zahlen von: Torsten Krüger
Geschrieben am: 13.11.2009 16:07:51

Hi habe folgendes Problem.
Habe eine Tabelle die wie folgt aussieht
A B
1 Hr 16
2 Hr 1
3 Hr 4
4 Ku 2
5 Hr 5
6 Kru 17
7 Fie 7
8 Fir 22
9 Kru 21
10 Kru 5
11 Fir 12
12 Fir 7

Ich möchte nun erreichen das Excel mir in eine Zelle, nennen wir sie mal c20, alle Zahlen addiert denen ein Hr vorrausgeht. In Zelle c21 alle denen ein Ku vorgeht und in c22 alle denen ein Kru vorangeht usw.

Danke schon mal im vorraus!
Gruß Torsten Krüger

  

Betrifft: AW: guckst Du: Summewenn(..) oT. von: Petra
Geschrieben am: 13.11.2009 16:09:16




  

Betrifft: AW: Summieren von Zahlen von: Mike
Geschrieben am: 13.11.2009 16:26:01


Hey Torsten,

da Deine nächste Frage vielleicht lauten könnte "wie finde ich automatisch
heraus, nach was summiert werden soll" nachfolgend eine erweiterte Lösung:
(weil es Freitag der 13te ist .. smile)


Vorlage

 ABCDEFGH
8  Einzigartig  sortiert    Deine DatenDeine Werte
968Hr66Fie    Hr16
1070Ku67Fir    Hr1
1169Kru68Hr    Hr4
1266Fie69Kru    Ku2
1367Fir70Ku    Hr5
141000  71      Kru17
151000  72      Fie7
161000  73      Fir22
171000  74      Kru21
181000  75      Kru5
191000  76      Fir12
201000  77      Fir7
211000  78      Hr16
221000  79      Hr1
231000  80      Hr4
241000  81      Ku2
251000  82      Hr5
261000  83      Kru17
271000  84      Fie7
281000  85      Fir22
291000  86      Kru21
301000  87      Kru5
311000  88      Fir12
321000  89      Fir7
331000  90      Fir12
341000  91      Fir7
351000  92         
781000  135         
791000  136         
80          TOTAL  257
81               
82               
83               
84            Auswertung nach Bereich 
85               
86            TOTAL 257
87            Checkok
88               
89    66      Fie 14
90    67      Fir 101
91    68      Hr 52
92    69      Kru 86
93    70      Ku 4
94    71        -
95    72        -
Bedingte Formatierung wird in dieser Tabelle nicht dargestellt

verwendete Formeln
Zelle Formel
A9 {=WENN(B9=0;1000;SUMME(WENN(B$9:B$79<B9;1))+(B9="")*1000)}
B9 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A1)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A1))))}
C9 =KKLEINSTE(A9:A79;1)
D9 =WENN(ISTNV(SVERWEIS(C9;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C9;$A$9:$B$79; 2; FALSCH))
A10 {=WENN(B10=0;1000;SUMME(WENN(B$9:B$79<B10;1))+(B10="")*1000)}
B10 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A2)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A2))))}
C10 =C9+1
D10 =WENN(ISTNV(SVERWEIS(C10;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C10;$A$9:$B$79; 2; FALSCH))
A11 {=WENN(B11=0;1000;SUMME(WENN(B$9:B$79<B11;1))+(B11="")*1000)}
B11 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A3)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A3))))}
C11 =C10+1
D11 =WENN(ISTNV(SVERWEIS(C11;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C11;$A$9:$B$79; 2; FALSCH))
A12 {=WENN(B12=0;1000;SUMME(WENN(B$9:B$79<B12;1))+(B12="")*1000)}
B12 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A4)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A4))))}
C12 =C11+1
D12 =WENN(ISTNV(SVERWEIS(C12;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C12;$A$9:$B$79; 2; FALSCH))
A13 {=WENN(B13=0;1000;SUMME(WENN(B$9:B$79<B13;1))+(B13="")*1000)}
B13 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A5)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A5))))}
C13 =C12+1
D13 =WENN(ISTNV(SVERWEIS(C13;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C13;$A$9:$B$79; 2; FALSCH))
A14 {=WENN(B14=0;1000;SUMME(WENN(B$9:B$79<B14;1))+(B14="")*1000)}
B14 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A6)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A6))))}
C14 =C13+1
D14 =WENN(ISTNV(SVERWEIS(C14;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C14;$A$9:$B$79; 2; FALSCH))
A15 {=WENN(B15=0;1000;SUMME(WENN(B$9:B$79<B15;1))+(B15="")*1000)}
B15 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A7)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A7))))}
C15 =C14+1
D15 =WENN(ISTNV(SVERWEIS(C15;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C15;$A$9:$B$79; 2; FALSCH))
A16 {=WENN(B16=0;1000;SUMME(WENN(B$9:B$79<B16;1))+(B16="")*1000)}
B16 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A8)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A8))))}
C16 =C15+1
D16 =WENN(ISTNV(SVERWEIS(C16;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C16;$A$9:$B$79; 2; FALSCH))
A17 {=WENN(B17=0;1000;SUMME(WENN(B$9:B$79<B17;1))+(B17="")*1000)}
B17 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A9)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A9))))}
C17 =C16+1
D17 =WENN(ISTNV(SVERWEIS(C17;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C17;$A$9:$B$79; 2; FALSCH))
A18 {=WENN(B18=0;1000;SUMME(WENN(B$9:B$79<B18;1))+(B18="")*1000)}
B18 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A10)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A10))))}
C18 =C17+1
D18 =WENN(ISTNV(SVERWEIS(C18;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C18;$A$9:$B$79; 2; FALSCH))
A19 {=WENN(B19=0;1000;SUMME(WENN(B$9:B$79<B19;1))+(B19="")*1000)}
B19 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A11)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A11))))}
C19 =C18+1
D19 =WENN(ISTNV(SVERWEIS(C19;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C19;$A$9:$B$79; 2; FALSCH))
A20 {=WENN(B20=0;1000;SUMME(WENN(B$9:B$79<B20;1))+(B20="")*1000)}
B20 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A12)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A12))))}
C20 =C19+1
D20 =WENN(ISTNV(SVERWEIS(C20;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C20;$A$9:$B$79; 2; FALSCH))
A21 {=WENN(B21=0;1000;SUMME(WENN(B$9:B$79<B21;1))+(B21="")*1000)}
B21 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A13)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A13))))}
C21 =C20+1
D21 =WENN(ISTNV(SVERWEIS(C21;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C21;$A$9:$B$79; 2; FALSCH))
A22 {=WENN(B22=0;1000;SUMME(WENN(B$9:B$79<B22;1))+(B22="")*1000)}
B22 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A14)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A14))))}
C22 =C21+1
D22 =WENN(ISTNV(SVERWEIS(C22;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C22;$A$9:$B$79; 2; FALSCH))
A23 {=WENN(B23=0;1000;SUMME(WENN(B$9:B$79<B23;1))+(B23="")*1000)}
B23 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A15)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A15))))}
C23 =C22+1
D23 =WENN(ISTNV(SVERWEIS(C23;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C23;$A$9:$B$79; 2; FALSCH))
A24 {=WENN(B24=0;1000;SUMME(WENN(B$9:B$79<B24;1))+(B24="")*1000)}
B24 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A16)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A16))))}
C24 =C23+1
D24 =WENN(ISTNV(SVERWEIS(C24;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C24;$A$9:$B$79; 2; FALSCH))
A25 {=WENN(B25=0;1000;SUMME(WENN(B$9:B$79<B25;1))+(B25="")*1000)}
B25 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A17)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A17))))}
C25 =C24+1
D25 =WENN(ISTNV(SVERWEIS(C25;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C25;$A$9:$B$79; 2; FALSCH))
A26 {=WENN(B26=0;1000;SUMME(WENN(B$9:B$79<B26;1))+(B26="")*1000)}
B26 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A18)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A18))))}
C26 =C25+1
D26 =WENN(ISTNV(SVERWEIS(C26;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C26;$A$9:$B$79; 2; FALSCH))
A27 {=WENN(B27=0;1000;SUMME(WENN(B$9:B$79<B27;1))+(B27="")*1000)}
B27 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A19)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A19))))}
C27 =C26+1
D27 =WENN(ISTNV(SVERWEIS(C27;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C27;$A$9:$B$79; 2; FALSCH))
A28 {=WENN(B28=0;1000;SUMME(WENN(B$9:B$79<B28;1))+(B28="")*1000)}
B28 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A20)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A20))))}
C28 =C27+1
D28 =WENN(ISTNV(SVERWEIS(C28;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C28;$A$9:$B$79; 2; FALSCH))
A29 {=WENN(B29=0;1000;SUMME(WENN(B$9:B$79<B29;1))+(B29="")*1000)}
B29 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A21)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A21))))}
C29 =C28+1
D29 =WENN(ISTNV(SVERWEIS(C29;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C29;$A$9:$B$79; 2; FALSCH))
A30 {=WENN(B30=0;1000;SUMME(WENN(B$9:B$79<B30;1))+(B30="")*1000)}
B30 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A22)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A22))))}
C30 =C29+1
D30 =WENN(ISTNV(SVERWEIS(C30;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C30;$A$9:$B$79; 2; FALSCH))
A31 {=WENN(B31=0;1000;SUMME(WENN(B$9:B$79<B31;1))+(B31="")*1000)}
B31 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A23)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A23))))}
C31 =C30+1
D31 =WENN(ISTNV(SVERWEIS(C31;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C31;$A$9:$B$79; 2; FALSCH))
A32 {=WENN(B32=0;1000;SUMME(WENN(B$9:B$79<B32;1))+(B32="")*1000)}
B32 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A24)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A24))))}
C32 =C31+1
D32 =WENN(ISTNV(SVERWEIS(C32;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C32;$A$9:$B$79; 2; FALSCH))
A33 {=WENN(B33=0;1000;SUMME(WENN(B$9:B$79<B33;1))+(B33="")*1000)}
B33 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A25)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A25))))}
C33 =C32+1
D33 =WENN(ISTNV(SVERWEIS(C33;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C33;$A$9:$B$79; 2; FALSCH))
A34 {=WENN(B34=0;1000;SUMME(WENN(B$9:B$79<B34;1))+(B34="")*1000)}
B34 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A26)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A26))))}
C34 =C33+1
D34 =WENN(ISTNV(SVERWEIS(C34;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C34;$A$9:$B$79; 2; FALSCH))
A35 {=WENN(B35=0;1000;SUMME(WENN(B$9:B$79<B35;1))+(B35="")*1000)}
B35 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A27)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A27))))}
C35 =C34+1
D35 =WENN(ISTNV(SVERWEIS(C35;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C35;$A$9:$B$79; 2; FALSCH))
A78 {=WENN(B78=0;1000;SUMME(WENN(B$9:B$79<B78;1))+(B78="")*1000)}
B78 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A70)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A70))))}
C78 =C77+1
D78 =WENN(ISTNV(SVERWEIS(C78;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C78;$A$9:$B$79; 2; FALSCH))
A79 {=WENN(B79=0;1000;SUMME(WENN(B$9:B$79<B79;1))+(B79="")*1000)}
B79 {=WENN(ISTFEHLER(INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A71)))); ""; INDEX($G$9:G$79;KKLEINSTE(WENN(ZÄHLENWENN(BEREICH.VERSCHIEBEN($G$9;;;ZEILE($1:$71));$G$9:$G$79)=1;ZEILE($1:$71));ZEILE(A71))))}
C79 =C78+1
D79 =WENN(ISTNV(SVERWEIS(C79;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C79;$A$9:$B$79; 2; FALSCH))
H80 =SUMME(H9:H78)
H86 =SUMME(H89:H146)
H87 =WENN(H86=H80; "ok "; "Check ")
C89 =C9
G89 =WENN(ISTNV(SVERWEIS(C89;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C89;$A$9:$B$79; 2; FALSCH))
H89 =SUMMEWENN($G$9:$G$79; $G89; H$9:H$79)
C90 =C10
G90 =WENN(ISTNV(SVERWEIS(C90;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C90;$A$9:$B$79; 2; FALSCH))
H90 =SUMMEWENN($G$9:$G$79; $G90; H$9:H$79)
C91 =C11
G91 =WENN(ISTNV(SVERWEIS(C91;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C91;$A$9:$B$79; 2; FALSCH))
H91 =SUMMEWENN($G$9:$G$79; $G91; H$9:H$79)
C92 =C12
G92 =WENN(ISTNV(SVERWEIS(C92;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C92;$A$9:$B$79; 2; FALSCH))
H92 =SUMMEWENN($G$9:$G$79; $G92; H$9:H$79)
C93 =C13
G93 =WENN(ISTNV(SVERWEIS(C93;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C93;$A$9:$B$79; 2; FALSCH))
H93 =SUMMEWENN($G$9:$G$79; $G93; H$9:H$79)
C94 =C14
G94 =WENN(ISTNV(SVERWEIS(C94;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C94;$A$9:$B$79; 2; FALSCH))
H94 =SUMMEWENN($G$9:$G$79; $G94; H$9:H$79)
C95 =C15
G95 =WENN(ISTNV(SVERWEIS(C95;$A$9:$B$79; 2; FALSCH)); ""; SVERWEIS(C95;$A$9:$B$79; 2; FALSCH))
H95 =SUMMEWENN($G$9:$G$79; $G95; H$9:H$79)
{} Matrixformel mit Strg+Umschalt+Enter abschließen

bedingte Formatierung
Zelle   Typ   Operator   Formel1   Formel2   Format   Unterstrichen   Schrift- farbe Muster   Muster- farbe
C111.Bed.: Formel ist   =A11=1000   Test   12632256     
C121.Bed.: Formel ist   =A12=1000   Test   12632256     
C131.Bed.: Formel ist   =A13=1000   Test   12632256     
C141.Bed.: Formel ist   =A14=1000   Test   12632256     
C151.Bed.: Formel ist   =A15=1000   Test   12632256     
C161.Bed.: Formel ist   =A16=1000   Test   12632256     
C171.Bed.: Formel ist   =A17=1000   Test   12632256     
C181.Bed.: Formel ist   =A18=1000   Test   12632256     
C191.Bed.: Formel ist   =A19=1000   Test   12632256     
C201.Bed.: Formel ist   =A20=1000   Test   12632256     
C211.Bed.: Formel ist   =A21=1000   Test   12632256     
C221.Bed.: Formel ist   =A22=1000   Test   12632256     
C231.Bed.: Formel ist   =A23=1000   Test   12632256     
C241.Bed.: Formel ist   =A24=1000   Test   12632256     
C251.Bed.: Formel ist   =A25=1000   Test   12632256     
C261.Bed.: Formel ist   =A26=1000   Test   12632256     
C271.Bed.: Formel ist   =A27=1000   Test   12632256     
C281.Bed.: Formel ist   =A28=1000   Test   12632256     
C291.Bed.: Formel ist   =A29=1000   Test   12632256     
C301.Bed.: Formel ist   =A30=1000   Test   12632256     
C311.Bed.: Formel ist   =A31=1000   Test   12632256     
C321.Bed.: Formel ist   =A32=1000   Test   12632256     
C331.Bed.: Formel ist   =A33=1000   Test   12632256     
C341.Bed.: Formel ist   =A34=1000   Test   12632256     
C351.Bed.: Formel ist   =A35=1000   Test   12632256     
C781.Bed.: Formel ist   =A78=1000   Test   12632256     
C791.Bed.: Formel ist   =A79=1000   Test   12632256     

Tabellendarstellung in Foren Version 4.28


Gruss
Mike


  

Betrifft: AW: Summieren von Zahlen von: WHOW
Geschrieben am: 13.11.2009 16:35:27

Hallo Mike
ist das die Mücke, die zum Elefanten wird!
gings nicht etwas bescheidener?
Hoffen wir mal, daß Torsten da durchblickt.

Lieben Gruß


  

Betrifft: klar .. Summieren von Zahlen von: Mike
Geschrieben am: 13.11.2009 16:38:47

Hey Erstaunter,

klar doch, er kann sich ja auch nur den "Auswertung nach Bereich" ab G85
anschauen, dort ist dann die Summewenn() praktisch angewandt.

Gruss
Mike


  

Betrifft: AW: klar .. Summieren von Zahlen von: Torsten Krüger
Geschrieben am: 13.11.2009 17:21:32

Danke euch hat geklappt.
Habe auch durchgeblickt ;-))))))


Beiträge aus den Excel-Beispielen zum Thema "Summieren von Zahlen"