Microsoft Excel

Herbers Excel/VBA-Archiv

Dreifach und mehr färben | Herbers Excel-Forum


Betrifft: Dreifach und mehr färben von: Gregor
Geschrieben am: 10.01.2012 09:27:11

Hallo zusammen

Ist möchte in einer Spalte alle Werte färben, die mehr als 2-mal vorkommen. Im Forum habe ich Einträge für doppelte und mehr Werte gefunden, nicht aber für dreifach und mehr Werte. Wie ist das per VBA möglich?

Danke und Gruss
Gregor

  

Betrifft: AW: Dreifach und mehr färben von: Beverly
Geschrieben am: 10.01.2012 09:31:39

Hi Gregor,

weshalb per VBA? Damit sollte es auch mit der bedingten Formatierung gehen =ZÄHLENWENN(A:A;A1)>=3


GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Dreifach und mehr färben von: Josef Ehrensberger
Geschrieben am: 10.01.2012 09:31:57


Hallo Gregor,

warum VBA? Das geht doch einfach per bedingter Formatierung.

Tabelle2

 A
11
22
33
44
52
63
74
85
91
102
116
123
132
145

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat
A11. / Formel ist =ZÄHLENWENN($A$1:$A$14;A1)>2Abc


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4






« Gruß Sepp »



  

Betrifft: AW: Dreifach und mehr färben von: Rudi Maintaire
Geschrieben am: 10.01.2012 09:33:20

Hallo,
wozu VBA? Bedingte Formatierung.
Formel: =Zählenwenn(A:A;A1)>2 und Format wählen.

Gruß
Rudi


  

Betrifft: AW: Dreifach und mehr färben von: Gregor
Geschrieben am: 10.01.2012 10:04:06

Hallo

Danke an alle.
Ich wollte diese Formatierung in eine VBA-Prozedur einbauen. Nun mache ich das halt nachträglich manuel.

Gruss Gregor


  

Betrifft: AW: Dreifach und mehr färben von: Beverly
Geschrieben am: 10.01.2012 10:52:10

Hi Gregor,

hier trotzdem noch eine VBA-Lösung:

Sub Faerben()
   Dim lngZeile As Long
   For lngZeile = 1 To IIf(IsEmpty(Cells(Rows.Count, 1)), Cells(Rows.Count, 1).End(xlUp).Row,  _
Rows.Count)
      If Cells(lngZeile, 1) <> "" Then
         If Application.CountIf(Columns(1), Cells(lngZeile, 1)) >= 3 Then _
            Cells(lngZeile, 1).Interior.ColorIndex = 3   '<== Farbe anpassen
      End If
   Next lngZeile
End Sub

Leerzellen werden nicht gefärbt.


GrußformelBeverly's Excel - Inn


  

Betrifft: AW: Dreifach und mehr färben von: Gregor
Geschrieben am: 10.01.2012 11:32:05

Karin vielen Dank, das dient mir sehr.

Gruss Gregor


Beiträge aus den Excel-Beispielen zum Thema "Dreifach und mehr färben"