Microsoft Excel

Herbers Excel/VBA-Archiv

Arbeitszeit je Monat summieren (exkl. Sonderfall)

Betrifft: Arbeitszeit je Monat summieren (exkl. Sonderfall) von: Dominic
Geschrieben am: 17.11.2014 09:30:46

Hallo,
ich habe ein Problem mit Excel2007. Und zwar hab ich eine Tabelle in der nach Datum Arbeitszeiten eingetragen sind im Format hh:mm.
Ich muss diese nun monatsweise addieren, also alle Stunden vom September, Oktober usw.
Das bekomme ich auch hin mit der Funktion:
{=SUMME(WENN(MONAT(A19:A504)=11;E19:E504;0))} // für November

Ich muss nun aber noch ausschließen, dass die Spalte der Abteilung, wo die Stunden gemacht werden, ein gewisses Event zeigt, denn das soll gesondert und nicht monatsweise abgerechnet werden. D.h. die Summe sollte nur berechnet werden, wenn in der Spalte F nicht "Event" steht.

Mein Versuch bisher war:
{=SUMME(WENN(UND(MONAT(A19:A502)=10;(F19:F502)<>"Event");E19:E502;0))}
Aber das gibt immer 0 zurück.

Ein anderer Versuch ist:
{=WENN(F19:F500="HMF";0;SUMME((WENN(MONAT(A19:A501)=9;E19:E500;0))))}
Aber das gibt mir die Stunden vom ganzen September zurück, wenn in der Spalte F nirgends das Event steht. Und sobald es irgendwo drin steht wird 0 zurückgegeben.

Wäre klasse, wenn mir jemand helfen könnte. Vielen Dank schonmal.

  

Betrifft: AW: Arbeitszeit je Monat summieren (exkl. Sonderfall) von: SF
Geschrieben am: 17.11.2014 09:34:35

Hola,

ungetestet:

=summenprodukt((Monat(A19:A502)=11)*(F19:F502<>"event")*(E19:E502))
Gruß,
steve1da


  

Betrifft: AW: Arbeitszeit je Monat summieren (exkl. Sonderfall) von: Dominic
Geschrieben am: 17.11.2014 10:15:13

Danke! Alles erledigt


  

Betrifft: am einfachsten mit PIVOTauswertung ... von: neopa C (paneo)
Geschrieben am: 17.11.2014 09:45:33

Hallo Dominic,

... dazu sind nur wenige Mausklicks notwendig, um gleich den aktuellste Auswertung für einen beliebigen Zeitraum natürlich auch monatsweise zu erhalten.

Mehr zu PIVOT sieh z.B. mal hier:

http://www.online-excel.de/excel/singsel.php?f=55

Gruß Werner
.. , - ...


  

Betrifft: AW: am einfachsten mit PIVOTauswertung ... von: Dominic
Geschrieben am: 17.11.2014 10:16:23

Jemand anderes hat mir geholfen es über ein Summenprodukt zu lösen. Danke trotzdem, ich werde es mir für die Zukunft mal ansehen!


 

Beiträge aus den Excel-Beispielen zum Thema "Arbeitszeit je Monat summieren (exkl. Sonderfall)"