Das Archiv des Excel-Forums

Erstellungsdatum

Bild

Betrifft: Erstellungsdatum
von: Karin

Geschrieben am: 13.10.2003 14:52:31

Guten Tag,
ich habe ein kleines Problem. Ist es möglich über eine Formel in einer Zelle das Erstellungsdatum anzuzeigen, falls möglich VBA zu umgehen?
Beispiel:
=WENN(A1<>"";HEUTE();"")

Nun ja, ohne HEUTE, eben das Erstellungsdatum.

Vielen Dank für den Tipp

Gruss

Karin
Bild


Betrifft: trotzdem mit VBA
von: ChrisL
Geschrieben am: 13.10.2003 14:56:37

Hi Karin

Ohne VBA geht es m.E. nicht.


Private Sub Workbook_BeforeSave(ByVal SaveAsUI As Boolean, Cancel As Boolean)
Worksheets("Tabelle1").Range("A1") = Date
End Sub


Sobald die Mappe gespeichert wird, wird in Zelle A1, Tabelle1 das aktuelle Datum eingetragen.

Alt + F11, links Doppelklick auf DieseArbeitsmappe, Code einfügen.

Gruss
Chris


Bild


Betrifft: vielen Dank!
von: Karin
Geschrieben am: 13.10.2003 15:00:31

Vielen Dank für die Antwort.
Dann werde ich mich wohl für VBA entscheiden ;o)
Gruss

karin


Bild


Betrifft: AW: Erstellungsdatum
von: Josef Ehrensberger
Geschrieben am: 13.10.2003 15:18:16

Hallo Karin,
du kannst eine Benutzerdefinierte Funktion benützen.

Z.B.:


Private Function GetCreateDate() As Date
GetCreateDate = ThisWorkbook.BuiltinDocumentProperties(11)
End Function


In ein Modul schreiben und in der Zelle inder das
erstellungsdatum stehen soll "=GetCreateDate()" .

Gruß Sepp


 Bild