Microsoft Excel

Herbers Excel/VBA-Archiv

bis zu 15 unterschiedliche Bedingte Formatierungen

Betrifft: bis zu 15 unterschiedliche Bedingte Formatierungen von: erichm
Geschrieben am: 04.11.2014 08:57:00

Hallo,

mit dem Problem komme ich nicht klar bzw. evtl. geht das vielleicht gar nicht:

Vorstellung (2)

 ABCDEFGHIJKLMNOP
1                
2                
3                
4Summe   1251141080131114210348764125100112199


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Von E4 bis P4 (= 15 Spalten) soll jede Zelle eine unterschiedliche (Bedingte) Formatierung erhalten, wenn ein Wert nur einmal vorkommt. Sobald ein Wert zwei- oder dreimal vorkommt, dann soll imer die gleiche bedingte Formatierung erscheinen.
Vielleicht geht das auch nur mit VBA?

Danke.

mfg

  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: mumpel
Geschrieben am: 04.11.2014 09:02:12

Hallo!

Welches Dateiformat benutzt Du? Bei den aktuellen Dateiformaten (xlsx, xlsm, xlsb) sind die bedingten Formatierungen nur durch den Arbeitsspeicher begrenzt. Bei Nutzung von XLS bleibt es bei 3 bedingten Formatierungen.

Gruß, René


  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: erichm
Geschrieben am: 04.11.2014 09:30:22

Dateiformat: xlsm;
Aber das Problem ist die Eingabemöglichkeit für die unterschiedlichen Ermittlungen; da sind die Eingebmöglichkeiten zu kurz.

mfg


  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: mumpel
Geschrieben am: 04.11.2014 09:45:53

Wie sieht denn Deine bedingte Formatierung aus, bzw. welche Formel und welches Format?


  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: erichm
Geschrieben am: 04.11.2014 10:43:28

Die Formatierung sollte pro Wert eine andere Farbenfüllung sein (egal welche).
Formeln probiere ich mit wenn bzw. zählenwenn; aber alles ohne Erfolg!
Ich dachte, wenn der Wert in der Zelle einmal oder mehrmals vorkommt kriege ich mit zählenwenn das hin.
Jetzt probiere ich es gerade mit einer Hilfszeile in dem ich die Werte aufsteigend sortiere und dann einen Bezug herstelle; aber das klappt auch noch nicht.

mfg


  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: Ewald
Geschrieben am: 04.11.2014 11:14:23

Hallo,

Zählenwenn ist schon der richtige Weg,

nur sollten die bedingten Formatierungen für alle Zellen einmal eingegeben werden.

die Zellen alle markieren und dann die Formatierung setzen.

=ZÄHLENWENN($C$38:$N$38;C38)=2

ist jetzt für SpalteC bis SpalteN

VBA wäre aber vielleicht die bessere Lösung

Gruß Ewald


  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: fcs
Geschrieben am: 04.11.2014 12:24:06

Hallo Erich,

die bedingte Formatierung für mehrfach vorkommende Werte jeweils unterschiedliche Farben darzustellen bekommt man nach meiner Einschätzung nicht ohne eine Hilfzeile.

Ich hab es jetzt so gelöst, dass identische Zahlenwerte jeweils eine andere Kennziffer von 1 bis 6 bekommen, einmal vorkommende die Ziffer 0. Diese Kennziffern werden dann in den bedingten Formatierungen ausgewertet.
Die Ziffer 0 für jede einzelne Zelle in E4:P4, die Ziffern 1 bis 6 jeweils für den gesamten Bereich E4:P4.

Gruß
Franz
https://www.herber.de/bbs/user/93533.xlsx


  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: erichm
Geschrieben am: 05.11.2014 07:06:39

DANKE für die Lösung funktioniert auch wunderbar!


  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: Daniel
Geschrieben am: 04.11.2014 11:17:07

Hi

propiers mal so:
in Zelle E3:P3 kommt folgende Formel (für E3) =Vergleich(E4;$E$4:$P$4;0)
in E3:P3 steht dann die relative Spaltennummer, in der der Wert das erste mal auftaucht (dh gleiche werte bekommen auch die gleiche Nummer)

für die Zellen E4:P4 richtest du dann 15 bedingte Formate ein mit jeweils der Formel:
=E3=1 : Farbe 1
=E3=2 : Farbe 2
=E3=3 : Farbe 3
...
=E3=15: Farbe 15


Gruß Daniel


  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: erichm
Geschrieben am: 04.11.2014 11:50:11

DANKE!
Das ist genau die Lösung :)

mfg


  

Betrifft: AW: bis zu 15 unterschiedliche Bedingte Formatierungen von: Daniel
Geschrieben am: 04.11.2014 12:34:11

Hi
bei dieser Lösung kann die Numerierung "springen", weil sie darauf basiert, in welcher Spalte der Wert das erste mal auftritt.
Wenn du eine lückenlose Numerierung von 1-x haben willst, dann nimm folgende Formeln:
in E3: 1
in F3 bis P3: =WENNFEHLER(INDEX($E3:E3;VERGLEICH(F4;$E4:E4;0));MAX($E3:E3)+1)
(Formel für F3)

Gruß Daniel


  

Betrifft: DANKE für die Ergänzung o.w.T. von: erichm
Geschrieben am: 05.11.2014 07:02:26

.....


  

Betrifft: Ich hingg halte die Beschreibung der Aufgabe ... von: Luc:-?
Geschrieben am: 04.11.2014 11:32:28

…immer noch für unzureichend, Erich;
es ist im ganzen bisherigen Thread nicht klarer geworden, was du mit …
„Von E4 bis P4 (= 15 Spalten) soll jede Zelle eine unterschiedliche (Bedingte) Formatierung erhalten, wenn ein Wert nur einmal vorkommt. Sobald ein Wert zwei- oder dreimal vorkommt, dann soll imer die gleiche bedingte Formatierung erscheinen“
…wirklich meinst.
Gruß, Luc :-?


  

Betrifft: AW: Ich hingg halte die Beschreibung der Aufgabe ... von: erichm
Geschrieben am: 04.11.2014 11:51:00

Mit der Lösung von Daniel klappts; so war's quasi gemeint.


 

Beiträge aus den Excel-Beispielen zum Thema "bis zu 15 unterschiedliche Bedingte Formatierungen"