Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema TextBox
BildScreenshot zu TextBox TextBox-Seite mit Beispielarbeitsmappe aufrufen

Problem mit Hyperlink

Betrifft: Problem mit Hyperlink von: Killerspots
Geschrieben am: 01.11.2020 20:22:50

Hallo in die Runde,


ich habe bereits parallel in einem anderen Excel-Forum gefragt, aber da bin ich bisher auch nicht auf eine Lösung gekommen und versuche es daher hier auch noch mal.

Ich habe ein kleines Problem, welches ich nicht verstehe und hoffe, ihr könnt mir Rat geben.


Ich möchte gern in einer Spalte B (zB. in Feld B2) einen bestehenden Text (Bsp: "0015-2019-001") mit einem Hyperlink zu einer externen Datei verknüpfen. Über einen Sverweis und eine Hilfsspalte C2 wird der entsprechende Link gesucht und dann über folgende Formel geladen und hinterlegt:


Code:

=HYPERLINK(SVERWEIS(C2;ExterneLinks!A$2:B$10;2;FALSCH);"0015-2019-001")



Das funktioniert auch soweit ganz gut. Gibt es eine gefundene URL im Blatt ExterneLinks in Spalte B zu dem gefundenen Text aus C2, dann wird diese hinter den Text 0015-2019-001 gelegt und öffnet beim Klick auch den Link. Gibt es keine hinterlegten Link, dann zeigt er mir #NV an, der auch nicht klickbar ist! Soweit so gut und nachvollziehbar.


Nun möchte ich über eine WennFehler-Funktion die Fehler auffangen, die keinen externen Link finden und wieder den Ursprungstext "0015-2019-001" in der Spalte B anzeigen lassen.

Das würde ich unter oben stehendem Beispiel folgendermaßen machen (wenn es hierfür keine URL gäbe)


Code:

=WENNFEHLER(HYPERLINK(SVERWEIS(C2;ExterneLinks!A$2:B$10;2;FALSCH);"0015-2019-001");"0015-2019-001")


Das funktioniert soweit auch, statt #NV zeigt er mir nun den Text "0015-2019-001" an. Nur wird der Hyperlink trotz eines Fehlers aktiviert (nicht wie oben beschrieben vorher, wo er nicht aktiviert wurde!), sondern verlinkt ohne einen gefundenen Link zu haben auf meine OneDrive-Seite und dort auf eine kryptische Seite, die nicht gefunden werden kann. Scheint, dass der Hyperlink trotz eines Fehlers aktiviert wird und die Funktion WennFehler nicht dafür sorgt, dass die Hyperlink-Funktion nicht aktiviert wird (was merkwürdig ist, weil es im ersten Test ja klappt).


Keine Ahnung, wo Excel plötzlich einen Link herzaubert.

Kann mir jemand folgen und mir hierbei einen heißen Tipp geben?


Im anderen Forum gab es den Vorschlag, dass man im Fehlerfall auf sich selbst verlinken solle. Aber auch das funktionierte nicht. Hat jemand hier eine gute Idee oder weiß, wie ich dieses "Feature" umgehen kann?


Tausend Dank und viele Grüße.

Betrifft: AW: Problem mit Hyperlink
von: Luschi
Geschrieben am: 02.11.2020 09:04:25

Hallo Killerspots,

WennFehler() kann erst reagieren, wenn Hyperlink() ein Ergebnis zurückliefert, der Hyperlink muß also aktiv bleiben, ansonsten würde dieses Prinzip beim 1. Fehler deaktiviert und der User könnte per Maus nie mehr den hyperlink bedienen.
Willst du es trotzdem realisieren, muß man mit Vba beim Öffnen der Excelmappe prüfen, ob der Hyperlink funktioniert und entsprechen die Formel mit oder ohne Hyperlink()-Funktion neu definieren.

Gruß von Luschi
aus klein-Paris

Beiträge aus dem Excel-Forum zum Thema "Problem mit Hyperlink"