Microsoft Excel

Herbers Excel/VBA-Archiv

Drucken, nur wenn Bedingung erfüllt ist!

Betrifft: Drucken, nur wenn Bedingung erfüllt ist! von: Josef_T
Geschrieben am: 11.07.2008 14:40:27

Guten Tag zusammen,

habe eine Stunde gegoogelt, aber nichts passendes gefunden.

Ich suche eine Möglichkeit mit einen Druckmodul, folgendes zu erreichen:

Wenn in dem Bereich der TB1: D3:K368 ein Eintrag größer Null ist, dann drucke mir die jeweiligen Zeilen, von A3:K368, die größer Null sind.
Die Zeile 1 und 2, (A1:K2) sollen immer gedruckt werden.

Kann mir bitte jemand behilflich sein?

Gruß
Josef

  

Betrifft: AW: Drucken, nur wenn Bedingung erfüllt ist! von: Yal
Geschrieben am: 11.07.2008 16:26:44

Hallo Josef,

ich würde so vorgehen:
_ Druckbereich auf A1:K368 festlegen,
_ Zeilen 1:2 als Wiedeholung in dem Druck (Menü "Datei >> Seiten einrichten")
_ eine zusätzliche Spalte L mit eine Formel wie =SUMMEWENN(D3:K3;">0";D3:K3)>0
_ und ein Autofilter auf der Spalte L

Auf "WAHR" filtern und drucken.
Da werden nur die gefilterte Zeile gedruckt.

Viel Erfolg
Yal


  

Betrifft: AW: Drucken, nur wenn Bedingung erfüllt ist! von: Josef_T
Geschrieben am: 11.07.2008 17:43:45

Hallo Yal,

erst mal Danke für Deine Hilfe.

Yal, dass mit dem Autofilter hatte ich auch schon versucht. Kann es sein, dass es deshalb nicht funktioniert, weil in allen Zellen Formeln stehen?

Gruß Josef


  

Betrifft: AW: Drucken, nur wenn Bedingung erfüllt ist! von: Yal
Geschrieben am: 11.07.2008 17:47:28

Hallo,

Eigentlich nicht. Es funktioniert, normalerweise, immer.

Der Autofilter richtet auf das Ergebnis in den Zellen, egal ob es Werte sind oder Formeln.

Bei manche Version von Excel habe ich festgestellt, dass der Autofilter die Zelle nur bis erste Leerzelle wahrnimmt. Also zuerst die Spalte L markieren, dann Autofilter aktivieren und dann filtern.

Viel Erfolg
Yal


  

Betrifft: Jetzt funktioniert es von: Josef_T
Geschrieben am: 11.07.2008 18:14:27

Hallo Yal,

genau das war der Punkt, "Spalte L markieren" .

Funktioniert alles einwandfrei. Danke sehr.

Gruß
Josef


 

Beiträge aus den Excel-Beispielen zum Thema "Drucken, nur wenn Bedingung erfüllt ist!"