Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt mit benannten Bereichen

Betrifft: Summenprodukt mit benannten Bereichen von: Carsten
Geschrieben am: 30.07.2014 16:46:26

Hallo alle zusammen,

ich habe folgendes Problem:

Ich habe alle meine Spalten benannt. Jetzt möchte ich mit folgende Operation ausführen:
=SUMMENPRODUKT((Sector=D10)*$AC$10:$AJ$5009)+SUMMEWENN(Sector,D10,Specific_Return)

Die Spalten AC bis AJ sind ja alle benannt, aber eben Spaltenweise. Wie kann ich diese komplette Matrix mit meinen Benannten Bereichen abbilden?

Grüße,
Carsten

  

Betrifft: warum willst Du das denn unbedingt tun ? :.. von: neopa C (paneo)
Geschrieben am: 30.07.2014 17:26:20

Hallo Carsten,

... Du würdest damit mE nur die Auswertungsformel verkomplizieren. Warum also?
Alternativ definiere für den Bereich $AC$10:$AJ$5009 auch noch einen Namen.


Gruß Werner
.. , - ...


  

Betrifft: AW: warum willst Du das denn unbedingt tun ? :.. von: Carsten
Geschrieben am: 30.07.2014 17:31:04

Hallo Werner,

danke für die Antwort,

Intension ist, dass die Bereiche bei mir per VBA Skript automatisiert benannt werden. Daher hätte ich dort gerne Kontinuität und möchte ungern diesen Bereich per Hand definieren, da der Bereich in dem diese Informationen stehen sich ebenfalls verschieben kann.

Daher wäre mir die Idee mit den benannten Bereich lieber.

Grüße,
Carsten


  

Betrifft: warum aber Namen mit VBA festlegen ? :.. von: neopa C (paneo)
Geschrieben am: 31.07.2014 15:47:55

Hallo Carsten,

... ich glaube (weiß es jetzt allerdings nicht zu 100%) das es schon in der Version 2007 die Funktion "Als Tabelle formatieren" gab, die automatisch dass standardmäßig automatisch vornimmt. Die sind dann auch immer dynamisch an die Tabellengröße angepasst.


Gruß Werner
.. , - ...


  

Betrifft: =SUMMENPRODUKT((Bereich1:Bereich8=D10)*... von: NoNet
Geschrieben am: 30.07.2014 18:26:32

Hallo Carsten,

falls Du die Spalten mit den Namen "Bereich1" bis "Bereich18" benamt hast, dann kannst Du diese Namen auch in den Funktionen verwenden, z.B. :

=SUMMENPRODUKT((Bereich1:Bereich8=D10)*(Bereich11:Bereich18))

Gruß, NoNet


  

Betrifft: AW: =SUMMENPRODUKT((Bereich1:Bereich8=D10)*... von: Carsten
Geschrieben am: 31.07.2014 09:13:35

Hallo NoNet,

war gestern im Meeting und danach hab ich Feierabend gemacht.
Danke für den Hinweis.
Es sollte nicht problematisch sein, dass die Bereiche nicht durchnummeriert sind oder? Also die bereiche sind nach deren Überschriften benannt.

Grüße,
Carsten


  

Betrifft: =SUMMENPRODUKT((Anfang:Ende=D10)*... von: NoNet
Geschrieben am: 31.07.2014 11:57:39

Hallo Carsten,

die Bereiche müssen nicht numeriert benamt sein, es würden z.B. auch folgende Benamungen funktionieren :

=SUMMENPRODUKT((Anfang:Ende=D10)*(Januar:Dezember))
=SUMMENPRODUKT((Irgendwie:Irgendwo=D10)*(Carsten:NoNet))
=SUMMENPRODUKT((Anton:Zeppelin=D10)*(Von:Bis))

Gruß, NoNet


 

Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt mit benannten Bereichen"