Microsoft Excel

Herbers Excel/VBA-Archiv

Variable Summenformel

Betrifft: Variable Summenformel von: KlausD
Geschrieben am: 23.11.2014 18:44:51

Hallo,
ich habe folgende Frage:
Ich habe eine Zeile mit Werten, die aufsummiert werden sollen:
=Summe(A1:A12)
Nun hätte ich gerne die Möglichkeit, die Anzahl der Zellen, die summiert werden sollen,variabel zu gestalten:
=Summe(A1:Ax)
und dieses x steht dann in einer anderen Zelle, auf die sich meine Summenformel bezieht.
Ich hoffe, ich konnte mich verständlich machen.
Im voraus vielen Dank für alle sachdienlichen Hinweise.
Klaus

  

Betrifft: =Indirekt() von: ransi
Geschrieben am: 23.11.2014 18:49:05

Hallo Klaus,

Schau dir mal =indirekt() an.
Damit geht das.

ransi


  

Betrifft: AW: =Indirekt() von: KlausD
Geschrieben am: 23.11.2014 19:08:05

Hallo, ransi,
ich denke eigentlich auch, dass das auch mit Indirekt() funktionieren müsste - aber irgendwie kapier ich diese Funktion nicht richtig, krieg's jedenfalls nicht hin.
Aber mit dem Tipp von Tino ist mir geholfen.
Danke trotzdem,
Klaus


  

Betrifft: AW: =Indirekt() von: ransi
Geschrieben am: 23.11.2014 19:34:22

HAllo Klaus

Fürs Archiv:
Tabelle1

 ABC
11155
22
33
44
55
66
77
88
99
1010
11   

Formeln der Tabelle
ZelleFormel
B1=SUMME(INDIREKT("A1:A" &C1))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4


ransi


  

Betrifft: AW: =Indirekt() von: KlausD
Geschrieben am: 23.11.2014 21:53:16

Hallo, ransi,
tatsächlich, auch das wäre eine Lösung für mein Problem.
Vielen Dank für diese Nachhilfe in Sachen "Indirekt"!
Klaus


  

Betrifft: AW: Variable Summenformel von: Tino
Geschrieben am: 23.11.2014 18:55:18

Hallo,
vielleicht so.

 ABC
11155
22  
33  
44  
55  
66  
77  
88  
99  
1010  

Formeln der Tabelle
ZelleFormel
B1=SUMME(A1:INDEX($A:$A;C1))


Gruß Tino


  

Betrifft: AW: Variable Summenformel von: Klausd
Geschrieben am: 23.11.2014 19:06:05

Hallo, Tino,
super, genau das hab' ich gesucht!
Vielen Dank!
Klaus


 

Beiträge aus den Excel-Beispielen zum Thema "Variable Summenformel"